locked
Microsoft Translator API Key (client ID + secret) does not work on Wordfast Anywhere RRS feed

  • Question

  • I went to the Azure Marketplace website and followed all the instructions from http://wiki.memsource.com/wiki/Microsoft_Translator and http://wordfast.fi/blog/cat-tools/2012/05/01/new-microsoft-translator-api-with-client-id-and-client-secret/ to subscribe to Microsoft Translator and obtain an API key (client ID + secret) for use in Wordfast Anywhere.

    Even after several attempts I still can get Microsoft Translator to work in WFA. I've entered the clientID and Client secret in the machine translation setup in WFA but, when I test it, I receive the message: "Test Failed no response from the MT engine the provider has been disabled."

    When I'm signed in on Azure Marketplace and when I click on "Data" I get a screen showing that I'm subscribed to Microsoft Translator. Yet, when I click on "My Applications" under "My Account," I get a screen saying "You do not currently have any application subscriptions;" when I click on "My Data." then Microsoft Translator is listed.

    Can somebody help me in solving this problem? Thanks.

    Wednesday, December 5, 2012 3:30 PM

All replies

  • Friday, December 7, 2012 3:52 PM
  • Finally got it to work. Thanks.

    Daniel


    Daniel Morin Cogitaction Communication Inc.

    Friday, December 7, 2012 5:07 PM
  • Hi,

    How did you get it to work? Because I went through the whole process step-by-step, as listed in that link, and I still get that same message when setting up my MT in WFA... The weird thing is that I've worked with WFA practically since it came out, and I had never had to type in any IDs and secrets, yet the MT worked fine. For the last week or so, it's like it's been disabled. So I set everything up as the instructions say, but to no effect...

    Can anyone help? Thanks!

    Saturday, October 4, 2014 11:35 AM
  • Same problem. Done all the steps, application registered and everything, but when I enter the client ID and the Secret IT and I test it, I always gat that error message...
    Wednesday, October 8, 2014 11:56 AM
  • I'm having the same problem also. Any help please!

    Just above the fields for the client ID and client secret in WFA, I have this warning "Caution: do not work with HTTPS protocol". I don't know if this can cause the problem.

    • Edited by zarashnikov Monday, September 14, 2015 10:10 AM
    • Proposed as answer by anhtuan66 Friday, October 30, 2015 5:01 AM
    • Unproposed as answer by anhtuan66 Friday, October 30, 2015 5:02 AM
    Sunday, September 13, 2015 1:06 PM