locked
"The specified path is not a metabase path." RRS feed

  • Question

  • We are installing Microsoft Dynamics CRM 4.0 together with Microsoft SQL Server 2008 and SQL Server 2008 Reporting Services all on the same server and we receive the following error message:

    "The specified path is not a metabase path." Platform Error: System.Exception: Action Microsoft.Crm.Setup.Server.RSConfigAction failed. ---> System.ArgumentException: The specified path is not a metabase path.

    One workaround is as below

    In Windows Server 2003, follow these steps:
    1. Click Start, click Run, and then type inetmgr.
    2. Expand the server name, right-click Web Sites, click New, and then click Web Site.
    3. Enter a description for the site, and then click Next.
    4. Enter the port number of the report server Web service. For example, enter 8181, and then click Next.
    5. Enter a path for the Web site, and then click Next.
    6. On the Permissions page, click Next.
    7. Click Finish.

    I am currently stuck on the fifth step. After entering the port number in my case 800, what path should i enter? This path is to what folder? There is no reporting service folder! so should i just create any empty folder?

    If i install the CRM on another server and connect it to this one which has sql server 2008 and reporting will the problem still stay? I cannot change the port from 800 to 80 as it used by symantec endpoint

    Can CRM web application be installed with exchange and sharepoint on a different port on the same server.

    This is a bit urgent

    Thank,
    Sheldon

     


    MVP - Most Valuable Primate
    Wednesday, July 22, 2009 4:51 PM

Answers

All replies

  • Hi Sheldon.   Ok, if your installing all this in the same server, it's not going to matter if you can get it installed.   That's too much for the average piece of hardware to begin with.

    http://support.microsoft.com/kb/957053

    The default crm port is 5555.  
    800 seems kind of low range.  
    800 has been used for attacks in the past.

     

    Wednesday, July 22, 2009 5:37 PM
    Moderator
  • Fine i will change the port 800 to anything but that is not the issue i am having here, the url you have given me is what i already visited. Im not sure if you understood my problem i have a problem understanding the Issue 6 of CRM; im stuck at step 5.


    MVP - Most Valuable Primate
    Wednesday, July 22, 2009 8:39 PM
  • Hi Sheldon,

    the Path is the Path, were the iis looks for the files, you want to use for this site. It is a path like this c:\inetpub\wwwroot\mysite.
    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Thursday, July 23, 2009 6:09 AM
  • The physical path doesn't matter; all the steps above are doing is putting the metadata information into IIS that CRM expects, and the physical path is irrelevant.

    Even after completing thses steps you can still get the problem if the default web-site is not on port 80. See http://mscrmuk.blogspot.com/2009/06/report-server-location-and-error.html for how to cope with this
    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Thursday, July 23, 2009 9:35 AM
    Moderator
  • Thanks for the reply, yup i found that that workaround was not that beneficial as it still needed port 80, since Report server did not show up in IIS just changed it under configuration setting hoping that it wont affect symantec; it didnt and it worked.
    MVP - Most Valuable Primate
    Friday, July 24, 2009 10:41 PM
  • Hi Everyone

    Iam installing Microsoft Dynamics CRM 4.0 together with SQL Server 2008 Reporting Services on the same server and Iam geting the following error message:
    Error| Failed to set Reporting Services Web site metabase property UploadReadAheadSize.
    11:21:14|  Error| System.Exception: Publishing CRM reports failed. ---> System.Runtime.InteropServices.COMException
    (0x80070003): The system cannot find the path specified.


    Can anyone suggest me the solution?

    Thanks
    Tuesday, November 24, 2009 6:24 AM