locked
Errors when running Picklist Synch on 2010/2011 integration RRS feed

  • Question

  • I am setting up the adapter to run an integration between GP 2010 and CRM 2011.  I have created the integration and launched the synchronization utility. 

    When the results post, I received two "succeed" Multiple "Failed" and a number of errors on the various fields such as

    "Unable to contact CRM Metadata Soap Client. Picklist for Entity account is not synced. Exception: Exception while trying to create an instance of the Dynamics CRM metadata service"

    and

    Unable to retreieve Referenc Key xxx using the Microsoft Dynamics GP2010 Adapter. Exception: Exception has been thrown by the target of an invocation.

    Any ideas what could be causing these errors?  It worked on ERPsystemuser and Unitgroup but failed on Account, Producttype code, and others.

    Can't be a permissions issue if some worked, right?

    Friday, April 15, 2011 5:26 PM

Answers

  • Wound up being a database version mismatch issue.  Nothing to do with the integration tool at all.  Seems to be running now.
    • Proposed as answer by thehetz Tuesday, April 19, 2011 5:03 PM
    • Marked as answer by Jamie MileyModerator Tuesday, February 14, 2012 4:40 PM
    Tuesday, April 19, 2011 4:59 PM

All replies

  • I wouldn't think so.  When I worked with this program it became apparent quickly that we could have bought scribe easily with the cost of the man hours it took us to get the thing set up.  I would check out scribe for GP to CRM integration.   www.scribesoft.com  I know it has gone through two iterations since I used it, but really remembered disliking that tool.  The customization merge was another point of headache as I recall too.
    Jamie Miley
    http://mileyja.blogspot.com
    Linked-In Profile
    Follow Me on Twitter!
    Friday, April 15, 2011 5:53 PM
    Moderator
  • Scribe is great but pretty pricey and it's simply not in their budget. We're doing a number of other things along with the CRM.  We had the connector working in the previous version without too much trouble.  That's why I"m confused about this.
    Friday, April 15, 2011 6:36 PM
  • There are several reasons that you could be seeing these errors.

    Did you supply CRM Deployment Administrator credentials when prompted for Credentials in the Sync utility?  And have you set up the GP user properly in the Dynamics Security console?  These settings are outlined in the Connector's documentation.

    Were you able to successfully test your settings for the CRM adapter?  And did the CRM Customization utiltiy succesfully run after importing the CRM solution?

    Were you able to sucessfully test the settings for the GP adapter?  Have tried restarting the GP Service Process Host NT service?

     

    Tuesday, April 19, 2011 2:59 PM
  • Wound up being a database version mismatch issue.  Nothing to do with the integration tool at all.  Seems to be running now.
    • Proposed as answer by thehetz Tuesday, April 19, 2011 5:03 PM
    • Marked as answer by Jamie MileyModerator Tuesday, February 14, 2012 4:40 PM
    Tuesday, April 19, 2011 4:59 PM
  • Glad to hear that this has been resolved and thanks for responding :)
    Tuesday, April 19, 2011 5:03 PM