locked
Scheduled backups do not happen - no error messages RRS feed

  • Question

  • WHS SP3, two Win7 computers, both scheduled to be backed up nightly. One of the computers does not get backed up, but there are no errors and nothing in the list when I "view backups". The only way I know that it is not working (other than looking) is when WHS starts warning me that a backup has not occurred in n days. I can manually backup the computer - no problem. 

    I used to get the error about not being able to take a snapshot, but at least there would be an entry in view backups that it had failed and here was why. Now, no entry and no backup and no explanation.

    Steve Woodward
    Tuesday, February 23, 2010 6:09 PM

All replies

  • Try narrowing down the backup window to a time when you are around and observe what happens.  Also you should check the event logs on the faulty machine to see what is happening when an automatic backup happens:
    http://windows.microsoft.com/en-us/windows7/Open-Event-Viewer


    The most common problem is an error on the hard disk.  You should check all your disks fully to be sure:
    http://windows.microsoft.com/en-US/windows-vista/Check-your-hard-disk-for-errors
    select both Automatically fix file system errors and Scan for and attempt recovery of bad sectors.

    Cheers,
    Al


    --
    Wednesday, February 24, 2010 1:38 AM
  • If you can back up manually, there's nothing wrong with your client computer's hard disks. So is it possible that you're turning the computer off at night? Is it connected to your network through a wired connection, or wifi? Do you have a power saving mode enabled? Do you have the connector set to "Wake this computer for backup"? Is the computer connected to a UPS?
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, February 24, 2010 4:35 PM
    Moderator
  • Thanks for the replies and my apologies for not responding sooner - I had requested notification when someone responded, but that did not happen.

    I will look at the event logs. A filter of "Windows Home Server" in the application and system logs shows no entries. There are a couple of random controller errors, but nothing during the times when WHS is scheduled to do backups. 

    The computer is on 24/7 and uses a wired connection. It uses a balanced plan with sleep after 30 minutes, but hibernation is not allowed. The computer is connected to a UPS. I do notice in looking at system events that the computer never stays in sleep mode for more than a few seconds.

    How do I check the setting to "Wake this computer for backup"? I haven't seen that one.

    thanks, ~Steve

    Steve Woodward
    Friday, March 5, 2010 5:44 AM
  • ...
    How do I check the setting to "Wake this computer for backup"? I haven't seen that one.

    You're going to wish you hadn't asked... :) Just right click the Windows Home Server icon in the system tray.

    UPS: try disconnecting the computer from the UPS (i.e. unplug the USB cable). Sometimes being connected to a UPS will make a desktop computer think it's running on battery, and a computer on battery will not wake to back up.

    I'm not on the WHS team, I just post a lot. :)
    Friday, March 5, 2010 3:43 PM
    Moderator
  • Doh! But that setting was checked anyway. 

    If the computer never goes to sleep, it wouldn't have to wake up would it?

    It's a mystery: why is there nothing in the log to say that the backup failed? I guess the logical answer would be that it never happened. I have confirmed that it is scheduled to be backed up every night.

    So tonight I'll take it off the UPS and if that doesn't work, I'll remove the computer from WHS and install it again. 

    Thanks, ~Steve

    Steve Woodward
    Friday, March 5, 2010 3:57 PM
  • I should have said "A computer will not back up automatically if it thinks it's running on battery". 
    I'm not on the WHS team, I just post a lot. :)
    Friday, March 5, 2010 4:31 PM
    Moderator