locked
Using NAT throws the head node connection down RRS feed

  • Question

  • Hello,

    I have a cluster that works fine with topology 1, but NAT is turned off. If I configure network to provide the compute nodes with access to the internet using NAT I experience intermittent problems in the connection. I lose the remote desktop session every few minutes.

    I need to access the world from the nodes because I need to use a license server that is outside.

    What can I check to find a solution to this?

    Thanks

    Thursday, November 11, 2010 6:28 PM

All replies

  • Is your cluster on a network where there might be some network restrictions that are blocking or preventing your head node from being a "Boundary Server" ? 

    Are you seeing anything in the Event Logs on your Head Node that may be able to shed more light on this problem?  If your head node is dropping connections with NAT turned on then perhaps something is there.

    Just some ideas.

    Mark

    Saturday, November 13, 2010 12:09 AM
  • Hello,

    I have a similar problem. Two network connections with topology 1, NAT on and if the private NIC is enabled I can't connect to my head node. The first NIC is connectect to our enterprise network with static IP. When I disable the 2nd NIC for private I can establish a RDP session. When I then enable the private NIC all is OK, but after a reboot I haven't RDP.

    What can I check?

    Thanks!

    Thomas

    Wednesday, December 22, 2010 11:39 PM
  • Troubleshooting NAT problems can be difficult in certain environments (including those at Microsoft where IPSec and multitudes of network security policies are in full force).

    Do any of the HPC pack network diagnostic tests fail (DNS, AD connectivity, ping, etc.)? 

    One thing to try is changing your private network definition to a more traditional definition of 192.168.0.1/255.255.255.0 (or perhaps a more encompassing subnet mask like 255.255.0.0).  You would also need to manually adjust your DHCP scope settings appropriately in the network configuration wizard.

    Thanks,
    --Brian

    Sunday, January 2, 2011 9:15 AM