locked
Error after importing an organisation crm 2011 RRS feed

  • Question

  • Hi I have imported an exsisting organisation from live server to UAT server but when i try and browse to the organisation i get the following error message

    An error has occurred.

    Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.

    I am trying to find a solution to this problem but am unable to find anything online.

    Can someone please help!

    Thanks


    amandip
    Wednesday, December 28, 2011 11:59 AM

Answers

  •  

    Yes I think I know what the problem might be. Install the latest RU, the error related with CrmMultiOrgCache, means there are stuff cached on the database which you don't have.

    Install the Rollup 20 and should go away.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    • Marked as answer by Amandip Wednesday, December 28, 2011 3:50 PM
    Wednesday, December 28, 2011 1:13 PM

All replies

  • Hi Amandip,

    You need to check the logs, windows logs and then CRM logs, enabling tracing.

    This will help identifying why is it failing.

    Let us know what is the exact error message on the logs, so we can help further.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    Wednesday, December 28, 2011 12:22 PM
  • Hi nrodi,

     

    I have enabled errors via the web config and am getting more information which is

    An error has occurred.

    Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally, you can contact Microsoft Support.

    Microsoft.Crm.CrmException: An unexpected error occurred. at Microsoft.Crm.Application.Platform.ServiceCommands.PlatformCommand.XrmExecuteInternal() at Microsoft.Crm.Application.Platform.ServiceCommands.RetrieveMultipleCommand.Execute() at Microsoft.Crm.Application.Caching.CustomResourceLoader.GetCustomResources(IOrganizationContext context, Int32 cacheKey) at Microsoft.Crm.Application.Caching.CustomResourceLoader.LoadCacheData(Int32 key, IOrganizationContext context) at Microsoft.Crm.Caching.CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context) at Microsoft.Crm.Application.ResourceManager.CustomResourceManager.TryGetCultureString(String name, CultureInfo culture, Boolean getSystemString, IOrganizationContext context) at Microsoft.Crm.Application.ResourceManager.CustomResourceManager.TryGetCultureString(String name, CultureInfo culture, IOrganizationContext context) at Microsoft.Crm.Application.ResourceManager.BasicResourceManager.GetCultureString(String name, CultureInfo culture, IOrganizationContext context) at Microsoft.Crm.Web.GlobalBase.BuildErrorHandlerUri(String errorHandlerPage, ErrorInformation errorInformation) at Microsoft.Crm.MainApplication.GenerateDevErrorPage(ErrorInformation errorInformation) at Microsoft.Crm.MainApplication.HandleError(ErrorInformation errorInformation) at Microsoft.Crm.MainApplication.Application_Error(Object sender, EventArgs eventArguments)

    I have checked the trace and no error is comming up on this apart from the language being changed and the database name being changed which i googled and found that this wasnt an error more for information.

    I will check the Widows log and the crm logs to see if i can locate the issue.

    Do you know what the above error means?

    Thanks


    Amandip
    Wednesday, December 28, 2011 12:54 PM
  •  

    Yes I think I know what the problem might be. Install the latest RU, the error related with CrmMultiOrgCache, means there are stuff cached on the database which you don't have.

    Install the Rollup 20 and should go away.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    • Marked as answer by Amandip Wednesday, December 28, 2011 3:50 PM
    Wednesday, December 28, 2011 1:13 PM
  • Hi nrodri,

    Thanks for the reply. I have already installed RU 5.0, would this not have already fixed the problem?


    Amandip
    Wednesday, December 28, 2011 1:52 PM
  • Sorry didn't realise this was CRM 2011

    did you install the RU 5 after the database imported?

    Please try an IIS reset, if you use a role based installation do an iisreset on all servers.

    EDIT: btw when you say imported, you used the deployment manager and imported the database? or you did a backup/restore of the database?

     


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    • Edited by nrodri Wednesday, December 28, 2011 2:23 PM
    Wednesday, December 28, 2011 2:05 PM
  • No i installed ru 5.0 before then imported the organisation. I have since deleted all organisations (as they were not required) and then removed the organisation again and then imported the organisation again.  I have also just installed the update again and restarted the server( this is a test server and is a single server setup).

    I have just tried it again and it is not working am still getting the same error. Can you suggest something else that i could try? I have looked at the logs and there was something in there that suggested that the id did not exsist.

    >Crm Exception: Message: User Was Not Found, ErrorCode: -2147220969
    [2011-12-28 12:48:45.043] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   15 |Category: Platform |User: 00000000-0000-0000-0000-000000000000 |Level: Info | MiniDump.CreateDumpInternal
     at MiniDump.CreateDumpInternal(MiniDumpReasons reason, Exception exception)
     at CrmException..ctor(String message, Exception innerException, Int32 errorCode, Boolean isFlowControlException, Boolean enableTrace)
     at CrmException..ctor(String message, Exception innerException, Int32 errorCode, Boolean isFlowControlException)
     at CrmException..ctor(String message, Int32 errorCode)
     at ServerLocatorService.GetDefaultOrganization(String authenticationInfo)
     at BaseCrmIdentity.RecognizeCrmUser(Guid organizationId)
     at WindowsIdentityAuthorizationManager.Authenticate(OperationContext operationContext)
     at WindowsIdentityAuthorizationManager.CheckAccessCore(OperationContext operationContext)
     at AuthorizationBehavior.Authorize(MessageRpc& rpc)
     at ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
     at MessageRpc.Process(Boolean isOperationContextSet)
     at ChannelHandler.DispatchAndReleasePump(RequestContext request, Boolean cleanThread, OperationContext currentOperationContext)
     at ChannelHandler.HandleRequest(RequestContext request, OperationContext currentOperationContext)
     at ChannelHandler.AsyncMessagePump(IAsyncResult result)
     at AsyncThunk.UnhandledExceptionFrame(IAsyncResult result)
     at AsyncResult.Complete(Boolean completedSynchronously)
     at ScheduledOverlapped.IOCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* nativeOverlapped)
     at IOCompletionThunk.UnhandledExceptionFrame(UInt32 error, UInt32 bytesRead, NativeOverlapped* nativeOverlapped)
     at _IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)
    >MiniDump: TraceDirectory setting not set or missing. Defaulting to temporary folder.
    [2011-12-28 12:48:45.044] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   15 |Category: Platform.Sdk |User: 00000000-0000-0000-0000-000000000000 |Level: Error | ServiceModelTraceRedirector.TraceData
     at ServiceModelTraceRedirector.TraceData(TraceEventCache eventCache, String source, TraceEventType eventType, Int32 id, Object data)
     at TraceSource.TraceData(TraceEventType eventType, Int32 id, Object data)
     at DiagnosticTrace.TraceEvent(TraceEventType type, Int32 code, String msdnTraceCode, String description, TraceRecord trace, Exception exception, Object source)
     at ExceptionUtility.TraceHandledException(Exception exception, TraceEventType eventType)
     at MessageRpc.ProcessError(Exception e)
     at MessageRpc.Process(Boolean isOperationContextSet)
     at ChannelHandler.DispatchAndReleasePump(RequestContext request, Boolean cleanThread, OperationContext currentOperationContext)
     at ChannelHandler.HandleRequest(RequestContext request, OperationContext currentOperationContext)
     at ChannelHandler.AsyncMessagePump(IAsyncResult result)
     at AsyncThunk.UnhandledExceptionFrame(IAsyncResult result)
     at AsyncResult.Complete(Boolean completedSynchronously)
     at ScheduledOverlapped.IOCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* nativeOverlapped)
     at IOCompletionThunk.UnhandledExceptionFrame(UInt32 error, UInt32 bytesRead, NativeOverlapped* nativeOverlapped)
     at _IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)
    ><TraceRecord xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord" Severity="Error"><TraceIdentifier>http://msdn.microsoft.com/en-GB/library/System.ServiceModel.Diagnostics.TraceHandledException.aspx</TraceIdentifier><Description>Handling an exception.</Description><AppDomain>/LM/W3SVC/1/ROOT-1-129695485311932000</AppDomain><Exception><ExceptionType>Microsoft.Crm.CrmConfigObjectNotFoundException, Microsoft.Crm, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35</ExceptionType><Message>User Was Not Found</Message><StackTrace>   at Microsoft.Crm.ServerLocatorService.GetDefaultOrganization(String authenticationInfo)
    >   at Microsoft.Crm.Authentication.BaseCrmIdentity.RecognizeCrmUser(Guid organizationId)
    >   at Microsoft.Crm.Authentication.WindowsIdentityAuthorizationManager.Authenticate(OperationContext operationContext)
    >   at Microsoft.Crm.Authentication.WindowsIdentityAuthorizationManager.CheckAccessCore(OperationContext operationContext)
    >   at System.ServiceModel.Dispatcher.AuthorizationBehavior.Authorize(MessageRpc&amp;amp; rpc)
    >   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc&amp;amp; rpc)
    >   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</StackTrace><ExceptionString>Microsoft.Crm.CrmConfigObjectNotFoundException: User Was Not Found
    >   at Microsoft.Crm.ServerLocatorService.GetDefaultOrganization(String authenticationInfo)
    >   at Microsoft.Crm.Authentication.BaseCrmIdentity.RecognizeCrmUser(Guid organizationId)
    >   at Microsoft.Crm.Authentication.WindowsIdentityAuthorizationManager.Authenticate(OperationContext operationContext)
    >   at Microsoft.Crm.Authentication.WindowsIdentityAuthorizationManager.CheckAccessCore(OperationContext operationContext)
    >   at System.ServiceModel.Dispatcher.AuthorizationBehavior.Authorize(MessageRpc&amp;amp; rpc)
    >   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc&amp;amp; rpc)
    >   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)</ExceptionString></Exception></TraceRecord>


    Amandip
    Wednesday, December 28, 2011 2:26 PM
  •  

    The error message you showing is now different.

    User is not found.

    Run internet explorer with an account which you are sure that is configured in the system and try again.

    When I referred to install the RU 5 was to be done after the import, this perhaps have fixed the issue.


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com
    • Edited by nrodri Wednesday, December 28, 2011 3:12 PM
    Wednesday, December 28, 2011 2:50 PM
  • Hi,

    I have removed the solution again and reimported but i removed the database this time and then restored from backup (prior to the import altogeather) and i then did the import again. I am now getting another error, the issue with the user ahs been resolved.

     

    >exit: ConvertMessageAndErrorCode: errorCode: 0x80040216; message: System.MissingMethodException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #BA67421A


    Amandip
    Wednesday, December 28, 2011 3:15 PM
  • Hi Amandip,

    I think you have passed the first error related to your question and I believe I may have answered with installing rollup 5 after the import.

    I believe you keep doing new things and keep getting new errors, the problem is completely different now. Is obviously very difficult to help you on this circumstance, if any of my posts were helpful please vote as helpful if any had the answer to your original problem which is the first error you posted, please mark as answer, you can mark as answer as many as you want on a single thread.

    Thanks

     


    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    • Edited by nrodri Wednesday, December 28, 2011 3:24 PM
    Wednesday, December 28, 2011 3:23 PM