locked
CRM 4.0 Emails not sending RRS feed

  • Question

  • Hello all,

    We are not able to send any emails at all through CRM. The email router is setup and configured and this was working up until a few days ago. We can't manually send emails and no emails are sent through workflows. I tried to send an email about a lead and went back and checked it and it says the email was not submitted for delivery.

    Does the CRM email service need to run all the time? When I try to start it, it pops up an alert that says "the service started and then stopped. Some services stop automatically if they have no work to do, for example, blah blah...

    Also when I test account access it says the configuration parameters cannot be verified if the E-mail Router service is not running. But, like I said, when I try to start it, it just stops immediately with that message. I have restarted IIS and restarted the server, but still get the same results. If anyone has any tips on how to fix this, that would be great!

    Thanks in advance,
    Mike
    Wednesday, May 27, 2009 4:37 PM

Answers

All replies

  • Mike,

    Attempt to restart the Email Router service and check the event log to see if any errors occurred at the same time.  There should be a more descriptive error message in the event log.
    • Marked as answer by Jim Glass Jr Wednesday, May 27, 2009 5:59 PM
    • Unmarked as answer by Mike McCoy Wednesday, May 27, 2009 6:27 PM
    Wednesday, May 27, 2009 4:45 PM
  • Hello,

    I followed Richard suggestion and this is what is the event viewer.


    #16192 - The E-mail Router service could not run the service main background thread. The E-mail Router service cannot continue and will now shut down. System.Configuration.ConfigurationErrorsException: The E-mail router service cannot access system state file Microsoft.Crm.Tools.EmailAgent.SystemState.xml. The file may be missing or may not be accessible. The E-mail Router service cannot continue and will now shut down. ---> System.Xml.XmlException: Root element is missing.
       at System.Xml.XmlTextReaderImpl.Throw(Exception e)
       at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
       at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
       at System.Xml.XmlTextReaderImpl.Read()
       at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
       at System.Xml.XmlDocument.Load(XmlReader reader)
       at System.Xml.XmlDocument.Load(String filename)
       at Microsoft.Crm.Tools.Email.Providers.ConfigFileReader..ctor(String filePath, ServiceLogger serviceLogger)
       at Microsoft.Crm.Tools.Email.Providers.SystemState.Initialize(ServiceLogger serviceLogger)
       at Microsoft.Crm.Tools.Email.Providers.SystemState..ctor(ServiceLogger serviceLogger)
       at Microsoft.Crm.Tools.Email.Agent.ServiceCore.InitializeSystemConfiguration()
       --- End of inner exception stack trace ---
       at Microsoft.Crm.Tools.Email.Agent.ServiceCore.InitializeSystemConfiguration()
       at Microsoft.Crm.Tools.Email.Agent.ServiceCore.ExecuteService()


    I looked into the "missing or not accessible" file and this is where I would think the problem is. The file is there, however, there is nothing in it. Does anyone know why this would be happening or how I can correct it?

    Thanks in advance,
    Mike
    Wednesday, May 27, 2009 6:03 PM
    • Marked as answer by Mike McCoy Wednesday, May 27, 2009 7:17 PM
    Wednesday, May 27, 2009 6:33 PM
  • So this seems to be because of Microsoft.Crm.Tools.EmailAgent.SystemState.Xml file getting corrupted. With one client it is happening every other day or so. Anyone have any ideas why it would get corrupt in the first place? Also, this just started happening. Any thoughts to it being related to a rollup?
    Tuesday, June 9, 2009 2:39 PM
  • Renaming microsoft.Crm.Tools.EmailAgent.SystemState.Xml worked for me.

    It can be found in this directory: C:\Program Files\Microsoft CRM Email\Service

     


    Leaf Consultancy NI www.leafconsultancy.com
    Thursday, June 17, 2010 10:19 AM
  • This happens at least twice a month on our servers.

    Any idea what could be the cause?

    Tuesday, June 29, 2010 11:28 AM