WHS restore CD can not find server RRS feed

  • General discussion

  • I've read the topics here on 'WHS PC Restore CD cannot find server'.

    At least for me, the answers were just wrong and the correct answer was simple.

    My setup:  Acer Aspire H340 with several additional hard drives and updated to PP3.

    Problem:  PC workstation, backed up by WHS needs to be restored but I experienced the same problems as many others here where the restore wizard could not find the server.  I tried many of the recommended solutions but they had no effect.

    Context:  Could not locate OEM Acer PC Recovery Disc, so I downloaded the recovercd.msi pointed to from the \\SERVER\software\Home PC Restore CD\ReadMe.txt file.  Apparently one of the power packs deleted the ISO file that used to reside here; the readme said it was obsolete and to download the new version.

    (Aside:  Microsoft, why did you put the ISO file in an MSI?  And why did the MSI drop the ISO file deep in the filesystem, then not notify where it put it?  That's just lame.  If a disk image needs to be compressed, just ZIP it.  Or at least have the installer tell the user where it created the file!)

    So I finally found and burned the 'new' ISO containing the recovery tool.  Booted the CD on the down PC and ran the wizard.  The wizard found my network hardware and storage devices without any problem.  But when it scanned the network for the WHS server, it would not find it.  Entering the server name ("HOMESERVER") had the same effect - not found.

    This is the point where I tried the MVP suggestions, but they were all wrong.

    So I eventually located the Acer OEM WHS PC Recovery Disc.  I booted that CD and it immediately found the WHS server and was able to restore the disk image from backup with no problems (other than the WHS going to sleep in the middle of the first restore attempt, but that's another story)

    I did look around the internet for the ISO image of the original PC Recovery Disc, but the only sources I found were dodgy torrents, etc.

    So my suggestion to people having trouble finding the server, at least H340 users, is to dig up the disks that came with the machine and use that.  It worked for me.

    As a final aside, I'd just like to say that I are really beginning to lose confidence in Microsoft Software.  As a software developer with 20 years of windows programming experience, I thought I knew my around windows computers.  The only thing I did on the PC that failed was follow VMWare Workstation's installation instructions and disable UAC prior to installing their software.  But as soon as I disabled UAC the system bluescreened and when rebooted many of the applications were completely hosed.  Re-enabling UAC fixed some of the issues but the system still had multiple weird problems from then on.  The only thing I could do to get the machine back into a known good state was restore from backup.   Having the restorecd.msi spit the ISO file hidden down in the user documents folder and not tell the user where it just completely stupid.  Allow the server to go to sleep in the middle of the restore, well, do I have to spell that out?  I could go on and on but frankly I feel that Microsoft listens less and less.  I've beta-tested microsoft products since DOS 5.0, and Microsoft used to listen to feedback and make the product better.  In the Vista beta I BEGGED Microsoft to fix many of the fundamental issues that were released to RTM and gave Vista the terrible reputation that it deserved.  Etc.

    Come on, Microsoft.  Fix UAC or remove the feature.  Fix restore so it ALWAYS works if the hardware permits - NO EXCUSES.

    Do better.  Or meet the fate of companies that put out new products that are inferior to their old ones.



    Friday, July 16, 2010 7:59 PM

All replies