locked
Report error in CRM 4.0 RRS feed

  • Question

  • Hello,

    When I create a new, custom report as administrator using built-in wizard in CRM appliction, other users can't run this report. They get the following error: SecLib::CrmCheckPrivilege failed. Returned hr = -2147220960 on UserId: 4cad2f11-a90e-dc11-8e6a-0007e91ff019 and PrivilegeId: d55d6eb9-d1e7-4ee9-a492-775015cf2f1f

    Another, built-in CRM reports run but only this customised don't.

     

    Any ideas?

    Lydia

     

    Friday, June 13, 2008 1:18 PM

Answers

All replies

  •  

    Dear see

     

    http://kbalertz.com/952279/Error-message-start-Microsoft-Dynamics-error-occurred-loading-Microsoft-Dynamics.aspx

     

    its permissions / security settings error

     

    Regards,

    Imran

     

    Monday, June 16, 2008 8:16 AM
    Moderator
  • Hi Irman,

    Thanks a lot for your tip but this dosen't solve ny issue. Changing pluar name of customized entity didn't help.

    I'm getting another issue running this report- " Server apllication error / The 'CRM_CalendarType' parameter is missing a value".

    But when any end-user wants to create a new report (got permissions on creating RS report and publish reports) he is getting the same issue "

    SecLib::CrmCheckPrivilege failed. Returned hr = -2147220960 on UserId: 24849abb-b20e-dc11-8e6a-0007e91ff019 and PrivilegeId: d55d6eb9-d1e7-4ee9-a492-775015cf2f1f"

     

    Where to look for security settings to solve this issue? When I'm looking at roles and permissions in CRM settings everything seems fine....

     

    Any ideas?

    Thanks in advance for any help

    Lydia

    Wednesday, June 18, 2008 6:17 AM
  •  

    Hi

     

    We are having the same problem

    got some feeback from microsoft saying that its an issue when creating a new role.

    they suggested that we copy one of the default roles.. i.e Administrator role and then configure it accordingly to the lower level users access. (they said there is a hidden attribute which does not get created on new roles.)

    This however did not fix our problem.

     

    Have you had any luck resolving this?

    Tuesday, June 24, 2008 12:46 PM
  • Hi,

    This last note was helpful to me.  Copying the Marketing Professional role got me a role which I could use.  Now my user can run the reports she needs.

     

    Thanks,

    Brian


    Brian Berry
    Wednesday, June 9, 2010 3:02 PM