AD Certificate Services failure RRS feed

  • General discussion


    My installation is hosed, with this error starting the string of errors in the event log each time I boot up:


    Active Directory Certificate Services did not start: Unable to initialize the database connection for servername-CA. Error 0xc8000158 (ESE: -344).


    It might have something to do with turning on Remote Web Access. I have been using the beta without trying the remote web access feature (had enabled it at one point and then changed my mind, but decided to try turning it on today). I told it not to configure the router, because I wanted to test it locally first. I was not able to remove into any of my online computers.

    I left it then, and when I came back (hours later), it was nonresponsive...client computers couldn't connect, could not ping, RDP, etc.
    It doesn't have a video card so I was trying to put one in to see the console, but apparently the one I bought was defective.
    I then pulled all peripherals, including 2 external drives, and was able to get it to boot up and remote into it.
    However, the clients cannot connect to the Dashboard...Launchpad works and shares are accessible, and Dashboard works from the (rdp) console.

    Tried the procedure at http://technet.microsoft.com/en-us/library/cc774578(WS.10).aspx to rebuild the AD-CA database and got:

    Update 4 April: I tried reinstalling the AD Cert role, which did not work. So I reinstalled WHS, and I can report that the server backup worked very well in getting my shared folders back (didn't bother with restoring client backups).

    I am going to keep this open for now just in case someone can give me an idea what else I could have done to rebuild the CA db, and what may have caused the problem in the first place.

    Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API parameter) 


    Tried turning off Remote Web Access and restarting. No help there either. It looks like I will need to reinstall at this point, but I wanted to throw it out here in case anyone else has experience with this and can suggest a shorter way.

    • Edited by Jeff Sahol Monday, April 4, 2011 2:10 PM further steps
    • Changed type Jeff Sahol Tuesday, April 12, 2011 8:19 AM resolved by reinstalling
    Saturday, April 2, 2011 11:44 PM

All replies

  • I had to reinstall, but discovered another issue, with certificates not being removed when I uninstalled the clients before installing on the new server.
    Tuesday, April 12, 2011 8:20 AM