locked
Import Managed Solution RRS feed

  • Question

  • HI, I imported a managed solution (Managed_1.0) on to a production system and when tried to import another version of managed solution (Managed_1.1) it showing the below error: "A managed solution cannot overwrite a SdkMessageProcessingStep component on the target system that has an unmanaged base instance." The new version have only form changes but imported failed in the processes. I am able sucussfully import the solution if I delete the previous processes imported with first managed solution (second managed solution have the exact same processes as first one).
    Friday, June 10, 2011 4:49 PM

All replies

  • Hi,

    Your managed solution have SDKMessageProcessingStep that already exsists in system as unmanaged, before importing you may have to delete the SDKMessageProcessingStep. I would recommend you to verify if component exsists in the package or not. In Import solution wizard after browsing file click on "View Soluton Package Details" to check if the SDKMessageProcessingStep is included or not.

    If it is included then you can delete it by selecting the step and click delete button from CRM->Settings->Customization->Customizations->Customize the System->SDK Message processing Steps.

    I hope this solve the problem.


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Friday, June 10, 2011 5:03 PM
  • I tried deleting the Sdk Message Processing Steps which are related to plugins but I had the same issue. Its only working when I delete the processes/workflows that are part of previous verion of solutions (and they are also part of the new version).
    Monday, June 13, 2011 7:21 PM
  • Malavika,

    I've come across the same problem. However removing the affected Process from the solution doesn't fix the problem. It looks like I would need to remove all workflows - although I haven't tried this yet. Looks like Microsoft should investigate this one further as I can guarantee that I haven't altered any processes between the two managed versions.

    There are other managed solutions on the CRM2011 OnLine install that we use. It could be one of these solutions has generated the error but why and how?!?

    I'll update later once I get more time to test etc.

    Simon

    Sunday, August 28, 2011 7:20 PM
  • Try uninstalling the older version of the solution before deploying the latest version.

    I know its not a ideal solution, just give it a go.

     

    I hope this helps.


    Amreek singh Senior CRM Consultant CDC Praxa Sydney,Australia http://mscrmshop.blogspot.com/
    Sunday, August 28, 2011 11:18 PM