none
Local Provider Upload Error RRS feed

  • Question

  • Hi all,

    I'm having a strange issue. Before I describe the problem let me describe the system. There is a central server with a database containing information on Countries A,B,C and D. There are then clients which hold a database provisioned from the central server but with a scope to limit them to a particular country There are also clients which holds an "All Countries" database for managers who need access to all the data. Using the Sync Framework V2.1 clients are able to sync to the server but not to each other. Once a month clients update their database and sync to the central server. Management can then sync to the server and pull down the latest data.

    This has been working fine for a few months until the other day. Now the problem. Country A tried to sync and after 3/4 of the sync it crashed with an error "Can not enumerate changes for at the RelationalSyncProvider for the table x" . There may have been an issue with the server we are not sure but when we tried to RDP to it later to check the database it gave a general error message which suggested the server was down. Since then Country A has managed to sync but none of the data was committed to the server. We have taken backups of the databases to perform sync tests in our test environment. What we have learned is.

    Country A can sync to the server without error but no data is uploaded to the server.

    Other Countries can sync data successfully.

    The "All Countries" database can successfully sync data to the server including Country A's data. 

    Country A can successfully sync data down from the server if it was uploaded by the "All Countries" database.

    None of the scopes or stored procedures seem to be missing on Country A's database.

    Entries are added to the tracking table but after the sync the fields which would normally be updated with values (update_scope_local_id, scope_update_peer_key, scope_update_peer_timestamp, create_scope_local_id, scope_create_peer_key, scope_create_peer_timestamp) all still have a NULL value.

    In short everybody can sync up and down to the server except Country A who can only sync down from the server. Sorry for the long winded questions but It's an unusual situation and I wanted get the facts clear.I'm sure re provisioning the table would fix the issue but I don't know what caused the issue and would like to avoid it again in the future if possible.

    Thanks all.

    Friday, June 1, 2012 5:23 PM

All replies