locked
OCS 2007 File Transfer RRS feed

  • Question

  •  

    So after upgrading from LCS 2005 to OCS 2007, my file transfer capabilities have completely stopped. File transfers are enabled, the file extension filter is disabled, but I'm still getting an error message after it gives up trying:

     

    "Cannot send "random.file" to Anonymous. This may be due to firewall restrictions or network problems. Please try again. If you need further assistance, contact your system administrator."

     

    Any suggestions would be greatly appreciated...

     

     

     

     

    Mike Keough
    Systems Engineer

     

    bluespring | SOFTWARE
    mike.keough@bluespringsoftware.com

     

     

    Monday, August 20, 2007 8:14 PM

Answers

  • File transfer is a peer to peer action, so it usually doesn't work with external users.  Ports 6891-6901 are used for file transfer.

     

    Sunday, September 2, 2007 9:25 PM
    Moderator

All replies

  • I had a similar problem and had to update/reapply the Group Policy.

    Tuesday, August 21, 2007 8:58 PM
  • Where did you do this? In the OCS global settings or user properties? I also experience this with some users. Sending files to users that are connected via Edge is also not working.

    /Thomas
    Wednesday, August 22, 2007 5:14 AM
  • File transfer is a peer to peer action, so it usually doesn't work with external users.  Ports 6891-6901 are used for file transfer.

     

    Sunday, September 2, 2007 9:25 PM
    Moderator
  • The strange thing is that i applied a rule in isa2006 that allowed port 6891 - 6900, but isa completely denied that rule.

     

    Regards, Mark

     

    Tuesday, September 4, 2007 7:49 AM
  • It's hard to say what's happening without looking at the firewall logs, but remember if one user is outside your network then their firewall is likely to be blocking those ports.

     

    Tuesday, September 4, 2007 6:38 PM
    Moderator
  • I could be wrong on this but I was speaking to a OCS support tech and he told me that OCS 2007 was designed to not allow file transfer outside the company. If I am wrong please let me know cause I really didn't believe him when to told me this.

    Monday, May 12, 2008 4:39 AM
  • It depends on what they mean with 'outside the company' . With OCS you always have to manually enable federation with other OCS environments and public IM servers. In this case File tranfer is enabled between internal and external (federated) contacts. File Transfer is based on peer to peer. If two federated contacts outside the company would like to transfers files they are dependent on firewalls between their networks and not the company firewall that is in front of the OCS pool. We have a group of federated users that are behind an ISA proxy. As long as they stay behind the ISA proxy they are able to tranfer files. When one user is behind the proxy and the other one is not the can not transfer files between each other.

    I'm wondering : is it possible to change the file transfer port in the communicator client or on the server?
    Has anyone tried file transfer between public messenger services and communicator clients?

    /Thomas
    Tuesday, May 13, 2008 1:57 PM
  •  

    I have a same problem.

    In my case, this problem is occured when file is transfered between private ip users.

     

    this problem is not involved in ports, and ocs'policies.

    I assume that this problem is rooted in ocs's origin problems.

     

    Has anyone ever solved this problem? 

    If this problem doesn't have answer, I wanna know the reason.

    I appreciate your help.

     

    /Hey ho

    Tuesday, October 28, 2008 12:22 PM
  • Hi there and thanks for your previous answers

     

    In my case it does not work with external users transfering files to internal users, and in my network traces took it on the external MOC, you can see it is trying to open a TCP port 6891 to the Internal non-routable ip address (192.168.241.x, my laptop IP address and I am behind a firewall, etc)

     

    I was expecting an external user would comunicate with some External OCS server (with a public IP addres) and this server will proxy the internal MOCs behind him. am I wrong?

     

    it works perfect with chat, but when you try to send or transfer a file, it tries to use the internal destination IP address, of course it fails

     

    i saw above is a peer to peer comunication but how can be peer to peer external-internal transfer files? it must be a server in the middle doing the public-internal and viceversa translation

     

    Thanks in advance for your answer

     

     

     

    Wednesday, November 5, 2008 2:35 PM
  • Is file transfer with external users supported in OCSr2, maybe?

     

    /Thomas

     

    Wednesday, November 5, 2008 2:55 PM
  • I too have the same problem.
    When two users transfer files with office communicator within the private network, at the end of the transfer by the error :
     
    Unable to send "NewDocument.txt" to User due to restrictions at the firewall or network problems. Please try again. For more information, contact your system administrator.


    Someone has solved?
     
     
    Many thanks to all
     

     

    Friday, December 5, 2008 11:49 AM
  • Did you disable the local firewall on the clients?

     

    Friday, December 5, 2008 8:17 PM
  • YES, and now it's work.

     

    Thank.

     

    Tuesday, December 9, 2008 9:24 AM
  • Maybe you can add exceptions in the Client Firewall

    Exclude Ports 6891-6901 that are used for file transfer

     

    Tuesday, December 9, 2008 9:58 PM