locked
WHS unable to restore specific file from client backup RRS feed

  • Question

  • We have been testing WHS in our small business (3 computers) as a client-machine backup solution.
    Today for the first time I really needed to restore an earlier version of an Access database from the WHS client backup database.

    So I launched the WHS console, and chose a backup one week ago. The backup mounted fine, but when I tried to drag/copy the database file to the desktop I got this error "

    "Cannot read from the source file or disk."

    So, I tried to copy other files from the same backup archive, and I was able to copy every other file I tried, but not the Access database file I needed (and btw our most important database file).

    I closed the backup windows (there were 2 of them?!). I then tried to mount a client backup from another date. This time, the mount froze at 81%, and I got an error message. So I then booted the machine. I now tried to open that same date again. Again, the process froze at 81%. Then, I tried to open a third date. This time, it mounted, but lo and behold: when I tried to copy the database file, it just said:  "Cannot read from the source file or disk. Try again or Cancel".  And I repeatedly Tried again, but the same error just kept popping up. And, since the database is changed daily, it definately was a different version of the database than that from the ohter date.

    Is this behaviour that someone has encountered before? Is there some solution for this?

    Previously we used Acronis to take image backups, and I have NEVER EVER been unable to restore an individual file from those incremental image backups during the 5 years we have used that solution. With WHS, it  seems you have to have really good luck and the right circumstances to get a file back. There are mounting problems, backup database corruption problems, problems if you client computer actually fails you and you have to restore to new hardware, and it seems "Cannot read from source file or disk"-problems...  :(

    Friday, January 30, 2009 6:58 PM

All replies

  • After trying to navigate around in more recent mounted client backup, when trying to go in to a directory that contains a lot of accounting files, I got this message: "You need to format the disk drive in Z: before you can use it".  Should I laugh or should I cry?
    Friday, January 30, 2009 7:25 PM
  • Fredrik70 said:

    After trying to navigate around in more recent mounted client backup, when trying to go in to a directory that contains a lot of accounting files, I got this message: "You need to format the disk drive in Z: before you can use it".  Should I laugh or should I cry?



    Hello,

    Another user has reported this issue; however, since there are various causes for the 81% bug, we do request that users submit their own bugs with CABs.

    Can you register on Connect, join our program, and submit a bug? We will need both client and server CABs and we have information on the site explaining how to submit them to the team here.

    Once we have the bug, we will follow up with you via Connect.

    Thank you


    Lara Jones [MSFT] | Program Manager
    Community Support and Beta | Windows Home Server Team
    Windows Home Server Team Blog
    Connect Windows Home Server
    Windows Home Server
    Friday, January 30, 2009 8:18 PM
    Moderator