locked
Mac client 0.9.3712.831 crashing RRS feed

  • Question

  • Live Mesh prompted me to update today.  I updated to 0.9.3712.831, and now it is crashing upon launch.  The error message is "The application LiveMeshAgent quit unexpectedly.  Relaunch always fails.  Ignore seems to allow Mesh to stay running, but nothing seems to sync.

    I've been able to get Mesh to collect logs, but I don't see a way to upload them here.

    Am I the only one?

    Thanks,
    Rick

    Wednesday, January 14, 2009 3:40 AM

Answers

  •  

    To all Live Mesh customers who have experienced crashes with the 0.9.3712.831 version of the Live Mesh for Mac software: A new version of the software that resolves this issue is now available.

    Please update or reinstall Live Mesh for Mac to receive the new version. If you continue to encounter problems, please let us know.

    Thank you,

    The Live Mesh Team.


    Blog | Forums | Feedback


    Nadia Fortini - Live Mesh Team
    • Marked as answer by Nadia Fortini Saturday, January 17, 2009 2:19 AM
    Saturday, January 17, 2009 2:19 AM

All replies

  • Wow - that version number seems way ahead of the new Windows one.

    I'd submit this as a bug - I currently don't have access to the net on my mac machine, but will try it out tonight.

    To submit a bug via Microsoft Connect, follow the instructions on the main page under "How to Submit Bugs and Live Mesh Logs".
    Wednesday, January 14, 2009 4:33 AM
  • Rick Lobrecht said:

    Live Mesh prompted me to update today.  I updated to 0.9.3712.831, and now it is crashing upon launch.  The error message is "The application LiveMeshAgent quit unexpectedly.  Relaunch always fails.  Ignore seems to allow Mesh to stay running, but nothing seems to sync.


    I am having the exact same problem.  I was prompted to update and now the program anounces that it quit unexpectedly upon launch but it is still running.  When I choose Ignore and let the program run, the program stays open and updates initially, but only once.  When I choose to relaunch, it runs into the problem that the program is still running and can't relaunch.
    To get things to update if I am working, I have to quit the program and then open it again.
    • Edited by extra5 Wednesday, January 14, 2009 4:58 AM added clarity
    Wednesday, January 14, 2009 4:55 AM
  • I have the exact same problem. I cannot revert to the old version, because Mesh keeps forcing the update. If this is a bug, it will be a bad day for Mac users all over. 
    Wednesday, January 14, 2009 5:11 AM
  • Thanks for the link to the instructions.  I'll submit it now.

    I'm thinking with a few people having the same problem that it must be a bug.  Hopefully they can get it resolved soon.

    Wednesday, January 14, 2009 1:25 PM
  • The exact same here. What a shame. System Version:    Mac OS X 10.5.5 (9F33)
    Wednesday, January 14, 2009 1:26 PM
  • I submitted feedback # 398494.

    Rick

    Wednesday, January 14, 2009 1:31 PM
  • Same issue here so I'm thinking its a larger probelm -- it was working so well....hope this gets addressed quickly!

    Adam

    Adam
    Wednesday, January 14, 2009 3:01 PM
  • I'm getting the same problem!

    I'd upload my logs but again we do not know where to, I think we shall wait for Ben to tell us :)

    Jase
    Wednesday, January 14, 2009 4:02 PM
  • Just wanted to chime in that it's working intermittently for me. I get a crash every now and then, but not consistently.
    Wednesday, January 14, 2009 5:25 PM
  • Cool_Me said:

    I'm getting the same problem!


    I'd upload my logs but again we do not know where to, I think we shall wait for Ben to tell us :)

    Jase



    Hi,

    Instructions for submitting a bug with logs attached are in the Announcement "How to Submit Bugs and Live Mesh Logs" at the top of the first page of the forums.  You can also choose to validate Rick's bug above: https://connect.microsoft.com/LiveMesh/feedback/ViewFeedback.aspx?FeedbackID=398494

    Please let me know if you have any questions.

    Thanks,

    Ben.
    Wednesday, January 14, 2009 6:55 PM
  • I am getting the same problem. Our system was working perfectly, and then Live Mesh prompted me to update. Now that I have, the program will not successfully run at all - it opens, begins running, and the Live Mesh Agent crashes almost immediately. The program throws up a few warnings, offers to collect its logs and then shuts down completely. Please fix this!!! Or at the very least, is there a link to the old working version? This 'upgrade' has made the program entirely useless. 
    Wednesday, January 14, 2009 8:25 PM
  • I tried the workaround in this thread, and (after fixing it) got Mesh working on my Mac.  It took Mesh back to a blank slate, so I had to log back in, and then tell it where to sync each of my shared folders, but it seems to be working now and it isn't crashing.

    What you need to do is to go to ~/Library/Application\ Support/ and rename Live/ Id and Live/ Mesh (safer than deleting in my opinion.)

    You can do it in terminal with the following three commands:
    cd ~/Library/Application\ Support
    mv Live\ Mesh/ Live\ Mesh.old
    mv Live\ Id Live\ Id.old

    Then start Mesh.  You'll be prompted to login, then you will be prompted to name your device.  I then logged in to the Mesh website and I had two machines with the same name.  I deleted the one that wasn't connected, and then back in the Mesh client, I clicked on each of the folders which were syncing with my Mac, and told it where to sync them.  Because those folders already existed, I told them to merge.

    Rick


    Thursday, January 15, 2009 3:25 AM
  • I'm having the same problem with the latest update.  Have tried deleting Live ID & Live Mesh folder in app support, all preference files, and reinstalling the application.  It will login successfully, but once I start adding folders back, the application will crash again.  It is essentially unusable now, when it was working well with the last version.
    Friday, January 16, 2009 3:23 AM
  • Same issues here.  seems to sync, but as stated only once.  Have not tried the instructions in the post mentioned as it seems there are mixed results.


    Friday, January 16, 2009 4:12 AM
  • I have the same problem after updating Live Mesh today.
    Friday, January 16, 2009 9:21 PM
  • Yes. Ditto. Completely unusable now. It starts and then stops. The only good news is that now I don't have to restart the client every day because it starts using 100% CPU like the last version, so one step forward I guess...oh, wait. :)
    Friday, January 16, 2009 10:05 PM
  • Add another user to the list. I have been loving it Live Mesh up to this point. Not sure how this Build made it out.
    Saturday, January 17, 2009 12:57 AM
  •  

    To all Live Mesh customers who have experienced crashes with the 0.9.3712.831 version of the Live Mesh for Mac software: A new version of the software that resolves this issue is now available.

    Please update or reinstall Live Mesh for Mac to receive the new version. If you continue to encounter problems, please let us know.

    Thank you,

    The Live Mesh Team.


    Blog | Forums | Feedback


    Nadia Fortini - Live Mesh Team
    • Marked as answer by Nadia Fortini Saturday, January 17, 2009 2:19 AM
    Saturday, January 17, 2009 2:19 AM
  • Nadia Fortini said:

    To all Live Mesh customers who have experienced crashes with the 0.9.3712.831 version of the Live Mesh for Mac software: A new version of the software that resolves this issue is now available.

    I updated and am still experiencing sync problems.  Three problems:
    1.  All changes seem to be updated when the program is first opened.  After that some files are syncing and some are not.  When I relaunch Live Mesh, anything that didn't sync previously, syncs on relaunch. 
    2.  Also, three times (in the last hour) when I quit the program, it gave a message that the program unexpectedly quit.
    3.  Lastly, sometimes the icon in the menu bar is dark as I believe is should be, giving full access to its options.  Other times the icon is grayed out and some of the options, are missing.  For example, the "new folder..." and "add existing folder" are not there.  My recent experience has been giving me the grayed icon every other time I relaunch.

    UPDATE:  The program is working fine now (1/17/09). I fear quitting and relaunching.  I will update again if the problems return.
    • Edited by extra5 Sunday, January 18, 2009 3:17 AM problem vanished
    Saturday, January 17, 2009 5:03 AM
  • Even after installing version 0.9.3715.831, I'm still having problems.  The sign-in to the Live Mesh service never appears to succeed and, after a short while, I get a notification that the LiveMeshAgent quit unexpectedly. 

    I've tried removing my device entirely, completely uninstalling the Live Mesh client (including the Library folders) and then reinstalling to no avail.
    Saturday, January 17, 2009 5:22 AM
  • I cannot get the new update to load at all.  I have deleted LiveMesh and LiveID folder from AppSupport, deleted the preference files, removed the login info from my kechain, rebooted my mac, and then installed the application.  When I launch it, the icon at the top remains grayed out for about a minute before I get a message that the application has quit unexpectedly.  This is extremely frustrating, and the client remains completely unusable.  I have tried uninstalling and re-installing several times with no difference.
    Saturday, January 17, 2009 5:25 AM
  •  In order for us to be able to investigate this issue, could you send your logs at lmprev@microsoft.com.

    To collect your logs:
    1.  Click on the Live Mesh icon in the top-right corner of your screen
    2.  Then click Collect Live Mesh Logs.
    3.  This will generate a .zip file on your desktop.

    Thank you for your help and patience,

    Nadia Fortini
    Live Mesh Team

    Nadia Fortini - Live Mesh Team
    Saturday, January 17, 2009 9:05 PM