locked
RTCHost on AES doesn't start, error E0434F4D RRS feed

  • Question

  • I've got a ticket open with PSS, but because we're not production yet, they are dragging on calling me back.

    This is the first error code I've got: E0434F4D.  lcserror returns nothing
    The first error that shows up in the OCS event log is:
    Source: OCS AppDomain Host Process
    Category: (1029)
    EventID: 50007
    -----
    An unhandled exception was encountered.

    Exception Details. System.NullReferenceException: Object reference not set to an instance of an object.
       at Microsoft.Rtc.IIMFilter.IIMFilter.GetThrottlingConfig(Int32& messageOverloadWatermark, Int32& memoryWatermark, Int32& overloadRecalculationInterval, Int32 messagesInServer)
       at Microsoft.Rtc.ApplicationService.ApplicationService.Start(EventWaitHandle shutdownEvent)
       at Microsoft.Rtc.ApplicationService.ApplicationService.Main(String[] args)
       at System.AppDomain._nExecuteAssembly(Assembly assembly, String[] args)
       at System.AppDomain.ExecuteAssemblyByName(String assemblyName, Evidence assemblySecurity, String[] args)
       at System.AppDomain.ExecuteAssemblyByName(String assemblyName, Evidence assemblySecurity, String[] args)
       at Microsoft.Rtc.AppDomainHost.Launcher.AppDomainLauncher.RunThread()
       at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Threading.ThreadHelper.ThreadStart()
    Resolution:
    Restart the server. If the problem persists contact product support.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    -----
    Following this, I get another for ClientVersionFilter, and then I get:

    Source: OCS Server
    Category: (1000)
    Event Id: 12331
    -----
    Worker process exited prematurely.  The process will be automatically restarted.

    Process: 'E:\Program Files\Microsoft Office Communications Server 2007\Server\Core\RtcHost.exe'  Exit Code: E0434F4D (No Message Text Found).

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    -----
    Of course the links take me to "sorry, we don't have any information".

    This started yesterday about 11 am.  AROUND that time (+/- 1hr), I made some Meeting Policy changes, via the GUI, but that's it.

    My research seems to indicate that it's a NET Framework issue, not an OCS issue.  I suspect when PSS calls me, they're going to make me reinstall the NET Framework.  If this is the resolution, I'll be particularly frustrated since nothing changed and the system stopped working, how can I be sure that it won't do this in production?

    I'm running 2 std servers, one Home, one AES, but we're part of the way through a migration from LCS05 w/ a similar config.

    So my question is straightforward, has anyone seen this in their environment and what was the resolution?
    Friday, February 29, 2008 3:46 PM

All replies

  • Hi Mark,

     

    I have the exact same issue - MS support looked at it and they ended up abandoning assisting us when they noticed the OCS server was running on ESX Vmware.....  Anyway our server runs for a while fine and then all the services die and we get the above errors in the eventlogs.  The only way to get the machine up is to restart it

     

    Have you had some help from MS?  Is this resolved, if so what did you do please?

     

    Cheers

    Jaco

     

    Saturday, May 17, 2008 6:00 AM
  • Ours service would not run at all (start and immediate stop).

    It turned out that the wmi/perfmon counters had to be reinstalled.  Microsoft worked with my coworker to complete the ticket so I don't have the information on what was done.  You might try digging into that.

    Wish I could be more helpful.

    Monday, May 19, 2008 4:22 PM