locked
Error: 'user-agent' - should be the first tag. RRS feed

  • Question

  • my robots validation test says
    • Warning: 'sitemap' - tag isn't specified.
    • Error: 'user-agent' -  should be the first tag.
    The " Error: 'user-agent' -  should be the first tag. " is quoted 100's of times. What does it mean? Surely I cannot put the whole sitemap on a single line???

    Also am not too clear if  "sitemap.xml" is the same as "Robots.txt."

    Any help warmly welcomed Many thx
    fish090
    Wednesday, January 21, 2009 3:37 PM

Answers

  • Success at last

    I found out the sitemap problem
    It was validated
    "No problems found."
    by doing the below....


    # Copy the contents of your robots.txt file here to validate it.
    User-agent: *
    Disallow:
    sitemap: http://caswellchat.co.uk/sitemap.xml



    Big Thx MGD King for the guiding hand
    Thursday, January 22, 2009 12:33 AM
  • You're quite welcome! I'm glad you got your issue squared away.

    Thursday, January 22, 2009 2:32 AM

All replies

  • What does your robots.txt file look like?

    Wednesday, January 21, 2009 7:59 PM
  • Hi ...MGD King

    The Robots.txt file was blank so I pasted my sitmap.xml in it (just to be on the safe side).


    Wednesday, January 21, 2009 8:13 PM
  • I'm not sure I follow what you did. Did you follow the guidelines outlined at http://www.robotstxt.org/robotstxt.html?

    Wednesday, January 21, 2009 8:22 PM
  • Hi MGD King

    I have had another look at http://www.robotstxt.org/robotstxt.html as you suggested and I think I have been barking up the wrong tree.
    The sitemap.xml was generated for google using http://www.xml-sitemaps.com/  and the Robot.txt file I left blank.  Having read your pointer to robot site I have renamed the file with a lower casing "R" e.g. robot.txt.  Inside this I have put

    User-agent: * and that's all.  Am I still barking up the wrong tree?? Thx in advance

    fish090


    Wednesday, January 21, 2009 10:15 PM
  • Try it this way:

    User-agent: *
    Disallow:
     
    Wednesday, January 21, 2009 10:31 PM
  • hi (again) MGD King

    Tried as you suggested now validation only complains as below:

    Warning: 'sitemap' - tag isn't specified.

    I tried  putting sitemap.xml in line 3

    User-agent: *
    Disallow:
    sitemap.xml
     and got this below

    Line #3: sitemap.xml
    Warning: MSNBOT doesn't support this tag.
    **************************************************
    Warning: 'sitemap' - tag isn't specified.


    and tried robot.txt in place of sitemap.xml and got  the same error message as above.

    ( Sometimes life is complicated when you can't see the obvious ).  Thx for your perseverance

    fish090
     
    Wednesday, January 21, 2009 11:28 PM
  • Success at last

    I found out the sitemap problem
    It was validated
    "No problems found."
    by doing the below....


    # Copy the contents of your robots.txt file here to validate it.
    User-agent: *
    Disallow:
    sitemap: http://caswellchat.co.uk/sitemap.xml



    Big Thx MGD King for the guiding hand
    Thursday, January 22, 2009 12:33 AM
  • You're quite welcome! I'm glad you got your issue squared away.

    Thursday, January 22, 2009 2:32 AM