locked
A Microsoft Dynamics CRM Window was unable to open RRS feed

  • Question

  • I’ve set up a virtual machine (2008 Server) and have successfully installed Dynamics CRM. (including the SSRS data connector and the Outlook client)

     

    When I click on reports in the Outlook OR in the Web Client and try to run a report I get the following message

     

    "A Microsoft Dynamics CRM window was unable to open, and may have been blocked by a pop-up blocker.

    Please add this Microsft Dynamics Server to the list of sites your pop-up blocker allows to open new windows:Localhost"

     

    I have turned off the Pop-up blocker in IE and have added http://localhost to the trusted sites.

    No other pop blockers employed

    Its IE 8 .

     

    I have also tried turning “Protected Mode” on and off.

     

    Interestingly – If I toggle the “Protected Mode” from its current state and don’t restart IE the Reports displays ( AS WELL AS THE ERROR)

    But when I restart IE it’s back to just the error message. That behaviour happens when going from enabled to disabled and vice versa

    I have made sure IE is the default browser.

    I'm running out of ideas

    it worked yesterday before upgrading to IE8.

    But please don't tell me to go back to IE7 because IE8 is supported

    Thursday, September 9, 2010 9:03 AM

Answers

  • Hi

    Enable protected mode for all zones in IE, Also enable the following

    Add the site to your trusted site from IE Tools -> Internet Options -> Security Tab -> Trusted Sites

    And Select Custom Level Button while the Trusted sites is selected and Set the following options

    Activex Controls and Plig-ins set the following to enabled [ONLY FOR TRUSTED SITES]

    1. Allow Previously Unused Activex controls to run without prompt
    2. Automatic prompting for activex controls
    3. Binary and Script behaviors
    4. Download Signed Activex controls
    5. Initialize and script Activex controls not marked as safe for scripting (this should prevent the prompt).
    6. Run Activex Controls and plug-ins
    7. Script Activex Controls marked safe for scripting

    Hope this helps. Amar
    Thursday, September 9, 2010 2:28 PM

All replies

  • Please look at this post - http://social.microsoft.com/Forums/en-US/crm/thread/df5aef4d-caae-40c8-9bfa-60c43c200a0e.

     

    I hope that helps,

    Kuba


    -- Kuba Skałbania, Netwise
    Thursday, September 9, 2010 10:16 AM
  • WHat worked for me was to install all possible Windows updates and to run a script found here.

     

    http://iefaq.info/index.php?action=artikel&cat=42&id=133&artlang=en

     

     

    Thursday, September 9, 2010 1:21 PM
  • Hi

    Enable protected mode for all zones in IE, Also enable the following

    Add the site to your trusted site from IE Tools -> Internet Options -> Security Tab -> Trusted Sites

    And Select Custom Level Button while the Trusted sites is selected and Set the following options

    Activex Controls and Plig-ins set the following to enabled [ONLY FOR TRUSTED SITES]

    1. Allow Previously Unused Activex controls to run without prompt
    2. Automatic prompting for activex controls
    3. Binary and Script behaviors
    4. Download Signed Activex controls
    5. Initialize and script Activex controls not marked as safe for scripting (this should prevent the prompt).
    6. Run Activex Controls and plug-ins
    7. Script Activex Controls marked safe for scripting

    Hope this helps. Amar
    Thursday, September 9, 2010 2:28 PM