locked
CRM Problems After Installing Sharepoint RRS feed

  • Question

  • Hello,

    We initially had CRM server installed and working properly on a server that has the IIS role as well. Today, we attempted to install TFS 2010 on the same server which required Sharepoint 3.0. The installation went fine but after installing, the CRM web pages were giving errors. The CRM site's Application Pool has been changed as warned in the installation wizard but after debugging for a bit, it seems like the web.config file of the CRM site has been entirely replaced by a SharePoint-friendly one. The problem was initially about missing permissions. After changing the trust level back to full, there were a bunch of NullReference exceptions. After merging the original and the new web.config, the site seems to be working now on the surface but there are a lot of js script problems. Most of the functions and object access give NullReference exceptions although the scripts themselves and the resources they're trying to load are not changed when comparing with original CRM installation files. 

    Our CRM site on IIS is definitely been broken somehow but a repair of the CRM installation doesn't solve it. Reimporting the CRM organization doesn't help either. What can we do to restore the CRM IIS site?

    Thanks!

    Xiao

    Wednesday, July 21, 2010 3:56 AM

Answers

  • k, I think that finding the np-completeness of whether it's possible to discover what went wrong there will be an exercise left for another time. The repair tool was useless. But uninstalling and reinstalling fixed CRM's IIS site
    • Marked as answer by xsterx Wednesday, July 21, 2010 11:14 PM
    Wednesday, July 21, 2010 11:14 PM