locked
CRM 2011 Outlook add-in RRS feed

  • Question

  • Hey Guys

    I've been struggling with pushing out CRM from SCCM 2007 R3. So to eradicate SCCM from the issue - I've copied the source files to my test client system and issued a SetupClient.exe /Q /L "c:\clientinstalllog.txt" /targetdir "c:\program files\Microsoft Dynamics CRM"

    Event viewer reports (as did SCCM) that installation was successful - however the installation actually fails with the installation log being populated with the following...

    10:07:34|   Info| === Setup bootstrap logging started 27/10/2011 10:07:34 ===
    10:07:34|   Info| Bootstrap version: 5.0.9688.1533.
    10:07:34|   Info| User: pauline.fowler.
    10:07:34|   Info| Invoked with command line: SetupClient.exe /Q /L "c:\clientinstalllog.txt" /targetdir "c:\program files\Microsoft Dynamics CRM"
    10:07:34|   Info| Running Microsoft Dynamic CRM 5 for Outlook at : C:\Source\CRM2011 Installer
    10:07:34|   Info| System Memory: 2137047040 Bytes
    10:07:34|   Info| Initializing COM.
    10:07:34|   Info| Initialized COM.
    10:07:34|   Info| No pending reboot detected
    10:07:34|   Info| No reboot required
    10:07:34|   Info| Uninitializing COM.
    10:07:34|   Info| Uninitialized COM.
    10:07:34|   Info| Current OS Version: 5.1.2600
    10:07:34|   Info|   ServicePack: Service Pack 3
    10:07:34|   Info|   System Type: Workstation
    10:07:34|   Info|   Suite Mask: 0x0100
    10:07:34|   Info| .NET version found is 3.5.30729.1
    10:07:34|   Info| Copying installer files to local directory: 
    10:07:34|   Info| Package: C:\Source\CRM2011 Installer\Client.msi, Options: ADDLOCAL="Installer" INSTALLDIR="C:\DOCUME~1\XXX~1.XXX\LOCALS~1\Temp\MSCRM_{91A7E369-6337-456A-B00E-E6A635796BD2}" TARGETDIR="C:\DOCUME~1\MATT~1.TIP\LOCALS~1\Temp\MSCRM_{91A7E369-6337-456A-B00E-E6A635796BD2}" ALLOWRUN=1
    10:07:38|   Info| Loading bootstrap library C:\DOCUME~1\XXX~1.XXX\LOCALS~1\Temp\MSCRM_{91A7E369-6337-456A-B00E-E6A635796BD2}\ClientSetup.dll
    10:07:38|   Info| Microsoft Dynamics CRM for Outlook is not currently installed.
    10:07:39|   Info| === Setup bootstrap logging ended 27/10/2011 10:07:39 ===

    10:07:39|   Info| Bootstrap version: 5.0.9688.1533.
    10:07:39|   Info| User: pauline.fowler.
    10:07:39|   Info| Initializing COM.
    10:07:39|   Info| Initialized COM.
    10:07:39|   Info| Current OS Version: 5.1.2600
    10:07:39|   Info|   ServicePack: Service Pack 3
    10:07:39|   Info|   System Type: Workstation
    10:07:39|   Info|   Suite Mask: 0x0100
    10:07:39|  Error| CString::LoadString(7407) failed.(error = 1814) (CheckBase.h:CCheckBase::SetErrorMessage:224).
    10:07:39|   Info| Uninitializing COM.
    10:07:39|   Info| Uninitialized COM.
    10:07:39|   Info| Error in Run client bootstrap : CString::LoadString(7407) failed..
    10:07:40|   Info| Clean up the BITS downloader.

    ted 27/10/2011 10:07:40 ===
    10:07:40|   Info| Bootstrap version: 5.0.9688.1533.
    10:07:40|   Info| User: pauline.fowler.
    10:07:40|  Error| Installation of Microsoft Dynamics CRM for Outlook failed.
    10:07:40|   Info| Clean up the BITS downloader.

    10:07:40|   Info| Clean up the BITS downloader.

    10:07:40|   Info| === Setup bootstrap logging ended 27/10/2011 10:07:40 ===

    Any idea's?

     

    Thursday, October 27, 2011 9:33 AM

All replies

  • Sorry - XP SP3 / x86 / IE8

    What I have noticed from the above output is that it states I have .NET 3.5.30729.1 installed... the client has .net 4 installed.

    Thursday, October 27, 2011 9:35 AM
  • Same issue here after an upgrade from Office 2003 to 2010 and then an uninstall of CRM 4 and install of CRM 2011.  Did you find a resolution?

    Windows 7 SP1 / x64 / Office 2010 SP1 / IE9


    • Edited by SyscomDT Monday, October 31, 2011 8:20 PM
    Monday, October 31, 2011 8:20 PM
  • I use the online version of the crm 2011 and I got a similar error. What worked for me was:

    logged into to my corporate crm homepage as an administrator and enabled the "get outlook client" option under "settings\system settings\outlook tab"

    logged out and logged back into the homepage and then clicked on the "get outlook client" button from the message bar that showed up (apparently this downloads a new client software)

    installed the new client software on my workstation and the error disappeared

    Wednesday, November 2, 2011 4:18 PM
  • I am running into this issue to.  I believe the only fix is to reformat your HD.  Just another crappy build MS app.
    • Proposed as answer by Steve Konde Tuesday, January 31, 2012 9:05 PM
    • Unproposed as answer by Steve Konde Tuesday, January 31, 2012 9:05 PM
    Tuesday, November 22, 2011 9:46 PM