locked
Huge memory usage and slow performance RRS feed

  • General discussion

  • I tried v2.1 out after some previous experience with 1.4 and overall I am happy, but I have noticed some severe performance issues:

    I am running W7 x64 with 4GB of RAM. I am attempting to do an Echo of one drive to another after most of the files have already been copied.
    The first time around when I copied ~300GB worth of data, everything ran fine (15k files or so)

    But this time, as I am running Echo to update changes, my system is getting totally bogged down. Memory usage on SyncToy started at 20MB and has climbed to over 2.3GB (and counting...) Also CPU usage has stayed in the 97 range. To add fuel to the fire, the performance is abysmal. The deletion process is currently going on and pictures are being deleted at a rate of 2/second which is poor for ~1MB images. Edit: I just did a manual delete of a folder and was able to delete hundreds of pictures in 2 seconds while the SyncToy delete process was going on--the hard drive was clearly not being fully utilized by SyncToy

    I don't know what is up, but I don't like it. Hopefully my computer doesn't crash before I can finish posting this.

    Any ideas what is going on?
    How can performance be so poor when I had no problems copying 300GB of files before? It seems to just be the delete process that is killing it
    • Edited by Function0 Wednesday, December 16, 2009 7:47 AM Additional Information
    Wednesday, December 16, 2009 7:42 AM

All replies

  • I currently have the same problem with v2.0, hoped it was gone after this version....

    Adding to the observations above: also during deletion of files (!) and even when I stopped the sync process, but not the synctoy program, the memory usage increase steadily with a few MB (estimated 3-4 MB) per second. This starts after the "adding an action for..." is ready and the sync process starts. And the CPU stay extremely active (indeed up and over 95%). This continues until the program uses all my internal memory and "stops", i.e. it stucks and you can not do anything about it except stopping the program via task manager. Apparently the memory handling is not right or there is a process adding "something" to the memory, independent of what the program is doing...
    Wednesday, December 30, 2009 2:39 PM
  • Hi -

    Have you tried checking if your recycle bin is full? Try emptying it and seeing if performance improves?

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, December 30, 2009 10:37 PM
  • Wasn't a problem for me. I was able to delete the folders in question without any problems. My recycle bin was almost empty

    Sunday, January 10, 2010 12:48 PM
  • 1. Do you sync files from the local machine to a remote share (either on network or another machine)?
    2. You have 15K (~15000) files on each side right?

    Thanks.
    Leo Zhou ------ This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 12, 2010 6:16 AM
    Answerer
  • It was from one hard drive to another on a local machine
    For the first copy, I had no files on the second drive and about 18,000 copied over -- this went fine.
    The second time, I had the 18,000 files on both drives and about 1,000 more copied, deleted, etc -- this is when the performance hit took place.


    Thursday, January 14, 2010 2:14 AM
  • I was using the software again tonight and performance is absolutely abysmal. It makes everything else on my computer incredibly slow and hard drive access on my main drive is nearly 0, even though the file transfer is from drive 2 to drive 3.

    This bug really needs to be fixed
    Sunday, February 14, 2010 3:30 AM
  • I have found the SyncToy 2.1 operating under W7-64bit on an i5 CPU with 4G RAM just about locks up my machine entirely. When I could eventually get the Task Manager to operate I found that over 99% of RAM was in use and only about 7% of CPU.

    I conclude that there is a glitch in the software that needs to be fixed.

    Will Microsoft read this?

    regards

    Thursday, April 29, 2010 9:24 AM
  • I had the same problem but solved it by unticking in SyncToy's Folder Pair Options the "Put overwritten files in Recycle Bin".

    Hope this helps.

    Wednesday, May 5, 2010 2:10 AM
  • Having the same problem.  Turned it off and will attempt to use the built-in backup on Win 7.

     

    I have (had) Synctoy as a scheduled task.  Havent checked but I believe the backup was successful but the process grew to take up the remainder of my available RAM (almost 3GB) and wouldnt shutdown without a manual kill.

     

    Running i5 laptop, Win 7 64-bit with 8GB of Ram.

    Saturday, October 30, 2010 5:21 AM
  • Thanks for the content of this thread. After reading Retrolaser's post, i turned off the "recycle bin" setting and my performance (both CPU and Memory) issues went away. Good tip - thanks. Win7 x64 6GB - working nicely once again.

    Monday, November 29, 2010 12:43 PM
  • Check the answer here -

    http://social.microsoft.com/Forums/uk/synctoy/thread/44472b7b-4192-4f5f-b954-4e5ca558d3fb

    Saturday, February 16, 2013 1:18 PM