locked
Updating Outlook Client Configurations with Batch File RRS feed

  • Question

  • Looking to configure CRM 2013 to use ADFS this week (or next week) and am looking for ways to reconfigure all user's Outlook clients to point at the new URL we'll be using without them having to do anything.  Per this document I've followed the suggested method by using a batch file to do the work, but it's not reconfiguring the addin at all.  I'm able to copy the new config.xml to their directory and delete their old configurations, but I can't make it use a new configuration.  Any ideas?

    Here's the exact code I'm using in the batch file:

    copy /y "\\<directory share>\CRM_Outlook_Update\default_client_config.xml" "C:\Program Files\Microsoft Dynamics CRM\Default_Client_Config.xml"
    "C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard\Microsoft.Crm.Application.Outlook.ConfigWizard.exe" /q /xa
    "C:\Program Files\Microsoft Dynamics CRM\Client\ConfigWizard\Microsoft.Crm.Application.Outlook.ConfigWizard.exe" /q /i "C:\Program Files\Microsoft Dynamics CRM\Default_Client_Config.xml"

    Here's the exact code I'm using in the config.xml:

    <Deployments>
    	<!--
    	The settings below are for crm client setup
    	-->
    
    	<!--
    	<TargetDir>C:\Program Files\Microsoft Dynamics CRM</TargetDir>
    	-->
    
    	<!--
    	<InstallOfflineCapability>false</InstallOfflineCapability>
    	-->
    
    	<!--
    	The settings below are for crm client configuration wizard
    	-->
    	
    	<!-- Use the Organizations Unique Name (i.e. Organization1)	-->
    	<Deployment>
    		<DiscoveryUrl>https://<hostname>.<domain>.com/XRMServices/2011/Discovery.svc</DiscoveryUrl>
    		<Organizations>
    			<Organization IsPrimary='true'>CRM-DEV</Organization>
    		</Organizations>
    	</Deployment>
    </Deployments>

    When I run the batch file I get no errors and no alerts.  It successfully copies the XML file over, then successfully deletes old configurations, then runs the final command without error.  I open up the Configuration Wizard and there are no entries.


    Tuesday, November 11, 2014 8:59 PM

Answers

  • Thank you, Jithesh!

    I actually found the logging parameter immediately after posting this and now have the entire process working.  It's very misleading that the XML asks for the Discovery Service URL instead of simple web URL.

    For anyone that may end up here with the problem, use the /l "C:\logfile.log" parameter every time you run this command just so you have the ability to see what it did.  In my case, it helped me discover that when the XML file asks for the Discovery Service URL, it actually wants the URL to your CRM web server alone, not the entire URL-Path to the Discovery Service; i.e., http(s)://<servername>.<domain>.<topLevelDomain>:<port_ifNot80or443>

    • Marked as answer by Josh Waclawski Friday, November 14, 2014 1:28 PM
    Friday, November 14, 2014 1:28 PM

All replies

  • hi,

    your discovery URL is not Correct. It should have only the server name and port.

    you can find installation logs as specified in this article.

    http://technet.microsoft.com/en-us/library/hh699813.aspx

    and potentially this.

    https://social.microsoft.com/Forums/en-US/c17cfe0a-ee41-473a-ba19-1bb2d182c53c/problems-connecting-outlook-to-crm-2011-using-https?forum=crm

    regards

    Jithesh

    Friday, November 14, 2014 8:07 AM
  • Thank you, Jithesh!

    I actually found the logging parameter immediately after posting this and now have the entire process working.  It's very misleading that the XML asks for the Discovery Service URL instead of simple web URL.

    For anyone that may end up here with the problem, use the /l "C:\logfile.log" parameter every time you run this command just so you have the ability to see what it did.  In my case, it helped me discover that when the XML file asks for the Discovery Service URL, it actually wants the URL to your CRM web server alone, not the entire URL-Path to the Discovery Service; i.e., http(s)://<servername>.<domain>.<topLevelDomain>:<port_ifNot80or443>

    • Marked as answer by Josh Waclawski Friday, November 14, 2014 1:28 PM
    Friday, November 14, 2014 1:28 PM