locked
Incoming Email Routing/Linking RRS feed

  • Question

  • I have an issue with incoming email and I am not sure how to change the behaviour. I must admit that I don't know much about Email Router other than installing it with a basic config, so my apologies if I've missed something obvious.

    I have a Queue set up in CRM with the email account support@email.com attached to it. An email is sent to this address from customer@email.com which goes to the queue, and them someone converts it to a case which is linked to the relevant record in CRM. This is fine, so far so good.

    However, when a second email arrives from the same sender (customer@email.com) this email goes into the queue, but it automatically gets linked to the original email (it appears in the history of the case and viewing the second email in CRM shows it is set as regarding the first email that was sent). Why is CRM assuming that the second email is related to the first just because they come from the same sender? Is there a setting somewhere that would control this in a different way? What I would like to see is the second email being placed in the queue and not linked to any other case/email.

    Incidentally if a third and forth email comes in from the same sender they all get linked to the first case, but if one of the subsequent emails get converted to a case then any further emails start getting linked to that more recent case instead.

    The reason this is causing such a big problem for me at the moment is that one of my clients has a website that converts a contact form to email and sends them to the support address. So potentially lots of emails come in from the same email address which are completely unrelated to each other.

    Friday, August 19, 2011 2:12 PM

Answers

  • Hi Bozell,

    Have you tried turning off Smart tracking?  Setting>Administration>System Settings>Email

    It may be associating due to similar subject strings.

    Hope this helps,
    craig


    My Blog
    Twitter
    Friday, August 19, 2011 2:52 PM
  • Craig,

    I forgot to say earlier this is CRM 4.0, so that option doesn't exist. However you make a good point and I've found that a hotfix is required to disable smart matching in 4.0 so I'll give that a go.

    Thanks.

    Friday, August 19, 2011 3:30 PM

All replies

  • Hi Bozell,

    Have you tried turning off Smart tracking?  Setting>Administration>System Settings>Email

    It may be associating due to similar subject strings.

    Hope this helps,
    craig


    My Blog
    Twitter
    Friday, August 19, 2011 2:52 PM
  • Craig,

    I forgot to say earlier this is CRM 4.0, so that option doesn't exist. However you make a good point and I've found that a hotfix is required to disable smart matching in 4.0 so I'll give that a go.

    Thanks.

    Friday, August 19, 2011 3:30 PM
  • My fault, I've been too engrossed with 2011 for the last 6 months, I forget the differences with 4.0

    Have a good weekend
    Craig


    My Blog
    Twitter
    Friday, August 19, 2011 3:33 PM