none
Corrupt files in Right Folder when SyncToy 2 Beta synchronized over network to Home NAS

    Question

  • I recently installed SyncToy Beta Ver 2.0.0.0 and used it to create a synchronized set of ~600 pictures onto a home NAS.  Upon examination of the synchronized pictures, I noticed that a small percentage (~1%) of the copied jpg files contained visible signs of  file corruption. The files were not so badly damaged that they couldn't be viewed.  However, when I examined some large avi files synchronized using a separate folder pair, I discovered that they had been irretrievably corrupted.  So far I have made the following observations:
    1. The problem is reproducible (at least 3x in a row).  The *same* files are corrupted the *same* way when the synchronization is repeated from scratch.  (e.g. the Folder Pair is deleted; The Right Folder contents & folders are deleted; A new Right Folder is created; A new folder pair is created; Synchronization is executed)
    2. The configuration affects the outcome.  The same files are NOT corrupted using SyncToy 2 Beta when the Right Folder resides on the local C: drive (1 test with no network or NAS involved).
    3. It makes no difference whether the Right Folder is defined in UNC syntax or PATH syntax
    4. The problem is specific to SyncToy Beta 2.0.0.0.  SyncToy 1.4 worked fine using the identical network/NAS setup. I unistalled SyncToy 2 Beta and installed SyncToy 1.4. and successfully repeated the synchronization 2x.
    I can provide paired jpg files exhibiting the corruption if anyone is interested in examining the nature of the corruption.

    The configuration(s) that results in corrupt files is:
    1. Action: Synchronization
    2. Options: Include - All Files (*), Exclude - none (blank); No excluded attributes;
    3. Other settings: Active for run all - on; Save overwritten files in recycle bin - on; Check file contents - off.
    4. Folder Pair: Left Folder defined as a standard windows PATH; Right Folder defined either as a UNC or PATH
    5. Initial State of Left Folder: populated with files & folders
    6. Intial State of Right Folder: empty
    7. Left Folder:  Local C: drive of Dell 600 Laptop computer running XP Professional SP2, File System NTFS, wired 100Mb ethernet
    8. Right Folder:  Network Share on an Iomega Home Network NAS, File System believed to be FAT32, wired 100Mb ethernet
    9. Router: D-Link DI-624
    Friday, August 8, 2008 5:02 AM

Answers

  • Hi -

    We have a fix for the problem and we will be sure to fix this in a future release. Currently however there is no workaround this problem.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, March 11, 2009 7:33 PM
    Moderator

All replies

  • I'm replying to this to say that I am experiencing what appears to be the same problem - it's disappointing that no-one's been able to suggest anything since last August, maybe there have been some developments since then?

     

     

     

    Friday, January 30, 2009 5:03 PM
  • I'm bumping this back onto the first page because unlike every other thread here which is commenting on feature requests/obvious failures/questions etc. this is about something that might stay hidden to most users until it's too late, and I think it needs to be kept visible while there isn't a fix for it!

    If there is a way to submit a proper bug report, or if anyone has the correct account type for submitting such a report please could they either do so or let me know how?

    Thanks.
    Monday, February 9, 2009 3:00 PM
  • Hi -

    Is this something you are seeing with SyncToy 2.0 ( not Beta ) as well ? We have not seen this before.

     

    Thanks

    Deepa


    Deepa ( Microsoft Sync Framework)
    Wednesday, February 11, 2009 12:21 AM
    Moderator
  • Absolutely - I made sure to uninstall the beta beforehand, but I get the same result with another laptop that has only ever had 2.0 (not beta) installed.

    I'm amazed you haven't seen this before, as I'm obviously not the only person to suffer from it - and what's worrying is that anyone using SyncToy for backup purposes (as I am) won't realise that it's happening until it's too late!

    I'm not connected to the NAS drive at the moment, but let me know if you'd like me to email you an example of a corrupt jpg or any other information that might help.

    Great to have someone looking into it - thank you Deepa.

    Jon
    Thursday, February 12, 2009 12:24 PM
  • Hi,  Just to report that I am getting this too. 

    Version 2.0.100.0 and this is the first time I have ever used and installed SyncToy ie no Beta versions ever installed here. 

    I have as the left folder C:\DigitalCamera and the right is G:\Digicam-backup    - the G: drive being a mapped drive to a folder on my ethernet connected  NAS (Freecom) storage device.      The C: drive is on my Windows Home Premium laptop.  All kit is fairly new (ie less than 6 months old and working perfectly in every other way).  

    If I copy the same folder manually via windows explorer there are no errors.   Photos sync'd with Synctoy show visible corruption ie picture is split into five horizontal segments  from top to bottom , each of similar height.  Strips 1,3 and 5 are as they should be but strips 2 and 4 are offset by about a quarter of the width of the photo and the rest is wrapped around   - looks a bit like those kids puzzles where you can change the top, middle and bottom of pictures with different images .  If it helps I can post an example here.

    I can, in theory, look at all pictures and manually fix all bad ones (the originals are ok - ie in the c: folder but it would take many hours) but what about other data / document files how are these being corrupted?

    Thanks in advance

    Saturday, February 14, 2009 9:58 PM
  • Deepa,

    Please could you make Synctoy version 1.4 available again through the Microsoft website while we wait for a fix to version 2?

    The more I look the more I find people saying V1.4 didn't have this file corruption problem, but I can't find a copy to download any more!

    Thanks!
    Jon
    Tuesday, February 17, 2009 9:33 AM
  • Can I ask you to send me an email at FirstName.LastName@microsoft.com?  We have a few questions about your issue that would probably be easier to ask over email.  Once we have a solution we will then post it here.

    Thanks,
    Liam Cavanagh
    Program Manager, Data Replication and Synchronization - http://msdn.microsoft.com/sync/
    Thursday, February 19, 2009 12:54 AM
  • Liam,

    I just sent you an email, so feel free to ask questions - hope I can be of assistance.

    Jon

    Saturday, February 21, 2009 12:05 AM
  • I see that this hasn't moved for a while.  Would you like me to email you some additional info as well?

    Happy to provide any help you need to help get this fixed.
    Sunday, March 1, 2009 9:57 PM
  • I have exactly this same problem on my new installation of SyncToy 2.0.100.0 (not BETA) with Windows XP Professional: JPG file corruption on my external Freecom network drive. I only found this out when I took the network drive on holiday and plugged it in to a laptop to show photos to a group of friends.  Hundreds of jpgs were corrupted with multiple stripes and large grey blocks blotting out the image.  I got a big shock and after trying lots of variations I eventually reformated the whole drive, started again from scratch - and recreated exactly the same problem on a fresh drive.  Having created the corrupt jpg files in the right folder, SyncToy 2.0 was unable to distinguish any differences between the good files in the left folder and the bad ones in the right folder, even with the "check file contents" option selected. The file sizes were in each case identical but the back up copies were unusable.

    SyncToy 2.0 is unusable for jpg files on network drives until this problem is fixed!

    Many thanks for a fix!

    P.S. this is also discussed on the following thread
    http://social.microsoft.com/forums/en-US/synctoy/thread/8cd6481c-1e96-43aa-aca6-ee9f95a6b50f/.  No movement there either - so I have posted this message on both threads in the hope that a moderator will look in and combine...


    Monday, March 9, 2009 10:09 PM
  • Hi -

    We have a fix for the problem and we will be sure to fix this in a future release. Currently however there is no workaround this problem.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, March 11, 2009 7:33 PM
    Moderator
  • Is this a Synctoy problem or a Sync Framework problem?  I want to uninstall Synctoy 2.0 and reinstall Synctoy 1.4.  Will this work?  I do not want to hace to check every .jpg to see if there is any corruption under the reinstall of 1.4.

    BTW, this is a great tool!  I hope microsoft will give this issue some priority because I really need the functionality.  NAS devices are becoming more ubiquitous.

    Thanx

    Possum
    Friday, March 13, 2009 11:31 PM
  • Hi Deepa

    Are you any closer to knowing when the next version will be released?

    In the meantime, should you issue a warning to anyone downloading 2.0 - letting them know not to use it with a network drive?  Not everyone downloading it will read these forums!

    Thanks,
    Jon
    Monday, March 23, 2009 9:31 AM
  • Is this a problem even if using to sync to an external hard drive on the same computer?
    Tuesday, March 24, 2009 8:18 PM
  • Hi -

    No it is not a problem that is generic to all external drives. You should not have a problem.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Tuesday, March 24, 2009 11:48 PM
    Moderator
  • Hi Deepa

    Are you any closer to knowing when the next version will be released?

    Thanks,
    Jon
    Monday, March 30, 2009 5:09 PM
  • It would be great if you could just release this fix!

    it is a major problem if you are releasing a program that you know is corrupting files! Jpg's can quite easily be peoples family photos that are priceless and irreplaceable. especially as alot of people are using it to backup there files to a nas drive and think they are safe.

    Also fixing the way the cmd line synctoy does not deal with the dynamic drive letter (Changing drive letters for a nas drive / flash disk) problems like the full program does  is a bit pants too.

    Sort it out or tell people you have messed up!

    When is the next version out? next week, next year. give us a clue

    Tuesday, April 14, 2009 5:25 PM
  • I have over 700 IMPORTANT .pdf files and loads have been corrupted using SyncToy.

     Also, when they corrupted my LiveMesh updated all my folders with the corrupted versions so now I have seemingly no backup for these files.

    This has landed me in at the deep-end does anyone have any suggestions?
    Friday, April 17, 2009 7:53 AM
  • We can certainly understand your frustration with this issue and we appologize for it.  Please know that we are working as fast as we can to get this new release out there.  Also unforEven though SyncToy is an unsupported product, we still take great efforts to test it internally as well as through internal "dogfooding" prior to release.  With this we don't feel we can just "release this fix" until we feel absolutely confident that it is stable and ready to be used by the huge community (we just hit 1 million downloads so it is quite heavily used).  Otherwise we would just be introducing new potentially frustrating issues.

    Unfortunately we are not able to announce our official release date.

    In any case we will put a sticky note about this in this forum with the hope that others do not have this kind of frustration.

    Liam
    Program Manager, Data Replication and Synchronization - http://msdn.microsoft.com/sync/
    Monday, April 20, 2009 9:39 PM
  • Does this file corruption occur with USB hard drive syncing? Or is this isolated to NAS based solutions?
    • Proposed as answer by Jennrica Friday, May 1, 2009 1:30 PM
    Sunday, April 26, 2009 3:27 AM
  • Jippers, this is specifically isolated to NAS based solutions.
    Program Manager, Data Replication and Synchronization - http://msdn.microsoft.com/sync/
    Monday, April 27, 2009 4:13 PM
  • Does the problem exist for X64 Versions of SyncToy?  I haven't seen it yet. 
    Friday, May 1, 2009 1:31 PM
  • Hi -

    I do not actually know the answer to this - we learnt about the NAS issue only from this forum and have not actually seen this in our labs. Without being too discouraging I would say assume that it is present in the x64 solution as well and wait till we release the fix for it because we would hate for more people to end up with corrupted data.

    Deepa
    Deepa ( Microsoft Sync Framework)
    Friday, May 1, 2009 10:35 PM
    Moderator
  • Deepa,

    Thanks for your comments.  However, some pieces of information are missing... 

    What do you define as a NAS?  Example - many devices sold as NAS boxes run Linux and use Samba for file sharing.  A PC on a network can also run Linux and Samba but is not a simple NAS.  So is the problem specific to a particular Linux or Samba version, or a particular system architecture, or is it an endian issue?  Why are people reporting the problem mostly in relation to JPG files (and PDFs in a few cases)?  Surely SyncToy and any file storage solution should be agnostic regarding the file type.  How can we have any confidence that our particular backup storage will work with SyncToy?

    Given that there are announcements that there will be a fix, we must assume that Microsoft know more about this than they are telling us.  I can accept that, and I accept the fact that SyncToy is classified as "unsupported".  But given the large number of users and the seriousness of possible problems, I find the lack of clear advice in what will / will not work very unsatisfactory.

    Thanks,

    Les.
    • Edited by S80_UK Thursday, July 30, 2009 2:15 PM
    Thursday, July 30, 2009 2:14 PM
  • I would like to echo Les' comments. Please explain what causes the problem and under what conditions does it occur. So far, I haven't seen any problems with my NAS but it would be nice to know exactly what does cause a problem.

    Does it only occur for Synchronize or does it happen with Echo and Contribute?
    Does it only occur with a specific NAS OS and version?
    Does it only occur with wireless or wired?
    Why does it only occur with JPEG and PDF files?
    etc.



    If MS has fix, then they know what the problem is. Please share.
    Thursday, July 30, 2009 3:37 PM
  • I would like to know more details also, this seems like a simple solution to my NAS backup question, but would have for this to damage the backup files.
    Thursday, July 30, 2009 5:02 PM
  • I don't understand ... you said "... we learnt about the NAS issue only from this forum and have not actually seen this in our labs." and yet earlier in the thread you stataed "We have a fix for the problem and we will be sure to fix this in a future release."

    How exactly do you have a fix for it when you havn't been able to replicate it?
    Tuesday, August 4, 2009 12:56 AM
  • Hi,

    have you been able to reproduce the problem in your labs allready?

    I had the same problems reported in this forum. Everything worked fine with Version 1.4. When I upgraded to Version 2.0, the tool first copied all files from my local drive to network drive (allthough they were synchronized). Many files got corrupted. Some .mdb-files lost forms and reports and my .pst-files lost two elements (mostly contacts) each time I synchronized the drives. This is reproducable! If you need any reports, I'll be glad to help.

    Jan
    Monday, August 10, 2009 8:56 AM
  • Although I've not experienced this problem I am using synctoy across a local network
    for my photos and fear that I may be exposed...

    I'm using synctoy 2.0.100.0 in Contribute mode.

    Should I be worried about file (image) corruption??

    Tom
    Monday, August 10, 2009 3:31 PM
  • I am experiencing the same problem since today.

    I have the original photo's on my C: drive and used synctoy 2.0.100.0 to make the backups many times before.

    Since today synching (echo) to my:
    - local extra harddrive : no problems (not in the past, not today)
    - new wired freecom NAS drive: many files corrupted when I newly synched all photo's to this drive.
    - USB toshiba drive: never had problems until today?? Only the recent photo's that were synched today are corrupted, the older photo's are OK.

    what changed that made this problem occure only now and not in the past?

    I am willing to provide any info you like:
    - using XP.
    - allways take the latest updates available.

    Please let me know when that fix is available.

    Arien
    Monday, November 2, 2009 9:08 PM
  • Just wanted to let everyone know that SyncToy 2.1 has been released and the notes indicate that they have resolved the NAS issue:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=c26efa36-98e0-4ee9-a7c5-98d0592d8c52&DisplayLang=en
    Wednesday, November 11, 2009 8:20 AM
  • Finally, that is great news! Has anybody tested it yet?
    Wednesday, November 11, 2009 11:19 AM
  • Any confirmation to the update by MS other than the web site?
    Wednesday, November 11, 2009 1:51 PM
  • I've just tested the new version without errors - so far...
    Wednesday, November 11, 2009 3:10 PM
  • First of all, I want to thank all of you for choosing SyncToy as your utility to sync up your files, and for proactively following up and updating with your findings for this issue.

    We have been seeing a few issues reported related with NAS as one of the end points for sync. so I want to start with this thread asking for some info. on this.

    regardless if you have encountered issues with NAS or sucessfully sync-ed up you folder pairs already with syncToy2.1, could you provide info as: 

    ·          what is the sync option, e.g. synchronize, echo or contribute?

    ·          how many files, how big are they, what type of the files ?

    ·          how is your NAS configuration looks like ?

    ·          if you have issues, what kind of issues, are there any exception in the SyncToy Log ?

    ·          other info you think it would be worth to mention.

    thanks
    Yunwen

    is provided "AS IS" with no warranties, and confers no rights.
    Thursday, December 3, 2009 10:34 AM
    Moderator
  • I have been using SyncToy 2.0 to back up ~50,000 photos to a NAS device (echo). I have not checked the destination files for corruption, but assume that I do have some corrupt files. I switched to using AllWay Sync to back up new files, but have not yet done anything about the potentially corrupt existing files.

    How can I force SyncToy 2.1 to overwrite the corrupt files? (I see there are still some 2.1 issues, so I may wait until these are resolved, but the question still stands).

    Thanks,

    Gary
    Thursday, December 3, 2009 4:54 PM
  • here is what you can do regarding with to  "overwrite" the corrupted files after we nail down the issue with NAS.

    assuming the NAS is on right side.

    1. delete the folder pair
    2. delete the corrupted files
    3. recreate the folder pair
    4. sync

    this should limited the filed being transfered with only the deleted ( corrupted ) files.

    thanks
    Yunwen


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, December 3, 2009 7:24 PM
    Moderator

  • My problems are gone now with the 2.1 version.

    Currently syncing all files to the local drives, NAS drive and USB drive: no more corrupted files.
    Sure I had to delete the old files and make new folder pairs.
    - Syncing only with Echo option (for backup purposes)
    - both large quantities of photos (9GB, 25000 files in 2000 dirs) as also a couple of 200MB .pst files
    - NAS drive is on FAT32 (right side) while the orginal is on NTFS (left side)
     
    Thank you for the new version! Sure this has cost me some time but now I can trust my backup again.

    regards,
    Arien
    Sunday, December 27, 2009 4:22 PM
  • Just FYI, I ran into data corruption myself (images showing blocks, songs skipping or stopping in middle,...).  My corruption however stemmed from a bad hard drive (brand new) that reported no errors in all the burn-in testing I did, but was corrupting the data.  I found that a good way to compare which files are corrupt and not is to use a comparison tool.  I used Araxis Merge.  Worked great at showing me all the files that were bad.
    Sunday, March 21, 2010 7:09 PM
  • HI  Jennrica and others

     

    I have been having tthis problem and I dont know how far this has been solved  ...At first I thoguht it was bevcause i was syncing so much data and it was the USB that wwas a problem  I have a corsair survivor 30GIG.

    I sync with synctoy 1.4.00

     

    I see - out of the blue one or two folders go completely corrupt and then I have to reformat the USB....

    Please help.

    Its driving me a bit crazy...

    Mark.

     

    Saturday, June 19, 2010 10:32 AM
  • HI There I am having a file corruption problem with 1.4 and was thinking now of going for a newer one.

    I work on XP.

    I sync a lot of stuff to a corsair survivor 30gig USB and quite big files sometimes like avi's

    I thought it was the USB and not SYNC 2 - what other sync programs are there out there...

    Please advise.

     

    Thanks

    mark

    Saturday, June 19, 2010 10:37 AM