locked
Urgent: Turn on Automatic Updates RRS feed

  • Question

  •  

    Every time I boot up my computer, the icon is green for about a minute, and then turns red.  Upon opening OneCare, there is a message that states "Urgent:  Turn on Automatic Updates:  Windows Automatic Updates isn't set to download and install high-priority updates automatically.  This PC may be at risk for Internet threats."  There is a button to the side that says "Turn On".  The odd thing is, my computer is set for Automatic Updates.  I'm using Windows Home Basic, which was installed over Windows XP SP2.  Services.msc tells me that there is no "Windows Automatic Update", but a "Windows Update" that is set for "delayed start".  Windows Live OneCare is set for "Automatic".  I thought that maybe OneCare was starting before the Windows Update and that is why I'm getting this message.  If I change the settings, the situation, however, is worse.  Upon rebooting the computer and logging into my user account, I receive a dire message that Windows OneCare could not be activiated and that I should try rebooting my computer. 

     

    By the way, when I push the button, "Turn on", everything works find after that.  So, a minor annoyance. 

    Monday, December 17, 2007 2:17 AM

Answers

  • There have been a few reports of this happening intermittently. I've had it once on one of my PCs for no apparent reason. However, yours is the first I've heard of where this happens every time you boot the PC. I suggest contacting support to have this investigated and escalated, if needed, as you may have a dependent service turned off or some other issue causing OneCare to not know AU is on and working.

    -steve

    Monday, December 17, 2007 6:07 PM
    Moderator

All replies

  • Each time I restart Windows, OC starts w/ red icon and reports "critical action needed." When I open OC it reports "auto update not enabled." I click "enable," icon goes green and all is well until next restart; then, same issue; Auto Updaes is ALWAYS enabled in security center, even while OC is reporting "not enabled."

     

    Anyone else seeing this? Any idea what causes, how to fix?

     

    TIA---David Rowell

    Monday, December 17, 2007 4:59 PM
  • There have been a few reports of this happening intermittently. I've had it once on one of my PCs for no apparent reason. However, yours is the first I've heard of where this happens every time you boot the PC. I suggest contacting support to have this investigated and escalated, if needed, as you may have a dependent service turned off or some other issue causing OneCare to not know AU is on and working.

    -steve

    Monday, December 17, 2007 6:07 PM
    Moderator
  • Thanks, Stephen.

     

    Monday, December 17, 2007 8:48 PM
  • Hello David, there have been a few other reports of this issue. I suggest contacting support for help. You can reach support by using the help link in the One Care console.

     

    Monday, December 17, 2007 11:30 PM
    Moderator
  • Stephen I have the same issue with version 2 in that the auto updates turn off and display a red icon. The difference with mine is that when I turn it back on it only stays on for about five minutes and then reverts to off. Annoying and a huge bug somewhere. I have recently installed a program called TVersity that allows me to watch divx movies through my xbox360 across the lan, maybe something to look at. Am running Vista home premium SP1 RC1. Was all good in version 1.6 of onecare but didn't have SP1 or TVersity on then. Will post again if I come up with any results.

     

     

    Regards,

    Andrew Owen

     

    P.S. Uninstalled TVersity while typing this thereby uninstalling the service but still turning off auto updates.

     

    Thursday, January 3, 2008 11:00 AM
  • Thanks for the additional information, Andrew. Do keep us posted if you have any new developments as this thread remains unanswered.

    -steve

     

    Thursday, January 3, 2008 8:06 PM
    Moderator
  • I did contact support.  They advised me to run the tool to clear out the database.  That did work, a bit.  What seems to happen now is that the icon starts green, then turns red (the same advice to "Turn On Automatic Updates" shows up), then, after about an hour, the icon turns green, again.  I've been doing some work on the computer, so I just left it at "red" status when I started.  I was a bit surprised to discover that it was turning green on its own after a period of time (about an hour).  Well, I'm supposed to renew my subscription in a few weeks and I think that I'll stick with it.  Still, it has been more of a hobbyist's experience rather than a program that you plug in and forget about.

    Thursday, January 3, 2008 10:25 PM
  • Fergy3453

     

    I have also tried the clean database tool, uninstalling etc and all other options put forward with no success at all.

    If they could just post the old 1.6 version, I had no problems with that.

    I hope they find an answer soon.

     

    Regards,

    Andrew

     

    Friday, January 4, 2008 12:26 PM
  • Every two days One care gives me a red system critical message to say that "Windows Automatic Updates" is turned off. When in fact it is on. It's so annoying and makes me wonder what's wrong with Onecare and does it actually do anything? Or does it just make up messages to make me think it's on top of stuff? I run Vista which may be the source of all computer woes - I realy should downgrade back to XP

    Sunday, January 6, 2008 2:46 AM
  • I have the exact same problem with VISTA Ultimate. It starts green and turns red after a short while.

    I cleaned the DB and reinstall, then disabled all startup programs, and it seem to work.

     

    I am still researching what program caused it, but I suspect that one of logitech programs is involved.

     

    Do you have Logitec WebCam? if you do, try to disable it.

     

    TIA

    Motty

    Sunday, January 6, 2008 7:49 AM
  • I personally don't have a logitech webcam only mouse and keyboard. I have noticed today that onecare has fixed itself and is now showing green. I have no idea why, will keep posting with updates.

     

    Regards,

    Andrew

     

    Sunday, January 6, 2008 9:19 AM
  • Andrew

     

    It turns out that Logitech is clear....

    I narrowed it down to a process named WrtMon.exe located in a subfolder under system32.

    I am trying to find out what it this process, but disabling it solved my problem.

     

    HIH

    Motty

     

    Sunday, January 6, 2008 11:13 AM
  • I will share how I finally dealt with the annoying messages from Security Center:

     

    1) GOTO "START" and click on "RUN"

    2) Enter "services.msc" (without the quotes)

    3) Scroll down until you find "Security Center"

    4) In the "startup type" column, right-click and select "Properties"

    5) Select "Disable", tell it OK and restart your computer

     

    What this does is disable Security Center's monitoring functions (firewall and antivirus), but it does leave the Automatic Updates alone (ON if you have it set that way and you still have the ability to change it...though Windows OneCare will know and throw a tantrum).

    For some reason, Microsoft doesn't have as much confidence in Windows Live OneCare to monitor system security all by itself as do the end users. Their cookie jar response is "It wasn't designed to do that"...in the meantime you are basically on your own as the OneCare Support Team doesn't have a clue what's going on...and their fixes only last about a day or so.

    I am sure our wonderful moderators will ring in on this one...standby...it should get very exciting.

     

    Best Regards

     

     

    Monday, January 7, 2008 3:07 AM
  •  mottych wrote:

    Andrew

     

    It turns out that Logitech is clear....

    I narrowed it down to a process named WrtMon.exe located in a subfolder under system32.

    I am trying to find out what it this process, but disabling it solved my problem.

     

    HIH

    Motty

     

    As near as I can find out, this file is used for some 3rd party printer driver functionality.

    -steve

    Tuesday, January 8, 2008 1:56 PM
    Moderator
  •  rps_westvan wrote:

    Every two days One care gives me a red system critical message to say that "Windows Automatic Updates" is turned off. When in fact it is on. It's so annoying and makes me wonder what's wrong with Onecare and does it actually do anything? Or does it just make up messages to make me think it's on top of stuff? I run Vista which may be the source of all computer woes - I realy should downgrade back to XP

    I merged your post into the other open thread on this topic. The cause of this problem is unknown, but one person in the thread you're being merged with reported success in resolving the problem by disabling a process at startup.

    Apparently, there is some sort of disconnect between the reporting of AU status and OneCare, but I don't know what that could be yet.

    -steve

    Tuesday, January 8, 2008 2:26 PM
    Moderator
  •  Perplexed Again wrote:

    I will share how I finally dealt with the annoying messages from Security Center:

     

    1) GOTO "START" and click on "RUN"

    2) Enter "services.msc" (without the quotes)

    3) Scroll down until you find "Security Center"

    4) In the "startup type" column, right-click and select "Properties"

    5) Select "Disable", tell it OK and restart your computer

     

    What this does is disable Security Center's monitoring functions (firewall and antivirus), but it does leave the Automatic Updates alone (ON if you have it set that way and you still have the ability to change it...though Windows OneCare will know and throw a tantrum).

    For some reason, Microsoft doesn't have as much confidence in Windows Live OneCare to monitor system security all by itself as do the end users. Their cookie jar response is "It wasn't designed to do that"...in the meantime you are basically on your own as the OneCare Support Team doesn't have a clue what's going on...and their fixes only last about a day or so.

    I am sure our wonderful moderators will ring in on this one...standby...it should get very exciting.

     

    Best Regards

     

     

    I'm glad that you found a way to disable the Windows Security Center warnings, but the post you answered had nothing to do with the Security Center. I merged the thread into an open discussion on problems with One Care reporting that AU is off, when it is in fact on.

    Note that you should have been able to resolve the Windows Security Center warnings a little easier by either using the WMI database repair instructions posted here - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2469173&SiteID=2 - or by opening the Security Center and selecting to "Change the way Security Center alerts me..." for antivirus, firewall, and spyware protection.

    I believe that the reason that OneCare does not disable the Security Center notifications is that it provides a failsafe in the event that OneCare does fail to load or becomes badly damaged.

    -steve

     

    Tuesday, January 8, 2008 2:34 PM
    Moderator
  • I just downloaded Live OneCare for the 90 day trial. I also get message that my automatic windows update is not set to "ON". When I check the settings it is set for auto update. Can't seem to convince OneCare that it is wrong. Have there been any improvements on this issue? It is more annoying than critical for me but I hate seeing those red warning icons all the time when I know it is wrong.

     

    AnyThoughts?

    Sunday, July 13, 2008 10:13 PM
  •  Keithct wrote:

    I just downloaded Live OneCare for the 90 day trial. I also get message that my automatic windows update is not set to "ON". When I check the settings it is set for auto update. Can't seem to convince OneCare that it is wrong. Have there been any improvements on this issue? It is more annoying than critical for me but I hate seeing those red warning icons all the time when I know it is wrong.

     

    AnyThoughts?

    As you can see by the fact that this thread remains unanswered, that there have been other reports of the problem - both intermittent and at every reboot - and no specific fix has been reported here that we're aware of.

    If you click the link from the OneCare warning to turn on Automatic Updates, does it clear the warning and make OneCare happy until the next reboot or some future time? Have you turned it off and back on again from Control Panel/Automatic Updates? Have you tried the Windows Security Center fix to reset the WMI repository? 

    http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2469173&SiteID=2

     

    If none of the above help, I suggest contacting support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Tuesday, July 15, 2008 12:09 AM
    Moderator
  • I have the same problem. Can't figure out why it just keeps turning on & off. Am reading posts to try & find answers. I'm afraid if this doesn't get cleared up, OC will end up losing a lot of business. Which is a shame, as it's basically a good program.
    Friday, March 20, 2009 3:35 AM
  • Contact support. One cause of this problem is malware. If it made it past OneCare's protection and is causing the issue, then OneCare support can help resolve it.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Friday, March 20, 2009 2:34 PM
    Moderator