locked
UPnP still being set to 80 & 443 even though I changed bindings. Disable UPnP in Vail? RRS feed

  • Question

  • I wanted both my WHS and Vail servers to be accessible from outside the network. My WHS is already set to use 80, 443, 4125, & 3389. I wanted Vail to be able to use 81 & 444. I was hoping a simple port redirection in my router would have worked but it didn't (WAN 444 > Vail 443). I changed the HTTP and HTTPS bindings in IIS and set a firewall rule. (It took me forever to get that part working because I did not think of the firewall...). But I see in the router that Vail is setting UPnP to use 80 and 443 still (which in turn messes up my port forwarding to my WHS).

    Shouldn't the Dashboard be smart enough to look at the bindings and see that I changed them rather than still using the default settings?

    So here's my question: How do I disable UPnP in Vail? The simple solution is to disable UPnP in my router (which is what I am doing for the time being) but I still want that capability.

    PS. Don't attempt to set up Vail without a network connection. It doesn't like that and gets stuck in a loop during setup...

    Monday, May 3, 2010 1:58 AM

Answers

  • Turn UPnP off in your router. Vail will detect that your router is manually configured, and respond appropriately. Vail (Windows Home Server in general) isn't designed for complex networks with multiple servers on different ports. It really expects to be the only server in the home, so things (like this) that can be simplified by assuming that it is, indeed, the only server have been for the most part.

    That said, you should submit a product suggestion on Connect if you would like to see behavior in this area changed.


    I'm not on the WHS team, I just post a lot. :)
    Monday, May 3, 2010 2:05 AM
    Moderator
  • Ken is correct, Vail and WHS will just attempt to configure the router automatically via UPnP.  To prevent this, turn off UPnP on your router.
     
    While it’s not officially supported or tested, you can go into the bindings within IIS and change the default ports to something else that it listens to.  I’d suggest adding instead of replacing (although for HTTPS you need to replace).
     
    Good luck,
       Sean
     
    This post is "AS IS" and confers no rights.
     
    "Dkissane" wrote in message news:5172b71f-f7c6-4ca4-aa9c-624ee50e00f5...

    d_sellers1

    Could you provide a bit more detail on how you set up the alternate ports and firewall changes?  I was looking to do the same thing, but could not get it working. Thanks.

    Monday, May 3, 2010 4:41 PM
    Moderator

All replies

  • Turn UPnP off in your router. Vail will detect that your router is manually configured, and respond appropriately. Vail (Windows Home Server in general) isn't designed for complex networks with multiple servers on different ports. It really expects to be the only server in the home, so things (like this) that can be simplified by assuming that it is, indeed, the only server have been for the most part.

    That said, you should submit a product suggestion on Connect if you would like to see behavior in this area changed.


    I'm not on the WHS team, I just post a lot. :)
    Monday, May 3, 2010 2:05 AM
    Moderator
  • d_sellers1

    Could you provide a bit more detail on how you set up the alternate ports and firewall changes?  I was looking to do the same thing, but could not get it working. Thanks.

    Monday, May 3, 2010 2:15 PM
  • Ken is correct, Vail and WHS will just attempt to configure the router automatically via UPnP.  To prevent this, turn off UPnP on your router.
     
    While it’s not officially supported or tested, you can go into the bindings within IIS and change the default ports to something else that it listens to.  I’d suggest adding instead of replacing (although for HTTPS you need to replace).
     
    Good luck,
       Sean
     
    This post is "AS IS" and confers no rights.
     
    "Dkissane" wrote in message news:5172b71f-f7c6-4ca4-aa9c-624ee50e00f5...

    d_sellers1

    Could you provide a bit more detail on how you set up the alternate ports and firewall changes?  I was looking to do the same thing, but could not get it working. Thanks.

    Monday, May 3, 2010 4:41 PM
    Moderator