locked
Namecheap Dynamic DNS and Vail RRS feed

  • Question

  • I'm sorry to ask another question again so soon,

     

    Right now i'm attempting to get Dynamic DNS to work in order to access the system's web UI away from the home network. The router has all necessary ports forwarded as I've seen come up so far, and the domain has been created and prepared with the necessary configuring

    I have to configure my domain manually as i'm using namecheap's Dynamic DNS service, which uses a EXE file i run the server (linked below) and i have book with the server. It runs and redirects the IP, however instead of going to my server, when entering the HTTP it just goes to the login screen for my router


    Why isn't the Dynamic DNS service redirecting the hostname to my server, and instead sending it to my router's login at 192.168.1.1, while the server is on 192.168.1.7


    Thanks,

     

    http://www.namecheap.com/resources/help/index.asp?t=dynamicdns

    Sunday, May 23, 2010 3:59 AM

Answers

  • This is a router configuration issue. Read your router's manual to learn how to turn off the external web interface. You should leave the local web interface active for router management. You should turn off external management of your router anyway; there are known vulnerabilities for some routers and firmware versions which allow malefactors to take control of your home router for various purposes, usually non benign.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, May 23, 2010 1:50 PM
    Moderator

All replies

  • This is a router configuration issue. Read your router's manual to learn how to turn off the external web interface. You should leave the local web interface active for router management. You should turn off external management of your router anyway; there are known vulnerabilities for some routers and firmware versions which allow malefactors to take control of your home router for various purposes, usually non benign.
    I'm not on the WHS team, I just post a lot. :)
    Sunday, May 23, 2010 1:50 PM
    Moderator
  • 4wetpaws

    Are you trying to access your server from within your local network? If so, that is normal - try accessing it from an external internet connection.

    Phil

    Sunday, May 23, 2010 2:22 PM
  • Hi, made some progress with the dynamic dns Typing the address on an external network gives a 404 not found message in only text, which makes me assume its coming from thw WHS Also trying to connect to remote desktop via the address does not worked. probably means i forgot to configure something on the server or router.
    Sunday, May 23, 2010 3:32 PM
  • I'm sorry to ask another question again so soon,

     

    Right now i'm attempting to get Dynamic DNS to work in order to access the system's web UI away from the home network. The router has all necessary ports forwarded as I've seen come up so far, and the domain has been created and prepared with the necessary configuring

    I have to configure my domain manually as i'm using namecheap's Dynamic DNS service, which uses a EXE file i run the server (linked below) and i have book with the server. It runs and redirects the IP, however instead of going to my server, when entering the HTTP it just goes to the login screen for my router


    Why isn't the Dynamic DNS service redirecting the hostname to my server, and instead sending it to my router's login at 192.168.1.1, while the server is on 192.168.1.7


    Thanks,

     

    http://www.namecheap.com/resources/help/index.asp?t=dynamicdns

    You have two issues:

    1.        It sounds like your router is not port forwarding to Vail

    Access your router’s setup and check the UPnP settings.  Ports 80, 443 and 55000 need to be directed at the Vail Intranet (192.168.1.7) IP

    2.        Once you have the traffic pointed at Vail you will find you need an SSL Certificate

    The IIS 7 self-signed Certificate will not work because it won’t include the DynDND address.

    Use selfssl.exe instead (http://www.netometer.com/tools/SelfSSL.zip )

    Remote Desktop into Vail and from an elevated Command Prompt (Run as Admin)

    The command you want to use is:

    selfssl.exe /N:CN=vail.changeip.com /V:1095 /S:1
    where
    CN is your URL, V is the number of days you want the certificate to be valid and S is the ID number of the website in IIS Manager (it is #1 for both WHS1 and Vail)

     

     

     

    Wednesday, May 26, 2010 6:06 PM
  • 80 and 443 yes, 55000 no.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, May 26, 2010 8:50 PM
    Moderator
  • 80 and 443 yes, 55000 no.
    I'm not on the WHS team, I just post a lot. :)

    Ken is correct. For what you want you only need 80 and 443.  Port 55000 is made use of by the IIS website but it looks like port 55000 is only used for the http://vail/connect webpage (to install the Client connector package)
    Thursday, May 27, 2010 6:48 PM