locked
Email router problems in CRM 2011 RRS feed

  • Question

  • I have some problems with the email router in CRM 2011. I'm trying to set up a CRM-server that will be used in a support organization and will have tickets emailed to a support address. For this reason I've set up a queue with the emaiaddress support@organization.com which has an email account on the email server.

    The email-replies that has a CRM source did not get tracked to the case that they originated from so I tried to set up a forward email box to which I forwarded all emails from the support address. This did not work out either since no emails were pushed to the CRM. When I looked at the logs I found that the emails were indeed processed but rejected since the CRM did not find any user or queue that matched the SENDING email address.

    The CRM server and email router are both updated to UR5, which was supopsed to fix the matching of sending email address according to the KB. Has anyone successfully set up a similar system? Would it differ if the email server were of POP3 och Exchange?


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    Monday, January 2, 2012 8:19 AM

All replies

  • What is the exact error message you see in the CRM Server trace?

    You can check the emailsearchbase table, check whether you can find a record with the sending email address  or the queue email address. All CRM User or reocord's email address should exist in this table.

    You can also go to  Settings=>administration=>system settings=>Email tab=>Allow message with unresolved e-mail recipients to be sent, select yes.

    BTW, could you please show me the KB you mentioned?

     


    Jackie Chen, Microsoft Online Community Support. Please remember to click “Mark as Answer” on the post that helps you. This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, January 4, 2012 8:21 AM
  • The Application log says the following:

     #17174 - An error occurred while validating the e-mail message with subject "test" in mailbox testforward@org.com. Microsoft.Crm.Tools.Email.Providers.EmailException: E-mails for address <sending email address>@org.se in forward mailbox could not be processed as the e-mail address is not associated with any approved forward mailbox user or queue record in CRM. at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.CheckForApprovedForwardMailboxUsersOrQueue(EmailMessage emailMessage) at Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider.ValidateMessageInternal(EmailMessage emailMessage) at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()

     

    This is the KB I was referring to: http://support.microsoft.com/kb/2567454.


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    Monday, January 9, 2012 1:43 PM
  • We're getting the exact same error.  We are using POP3.  Also set the Allow message with unresolved e-mail recipients to be sent to 'yes'.
    Thursday, April 5, 2012 10:33 PM
  • Create the forward mailbox as a user in CRM.

    Restart Email router and publish the settings.


    You can also remove from CRM settings -> Users/Queues needs to be aproved for sending emails.
    Friday, April 6, 2012 7:22 AM