locked
No mapping exists from object type Telerik.Web.UI.RadMaskedTextBox to a known RRS feed

  • Question

  • hi for all i got this problem when i try to update record in a database actually it's first

    time happining with me

    No mapping exists from object type Telerik.Web.UI.RadMaskedTextBox to a known
    managed provider native type

    and this is my code

    SqlCommand cmd = new SqlCommand("update RealEstate set  DestinationEntity=@speechDirect,FULLName=@name,Individual_Iqama_NR=@egamhNo,Individual_Passport_NR_ID=@passport,Individual_Gender=@six,Individual_Sociall_Status=@martialstate,Individual_Passport_Issue_Date=@passportdate,Individual_Nationality_ID=@nationality,IqamaIssued_From=@egamhsource,Total_Staying_Time_KSA=@stayduration,Individual_Work_Address=@workdisc,Possess_Type=@omntype,Apartment_No=@estateno,Apartment_Floor_No=@storyno,Possess_City_ID=@city,QuarterID=@area,Deed_No=@InstrumentNo,Deed_Date_HijriAfter=@Instrumentdate,Deed_Issue_City_ID=@Instrumentsource,Request_Status=@orderstate,Real_Estate_Area=@estatespace,[notes]=@notes,Incomming_No=@waredno,Incomming_Date_HijriAfter=@wareddate,Qaied_No=@ghaidno,Qaied_Date_HijriAfter=@ghaiddate,ExportNumber=@jihtsdor, ExportDateHijriAfter=@job where Possess_ID=@id", _con);
            cmd.CommandType = CommandType.Text;
           
    
            _con.Open();
            
            cmd.Parameters.AddWithValue("@id", int.Parse(Request.QueryString["Serial"].ToString()));
            cmd.Parameters.AddWithValue("@speechDirect", RadComboBox1.SelectedValue);
            cmd.Parameters.AddWithValue("@name", txtname.Text);
            cmd.Parameters.AddWithValue("@egamhNo",txtegamhno.Text);
            cmd.Parameters.AddWithValue("@passport", txtpassportno.Text);
            cmd.Parameters.AddWithValue("@six",RDSix.SelectedValue);
            cmd.Parameters.AddWithValue("@martialstate", Rdstatus.SelectedValue);
            cmd.Parameters.AddWithValue("@passportdate", DateTime.Now);
            cmd.Parameters.AddWithValue("@nationality", RdNationality.SelectedValue);
            cmd.Parameters.AddWithValue("@egamhsource", txtegamhsou.Text);
            cmd.Parameters.AddWithValue("@stayduration", txtstayduration.Text);
            cmd.Parameters.AddWithValue("@workdisc", txtjobdirec.Text);
            cmd.Parameters.AddWithValue("@omntype", RdownType.SelectedValue);
            cmd.Parameters.AddWithValue("@estateno",txtflatNo.Text);
            cmd.Parameters.AddWithValue("@storyno", txtstoryNo.Text);
            cmd.Parameters.AddWithValue("@city", RDcity.SelectedValue);
            cmd.Parameters.AddWithValue("@area", RadComboBox2.SelectedValue);
            cmd.Parameters.AddWithValue("@InstrumentNo",txtskno.Text);
            cmd.Parameters.AddWithValue("@Instrumentdate", txtskdate.Text);
            cmd.Parameters.AddWithValue("@Instrumentsource", Rdsksource.SelectedValue);
            cmd.Parameters.AddWithValue("@orderstate", Rdordercase.SelectedValue);
            cmd.Parameters.AddWithValue("@estatespace",txtspace.Text);
            cmd.Parameters.AddWithValue("@notes", txtcomments.Text);
            cmd.Parameters.AddWithValue("@waredno",txtwaredno.Text);
            cmd.Parameters.AddWithValue("@wareddate", txtkitabno.Text);
            cmd.Parameters.AddWithValue("@ghaidno", txtgaidno.Text);
            cmd.Parameters.AddWithValue("@ghaiddate",txtghaiddate.Text);
            cmd.Parameters.AddWithValue("@jihtsdor",Rdsksource.SelectedValue);
            cmd.Parameters.AddWithValue("@job", txtsaderdate);
            int x =cmd.ExecuteNonQuery();

    any one could provide suggestion to solve this problem

    thanks

    • Moved by Fred Bao Monday, May 5, 2014 8:53 AM
    Monday, April 28, 2014 7:45 AM

Answers

  • This forum is for the dataset, you're are not using it.

    Beside that it can be problem in the Telerik control, so ask it to the makers of that.

    This is about Microsoft tools you know. It is like asking in a Mercedes show why your Nano is not running.


    Success
    Cor

    • Proposed as answer by Fred Bao Tuesday, April 29, 2014 1:33 AM
    • Marked as answer by Just Karl Thursday, May 15, 2014 8:44 PM
    Monday, April 28, 2014 10:03 AM
  • Hello,

    I would like suggest you posting it to:

    http://www.telerik.com/support

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Just Karl Thursday, May 15, 2014 8:44 PM
    Tuesday, April 29, 2014 1:33 AM

All replies

  • This forum is for the dataset, you're are not using it.

    Beside that it can be problem in the Telerik control, so ask it to the makers of that.

    This is about Microsoft tools you know. It is like asking in a Mercedes show why your Nano is not running.


    Success
    Cor

    • Proposed as answer by Fred Bao Tuesday, April 29, 2014 1:33 AM
    • Marked as answer by Just Karl Thursday, May 15, 2014 8:44 PM
    Monday, April 28, 2014 10:03 AM
  • Hello,

    I would like suggest you posting it to:

    http://www.telerik.com/support

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Just Karl Thursday, May 15, 2014 8:44 PM
    Tuesday, April 29, 2014 1:33 AM