locked
My Solution is broken; how can I fix it? RRS feed

  • Question

  • I developed a Solution consisting of two projects: (1) MyAppCode; and (2) MyAppInstall. I successfully built the Solution, successfully Installed it (on my machine), and successfully tested the installed code. I then, using Add/Remove Programs, removed the application, and, after a lunch break, tried to open the MyAppCode project, but was showered with a host of errors regarding "Designer" faults and missing Control files. I noticed that there is now a MyAppInstall Solution file as well as the original MyAppCode Solution file.

    Why did this happen, and how can I make it "unhappen"?

    Price Buhrman

    • Moved by lucy-liu Thursday, April 12, 2012 3:36 AM it is not a msbuild issue (From:MSBuild)
    Thursday, April 5, 2012 9:46 PM

Answers

  • I restarted my development from scratch, and the problems have not recurred.

    This thread is moot and can be closed.

    Price Buhrman

    • Marked as answer by BuhrmanP Monday, May 14, 2012 7:57 PM
    Saturday, April 28, 2012 9:20 PM

All replies

  • I restored a prior version of my application, but it opened with the same cluster of errors. Believing that VS 2010 code was broken, I reinstalled the product (from a DVD). Still the same errors.

    The errors reported seemed to suggest Registry corruption, so I browsed forum topics on that subject. There, I learned that MSBuild uses the Registry to manage the control of an application under development!

    Now, it would seem, I must try to fix the Registry manually (but how?), delete my setup project and define a new one from scratch (with a different name?), go back to VB6 and retrace my migration path (on another machine?), or just bag it.

    The errors included two "validating" an HRESULT, a ClassDiagram2.cd "not added", and a [TARGETDIR] file "not found or locked". All referenced files exist in my development folder tree.

    Any pointers to fixes or work-arounds will be welcome, since in the meantime I will just be staring at the wall or incesently checking my inbox.

    Price Buhrman


    • Edited by BuhrmanP Sunday, April 8, 2012 8:20 PM text error
    Sunday, April 8, 2012 8:18 PM
  • Hi BuhrmanP,

    The MSBuild forum only discusses the the Microsoft build engine aka MSBuild. Topics including: usage of MSBuild, build customization, and MSBuild extensibility via tasks, loggers and hosting.

    This is not a MSBuild issue, I suggest you to write it to a more suitable forum for a better support.

    If you have no idea which forum should be, you can post it to Where is the Forum For…? forum. they will tell you which forum should it be.

    Thank you for your understanding!


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 9, 2012 4:35 AM
  • I restarted my development from scratch, and the problems have not recurred.

    This thread is moot and can be closed.

    Price Buhrman

    • Marked as answer by BuhrmanP Monday, May 14, 2012 7:57 PM
    Saturday, April 28, 2012 9:20 PM