locked
Laptop that is normally connected to a corporate domain RRS feed

  • Question

  •  

    I have a question about how I can have my company laptop get full access to my WHS shares without having to unmap and remap drives with a user name that is setup on the WHS.  I log into my laptop at home using my corporate sign on.  If I want to get access to my WHS shares I need to map the drives and then use the user name and password that I setup on the Home Server.  Every time I disconnect and reconnect my laptop to my home network I have to disconnect the mapped drives and re-create them and then I can get access to the shares.  Is there a way around this?  I don't want to have to log in on my laptop with a account that is setup on my WHS.  Everything I do on my laptop is under the corporate profile I use in my day-ta-day activities.  I don't want to manage 2 user accounts on my Vista Laptop.  Also I am running 64bit and I know I can't yet use the WHS connector software until Power Pack 1 is released.

     

    Thanks

    -Scott

    Friday, May 16, 2008 1:17 PM

Answers

  • You don't need to map drives.  If you have the same username and password defined in the WIndows Home Server Console as Brubber suggests, then you can simply navigate to \\<server_name> in IE or WIndows Explorer and you will have access to the Shared Folders on your home server that you have permissioned the above user to have access to ...

    Friday, May 16, 2008 3:12 PM

All replies

  • Just make sure the username and password on your WHS match your corporate login.

    Friday, May 16, 2008 2:42 PM
    Moderator
  • You don't need to map drives.  If you have the same username and password defined in the WIndows Home Server Console as Brubber suggests, then you can simply navigate to \\<server_name> in IE or WIndows Explorer and you will have access to the Shared Folders on your home server that you have permissioned the above user to have access to ...

    Friday, May 16, 2008 3:12 PM
  • Another option is to enable the guest account on WHS or just enter the username and password when prompted. When you try to access the shares on your server for example \\server\videos your laptop should prompt you for a username and password. Make sure you have a user on your server with a different username than your domain user. By default, the laptop tries the username and password of  your domain user. If the password is different for this username on your WHS it won't be able to connect. I have my corporate laptop connected to WHS and when I had frist set everything up, I synchronized the passwords on all my home machines and WHS with the domain password. In the meantime, though, they are different because I'm forced to change my domain password every three months. Most of the time I just need to pull down a file from WHS, so I have the guest account setup with read permissions only. I do have an issue with my laptop getting backed up to WHS, though, and come to think of it this could have started when I changed my domain password. All I had to do at the beginning was making sure the laptop is connected to the power supply. Then it would wake up during the backup window, do the backup and go back to sleep. Now it wakes up, skips the backup and goes back to sleep unless I wake up my laptop, reboot it and put it back to sleep before going to bed. Very strange. Need to try synchronizing the passwords again and see if that solves the issue.

     

    Friday, May 16, 2008 5:24 PM
  • Thanks everyone for your responses.  I am pretty sure I have tried creating my corporate username and password on my WHS and it did not work.  I will try it again and see what happens.  That seems like the obvisous solution, but again I have a feeeling that it did not work for me.  I will try this when I get back to my home later tomorrow.

     

    Thanks!

    -Scott

     

    Friday, May 16, 2008 7:36 PM
  • Hey Scott,

    Not sure if you got it working yet.  But I had the same situation with my work laptop, and I got the connector software working on mine.  It seems to work just fine.  It lets me log in, run backups of my laptop, etc.

     

    Saturday, May 17, 2008 5:11 AM
  •  Scott Micale wrote:

    Thanks everyone for your responses.  I am pretty sure I have tried creating my corporate username and password on my WHS and it did not work.  I will try it again and see what happens.  That seems like the obvisous solution, but again I have a feeeling that it did not work for me.  I will try this when I get back to my home later tomorrow.

     

    Thanks!

    -Scott

     

     

    If it doesn't work your sysadmin / IT department has probably implemented security policies that prevent you from connecting. Other things that may be a problem are identical names for (one of) the office server and your homeserver (windows server are named "server" by default), or a discrepancy between your username and the actual logon name. To check this you can do Start, Run type control userpasswords2 and hit enter.

    Saturday, May 17, 2008 5:15 AM
    Moderator
  • Still have not had a chance to try this, but I should know tonight when I get home from work.  I was not able to change my password to match the WHS password security level until I got back to my office to change it to match the security level of the WHS.  From home I could not change my password on my laptop because it had no server to authenticate my new password change.  i will post something tonight and let everyone know.

     

    Monday, May 19, 2008 12:15 PM
  • The recommended ways of dealing with a corporate laptop that needs local access to your Windows Home Server shares are:
    • Keep the password on the corporate laptop. When that changes, allow the WHS connector to propagate that change to Windows Home Server, or...
    • Use a local account on the laptop which matches an account on WHS.
    Changing the password on the corporate laptop to match WHS will be an exercise in frustration; your IT department doubtless has a domain policy that requires passwords to change regularly, and you'll wind up with additional management headaches if you try to go from WHS to the corporate laptop.
    Monday, May 19, 2008 3:07 PM
    Moderator
  • ok I tried setting up the same username and password on my WHS that I use on my laptop and I am still having issues connecting.  When I try and get to \\WHS\sharename it is still prompting me for a username and password.  Now is this because I don't have the WHS connect software running on my laptop which does not yet support 64-bit?  The only other thing I can think of is that when I was able to map a drive to a share using a differnt account name that is on my WHS I then created some offline files so that they would always be on my laptop no matter what.  Is it possible that the login info for those files is somewhere cached on my system and that is the reason the matching account I just setup is not working?

     

    Tuesday, May 20, 2008 4:02 AM
  • Another update on my issue.  Looks like I have it working now and I see what I did wrong.  When mapping my connections I needed to use the logon like this Username: WHS<computer_name>\user_Account Password: password.

     

    Now I can connect to my WHS shares with now problem.

     

    Thanks guys!

    Thursday, May 22, 2008 12:55 AM