locked
CRM 2011 Deployment Manager cannot load RRS feed

  • Question

  • I am having the problem that Deployment Manager cannot load.

    This is the screen shots, anyone can advice me what to do to fix this?

    Run from desktop I get this:

    Run from MMC:

    Could not load file or assembly "Microsoft.Crm.Tools.Admin.DMSnapin, version 5.0.0.0". This assembly is built by a runtime newer than the currently loaded runtime and cannot be load.

    Already tested run with admin, but it still fail. Please help.

    Wednesday, April 4, 2012 9:31 AM

All replies

  • Hi Melvin,

    To run Deployment Manager, you need to run Microsoft.Crm.DeploymentManager.exe from c:\Program Files\Microsoft Dynamics CRM\Tools\ because this tool needs the required DLLs (assemblies) in the same directory as the exe.

    Or for your convinence, you can create a shortcut to that exe on your desktop but do not move or copy any files from that directory.

    Hope this helps.


    Eric UNG [Senior Analyst Programmer :: Sydney, Australia]

    Wednesday, April 4, 2012 11:51 AM
  • Yes.. I am running the application from the directory you mentioned above.

    Just to mention that execute it from the EXE and from the MMC will prompt me different error message. Any idea?

    Wednesday, April 4, 2012 1:14 PM
  • Hi,

    Try this solution,

    What worked for me is to add the Preferred Domain Controller  value to MS CRM registry entries:HKLM\Software\Microsoft\MSCRM

    For doing so, follow the next steps:

    • Step 1. Right Click and click on NewString value as "PreferredDc"
    • Step 2. Add the value to PreferredDc is YourDomainControllerName you can find this in your AD by typing the command in your cmd prompt echo %logonserver%

    Thanks & Regards, MS CRM Consultant, V.Surya.

    Thursday, April 5, 2012 12:30 PM
    Answerer
  • Under HKLM\Software\Microsoft\MSCRM you should update the following key:

    configdb (REG_SZ)

    Write the sql name that hosts your MSCRM database after Data Source= ____;

    Thursday, April 5, 2012 3:15 PM
  • Tried.. it does not work..
    Monday, April 9, 2012 3:39 AM
  • Tried.. it does not work as well..
    Monday, April 9, 2012 3:39 AM
  • Exact same problem here:

    Could not load file
    or assembly 'Microsoft.Crm.Tools.Admin.DMSnapin, Version=5.0.0.0,
    Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies.
    This assembly is built by a runtime newer than the currently loaded runtime and
    cannot be loaded.

    We see the same error on 2 CRM implementations.  

    We installed Rollup 11 on both a few days ago.

    This is the first time we run Deployment Manager after installing Rollup 11.

    So is it because of Rollup 11?

    Please help!



    Best regards, Javier


    EDIT: fixed! I read the user log file crm50dmsnapin at C:\Users\crm_user\AppData\Roaming\Microsoft\MSCRM\Logs\crm50dmsnapin and the error was very obvious: Login failed for user 'DOMAIN\crm_user'. SSMS showed crm_user had no Access permissions to MSCRM_CONFIG. After granting crm_user access to MSCRM_CONFIG DeploymentManager runs OK.

    Wednesday, November 7, 2012 12:10 PM
  • Are you running the deployment manager as an administrator (right click - run as administrator)

    is the user a deployment administrator (you have to get a current deployment admin to make other users deployment admins)


    Ben Hosking
    Check out my CRM Blog
    Linked-In Profile
    Follow Me on Twitter!

    Sunday, November 11, 2012 12:20 AM