Reports not pulling parameters from CRM after enabling CBA/IFD RRS feed

  • Question

  • Hello,

    We recently needed to enable CBA/IFD on our on-premise installation.

    Ever since, Reports act reeaaaaally weird. The very same report will work for me, but not for another user, where before CBA/IFD it worked for everyone. The error is: Parameter validation failed. It is not possible to provide valid values for all parameters. (rsParameterError) 

    If I look at it in BIDS, it is saying "the ContactID parameter is missing a value"

    This report worked just fine before enabling CBA/IFD so I have a hard time with the idea that I've got something wrong on the report itself, it seems like maybe an authentication issue or something. The weird thing is, I have twelve reports all configured the EXACT same way with regards to the DataSource, and the Datasets all being FetchXML queries. Four reports based on one entity all work just fine. Of the other 8 reports that reference another entity, two work just fine and 6 give this error.

    I can't for the life of me figure out what's causing this. Is there some sort of "deploying CBA/IFD and custom SSRS reports" guide I have completely overlooked, are there special settings I need to change? Everything I've read about CBA/IFD none of it even mentions any problems or considerations with reporting so I am at a total loss here...

    Any insight or ideas where to look for answers would be greatly appreciated. I'm not seeing anything in event logs on the SQL server to guide me here

    Wednesday, April 16, 2014 4:59 PM

All replies

  • Looking into it further, it seems like a permissions issue of some kind since it works for people with one security role but not the other. Oddly enough, it won't work for me as system administrator either.

    I have narrowed it down to what seems to be having more than the User scope on the Read privilege for the entity the report is based off of.

    What's weird is this was not an issue at all before enabling CBA/IFD. I checked the FetchXML query of a report that works and one that doesn't, they both have enableprefiltering set to true so that's not it... I'm just baffled how that one little privilege issue can cause all this, and that there isn't a better error to describe what's going on... heeeeelp please! At this point I am completely stumped. Why did it stop working, and why just because someone can view more than their own records does the report break on them?

    Any insight would be greatly appreciated!

    Monday, April 21, 2014 9:52 PM