locked
OneCare blocking network from getting IP Address from router RRS feed

  • Question

  • Hi All,

     

    Before I installed OneCare on my computer everything was fine.

    My router assigned automatically an IP address to my computer by DHCP like

    IP Address 10.0.0.150.

    Gateway: 10.0.0.138.

     

    Now that I installed OneCare my computer assigns a local IP address to the networkconnection.

    Seems to me that OneCare is blocking the networkconnection from getting an IP address from the router.

     

    If I go to Advanced settings - networkconnections (I have a dutch version so I have to translate, I don't know the actual tabnames)  I see a public network connection. After changing it to Home/Work and disabeling the firewall and enable it again I can renew my IP address. For now everything is as it should be.

     

    But after some days the settings which I made are not longer working.

    I haven't changed the settings, no IP address is assigned, just a local one. The Networkconnection isn't correct.

    It seems to me that a router which assigns IP address like 10.0.0.150 are not recognized as safe.

     

    I have to repeat the steps above to get an IP address from my router. (change zone, disable/enable firewall)

    Is there an easier way to solve this problem?

     

    I have a Speedtouch router.

     

    Regards,

     

    Peter

    Monday, February 11, 2008 9:05 AM

Answers

  • All solutions provided by the support centre didn't help.

     

    I just bought a new modem and all my problems are gone.

     

    Friday, June 6, 2008 6:56 AM
  • What settings did you change? There should be no changes required for you to access the Internet via the OneCare firewall through your router. However, since you have no problem when you turn off the OneCare firewall, I recommend that you contact support to get help in determining what the actual cause of the connectivity problem is.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Friday, August 22, 2008 12:28 PM
    Moderator

All replies

  • Is this a wired or wireless connection?

    The way it is supposed to work is that the PC obtains the IP address from the router and you identify the network as "Home of Work" the first time you connect after OneCare is installed. When you reconnect, the network is recognized and the "home of Work" setting is retained.

    When you first turn on or connect the PC, what is the IP address, subnet and Gateway shown as?

    What do you mean by a "local one?" If your IP address is 10.0.0.x, with x being any number, the router is assigning that.

    If you don't disable the firewall, but simply configure the network as "Home of Work" in OneCare, can you proceed to connect to the Internet? In fact, if you make no changes, do you have Internet connectivity or is that blocked also?

    Are you using Dynamic Disk partitions by any chance?

    -steve

    Monday, February 11, 2008 1:28 PM
    Moderator
  • It is a wired connection.

     

    Before OneCare was installed the IP address was

    IP address 10.0.0.150

    Mask 255.255.255.0

    Gateway 10.0.0.138

     

    After OneCare I have an IP address like 192.x.x.x

    I have configured the network as 'Home or Work' but after a couple of days the connection is lost again.

    Networkdetection is on.

    Sharing of files and printers as streaming media are also on.

     

    If I fix the problem manualy everything is ok even when I reboot the computer.

    But the problem apears after a couple of days.

     

    I am not using Dynamic Disk partitions.

     

    Peter.

    Monday, February 11, 2008 2:11 PM
  • Okay, it appears that the 192. address would mean that the PC is generating its own address since it can't reach the DHCP server on your network.

     

    Your best bet at this point is to contact support, but I'll leave this thread open in case someone else can step in with a suggestion.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Monday, February 11, 2008 2:43 PM
    Moderator
  •  

    I have the same issue as this guy is having.  If I turn off the Firewall in Onecare I can connect to the network, after connected I can turn on the Firewall back on in Onecare and everything will be working fine.  Another thing I saw that if I leave the computer on for about 15-50min is this disconnected state it will eventurally get an IP from the Router and connect to the internet.  This happens almost everytime I boot my computer.  Any Help?
    Tuesday, March 11, 2008 4:14 AM
  •  Sun Kim wrote:

     

    I have the same issue as this guy is having.  If I turn off the Firewall in Onecare I can connect to the network, after connected I can turn on the Firewall back on in Onecare and everything will be working fine.  Another thing I saw that if I leave the computer on for about 15-50min is this disconnected state it will eventurally get an IP from the Router and connect to the internet.  This happens almost everytime I boot my computer.  Any Help?

    Have you contacted support about this?

    What is the make and model of your router and what is the connection method?

    -steve

    Tuesday, March 11, 2008 9:01 AM
    Moderator
  • In one of my previous replies I wrote that the ip address was 192.x.x.x. but in fact it is 169.254.147.96.

    So OneCare is blocking my network connection, WinXP is generating a local ip address.

     

    The problem still exists.

    Tuesday, March 11, 2008 1:59 PM
  • Same questions as I had for the other poster to the thread, Anony37 -

    1. Make and model of your router? (sorry, saw above you said Speedstream) Model?

    2. Have you contacted support?

     

    Try the following:

    Open OneCare, click on change settings.

    Firewall tab, click advanced

    Click on Ports and Protocols

    Click Add

    Name: DHCP

    TCP or UDP - select UDP

    Port Range: 67 to 67

    For connections: Outbound

    Scope: Local subnet

     

    Click Add

    Name: DHCP Response

    TCP or UDP - Select UDP

    Port Range: 68 to 68

    For connections: Inbound

    Scope: Local subnet

     

    Note that you should not need to set this up in OneCare, but for some reason, it appears that the DHCP response (and possibly the request) is not passing through the firewall.

     

    Any chance that another firewall is still active following an uninstall before OneCare was installed? Any other network software - parental controls, etc?

     

    -steve

     

     

    Tuesday, March 11, 2008 2:52 PM
    Moderator
  • I have contacted support about this.

    They suggest:

     

    Name: DHCP Response

    TCP or UDP - Select UDP

    Port Range: 68 to 68

    For connections: Inbound

    Scope: Local subnet

     

    -Add Protocols : 53(TCP), 6(TCP), 17(UDP)

     
    -6(TCP)".
    -In the name box, please type "6(TCP)".
    -Under "Protocol" ensure "TCP or UDP" has a dot and choose "TCP" in the drop down, and the port range should be "6 to 6".
    -Change the "For Connections" to be "BOTH".
    -Ensure that "Scope" says "Internet".
     
    -53(TCP)
    -In the name box, please type "53(TCP)".
    -Under "Protocol" ensure "TCP or UDP" has a dot and choose "TCP" in the drop down, and the port range should be "53 to 53".
    -Change the "For Connections" to be "BOTH".
    -Ensure that "Scope" says "Internet".
     
    -17(UDP)
    -In the name box, please type "17(UDP)".
    -Under "Protocol" ensure "TCP or UDP" has a dot and choose "UDP" in the drop down, and the port range should be "17 to 17".
    -Change the "For Connections" to be "BOTH".
    -Ensure that "Scope" says "Internet".
     
    -Click start>in the search box type regedit, right click click and run as administrator.

    -Rename HKLM\SYSTEM\CurrentControlSet\Services\MSFWHLPR\Enum to Enumold.
    -Reboot computer.
    -See if you have conection..
     
    Sofar nothing works.
    Also removed the network connector from port 1 and plugged it in port 4 of the modem.
    If Firewall is disabled the networkconnection gets the same ip address from the modem.
    I think the modem always assigns the same ip address to the same mac.
     
    Modem is SpeedTouch V510i
     
    Peter.
    Tuesday, March 11, 2008 3:14 PM
  • I don't know why they asked you to add that many other ports. The DHCP ports are 68 and 67.

    Port 53 is for DNS  and you aren't having a problem with that.

    I have no clue why they would want you to open 6 and 17.

    I recommend that you delete those additions as soon as possible.

    -steve

     

    Tuesday, March 11, 2008 7:15 PM
    Moderator
  • No, I haven't contacted support yet, as you can see I don't have time to get on the phone with support for hrs for this, right now (I couldn't reply to you until now).  I know the work around, so for now I'll just use that.  I'll call support later when I get a chance.

    My router is from Verizon Fios, It is an Actiontec router MI424WR.

     

    Thursday, March 27, 2008 3:04 AM
  • Nope, I am still getting blocked from getting IP address from router.  Only way for me to get IP is to turn off Onecare's Firewall and do a repair and then turn the firewall back on.

     

     

     

     Stephen Boots wrote:

    Same questions as I had for the other poster to the thread, Anony37 -

    1. Make and model of your router? (sorry, saw above you said Speedstream) Model?

    2. Have you contacted support?

     

    Try the following:

    Open OneCare, click on change settings.

    Firewall tab, click advanced

    Click on Ports and Protocols

    Click Add

    Name: DHCP

    TCP or UDP - select UDP

    Port Range: 67 to 67

    For connections: Outbound

    Scope: Local subnet

     

    Click Add

    Name: DHCP Response

    TCP or UDP - Select UDP

    Port Range: 68 to 68

    For connections: Inbound

    Scope: Local subnet

     

    Note that you should not need to set this up in OneCare, but for some reason, it appears that the DHCP response (and possibly the request) is not passing through the firewall.

     

    Any chance that another firewall is still active following an uninstall before OneCare was installed? Any other network software - parental controls, etc?

     

    -steve

     

     

    Friday, April 4, 2008 4:41 PM
  • Ok, this is what I got from Onecare support,

     

    1. Open Windows Live OneCare and then click Change settings.

    2. Click Advanced settings on the firewall tab, click the Ports and protocols tab.

    3. Check the option "ICMPv4 Inbound" and click OK.

    4. Click OK in the Windows Live OneCare Settings window.

     

    This seems to fix my problem.  It has worked for few days now.  I'll keep you guys posted on my progress.

     

    Sun

    • Proposed as answer by David_Mon Sunday, March 1, 2009 3:53 PM
    Thursday, April 10, 2008 8:35 PM
  • Thanks for posting that, Sun. Not sure why that would affect DHCP, but if it works, great.

    -steve

     

    Friday, April 11, 2008 1:36 AM
    Moderator
  • I also have Verizon FIOS/Actiontec MI424-WR and OneCare.
    I have 'no DHCP' problems frequently, but I've always considered it a problem with the half-baked firmware on the Actiontec since I never had problems like this until I switched to FIOS.
    My router doesn't hold static IP settings and I frequently have Xbox LIVE connection problems... similar to my DHCP problems.

    I don't seem to have DHCP problems on computers without OneCare.
    I aso haven't seen a DHCP problem over wireless... although I'm not sure if I've ever used wireless on my laptop after I installed OneCare on it.

    I've talked with Verizon support, but they are clueless.
    I haven't contacted OneCare support, but I'll try Sun Kim's fix from OneCare support.



    Wednesday, April 23, 2008 3:03 PM
  • Do let us know your results, turbobozz.

    -steve

    Wednesday, April 23, 2008 3:31 PM
    Moderator
  • It's been a week, and no problems so far.
    I'll post again if I run into the no DHCP problem again.
    Thursday, May 1, 2008 5:12 PM
  •  turbobozz wrote:
    It's been a week, and no problems so far.
    I'll post again if I run into the no DHCP problem again.

    That's good news. Thanks for the update!

    -steve

    Thursday, May 1, 2008 6:56 PM
    Moderator
  • The problem has happened less often, but it still happens.  When I talked to OneCare support they want me to disable all of my startup service and enable one by one to see if the problem happens with one of them.  Thing is this problem I'm having does not happen every time I reboot my computer only about 60% - 70% of the times it happens, so what if I turn on one of the service that might cause this but the problem doesn't occur?  If anyone has more suggestion pleases say so.  Thanks.

     

     

    Friday, June 6, 2008 4:02 AM
  • All solutions provided by the support centre didn't help.

     

    I just bought a new modem and all my problems are gone.

     

    Friday, June 6, 2008 6:56 AM
  • easy for you, you can just change out the modem, I can't mine is from Verizon and it is only router/modem that they give out with their Fios service.  I have to use this router to get on the internet.  My only other choice is to not use Onecare, but I don't want to do that.

    Tuesday, June 10, 2008 4:27 AM
  • I'm sorry to read the the problems persist for you Sun Kim. :-(

    Have you considered borrowing (or purchasing an inexpensive) a router and disabling DCHP on your Verizon provided modem/router's router config? You would then turn your mode/router into a modem only. If the modem/router also provides wireless capabilities, it may be a little trickier to configure, but it should still work.

    -steve

     

    Tuesday, June 10, 2008 7:32 PM
    Moderator
  • I have this very same problem.  Verizon requires that router for television service(on demand mostly) and buying another one seems like a waste of money, which my gas tank needs more! Sad  
    My workaround is (and it is a pain) to turn off firewall (for 15 minutes in case I forget to turn back on) repair my wireless connection...wait... everything ok, so put firewall back on.  What a pain.
    I like OneCare, but the firewall is not as good as zonealarm... the gateway router would be set as a trusted host (and if it isn't by default, I can easily add it!) then nothing would be blocked to and from it.  I was thinking about using a packet analyzer, to see exactly what is trying to come in/go out that is being blocked(other than a simple DHCP request!?!)...but I'm afraid it will be much easier to just stop using OneCare altogether.
    Sorry MS...good product, but needs a little improvement with the firewall.

    Wednesday, June 18, 2008 4:50 PM
  •  

    I think this may be a problem with the DHCP server in the Verizon unit.  I have 3 computers (2 vista, and 1 XP), a Windows homserver, and an xbox.  I have the sam DHCP problems you describe with the XP machine & onecare (wireless), but I have similar problems with the xbox360 (wired) getting a lease.
    Sunday, July 20, 2008 2:12 PM
  • Same issue I read about in the forum.  Fios internet will be very slow to connect if at all with the onecare firewall on.  If I turn it off it connect right away.  I tried the setting recomendations in the furum but no luck.  Any other suggestions?

    Friday, August 22, 2008 12:00 AM
  • What settings did you change? There should be no changes required for you to access the Internet via the OneCare firewall through your router. However, since you have no problem when you turn off the OneCare firewall, I recommend that you contact support to get help in determining what the actual cause of the connectivity problem is.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

     

    Friday, August 22, 2008 12:28 PM
    Moderator
  • Steve, thanks for the reply.  There are several folks with the identical problem on the firewall section of the forum.  I followed the recommendations that were listed there adn it did not help.  The changes were around the ports and protocalls.  But they did not work.  I have tried Norton and McAffee trials and they both work, no problem.  However,  want to stick with OneCare since I already paid for it.

     

     

    Friday, August 22, 2008 1:23 PM
  • Since you were actually replying to an existing topic that is not answered for most people, at least consistently, I will merge this thread into that one.

    My advice stands - contact OneCare support. Re-reading that thread, I also think that you may want to badger Verizon as others seem to feel that the modem/router is problematic for other devices and not just with OneCare installed.

    -steve

     

    Friday, August 22, 2008 1:45 PM
    Moderator