locked
Project Server 2010 Web. Manage Delegates. How to display all users in "Working on Behalf" RRS feed

  • Question

  • One of our Project Managers unexpectedly left for a few weeks and we need to create a delegate for him. I can log in into the PWA as an Administrator but the "Working on Behalf Of" dropdown displays only the current User. Trying to type in the name gives a message "You don't have the right to manage delegates for the selected user".

    Is there a way to allow Administrator to manage delegations for other users? I presume this should be one of the security configurations?

     

    Regards

    Maciej


    mjsk
    Friday, December 2, 2011 5:23 AM

Answers

  • Dear Amit

    I'm sorry for the trouble.

    I found the answer. The key was "My Resource Delegates" and the RBS structure was incorrectly set. Once I figured out correction to RBS it all worked as expected.

     

    Once again thank you for your help.

    Regards

    Maciej


    mjsk
    Friday, December 2, 2011 6:43 AM

All replies

  • Hi there,

    You will need to set the permissions for delegation in security category. Administartor can deletgate the user who can be delegated.

    · Manage My Resource Delegates   Allows a user to set up delegates for other users.
    · Manage My Delegates   Allows a user to create a delegate for themselves, but relies on someone else to pair up the delegation to another user who will do the work.
    · Can be Delegate   If a delegate has been created, it allows the user to go to the “Act as a Delegate” page and act for another user.
    · Manage Resource Delegates   Turns on the delegates feature.

    Here is a good article which describes step by step to setup  required permissions for delegate functionality.

    http://blogs.msdn.com/b/project/archive/2010/03/19/project-2010-introducing-delegates.aspx

    Hope that helps.


    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Friday, December 2, 2011 5:56 AM
  • Amit

    I believe I did this before. I found this blog before asking this question and I could not resolve the issue. I do not know much about Project Server so I could have done something silly.

    Regards

    Maciej


    mjsk
    Friday, December 2, 2011 6:18 AM
  • Ok, I see. Are you trying see the user name to be delegated in the delegation setup?

    To set permissions for a specific user "A"
    1. On the PWA home page, click Server Settings.
    2. Under Security, click Manage Users.
    3. Click the name of the user A for which you are setting permissions.
    4. On the Edit User page, expand the Global Permissions section.
    5. In the Global Permissions section, under Resource, choose the appropriate permissions for this user.
    >Can be Delegate Select the Allow check box for this permission to enable this user to actively become a delegate for another user.
    > Manage My Delegations Select the Allow check box for this permission to enable this user to create his or her own delegations.
    > Manage My Resource Delegations Select the Allow check box for this permission to enable this user to set up delegations for other users.

    Now, when you login as Administrator & go to Manage delegate, You should be able to view the User A in the list.

    Please let us know the result.

    Thanks,
    Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82
    Friday, December 2, 2011 6:25 AM
  • Dear Amit

    I'm sorry for the trouble.

    I found the answer. The key was "My Resource Delegates" and the RBS structure was incorrectly set. Once I figured out correction to RBS it all worked as expected.

     

    Once again thank you for your help.

    Regards

    Maciej


    mjsk
    Friday, December 2, 2011 6:43 AM