none
UWP Build Exited with Code 1 RRS feed

  • Question

  • This is an issue I've encountered for three days. I am using Unity 5.6 and a the Playmaker and EasySave2 Plugins.  I get as far as building the Visual Studio Solution but when I import it to Visual Studio 2017 I get the follow error:

    Severity Code Description Project File Line Suppression State
    Error The command ""C:\Users\Wyvern\Documents\DragonsBe\Build\Unity\Tools\AssemblyConverter.exe" -platform=uap -lock="C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\project.lock.json" -bits=64 -configuration=Master -removeDebuggableAttribute=True -uwpsdk=10.0.15063.0 -path="." -path="C:\Program Files\Unity\Editor\Data\PlaybackEngines\MetroSupport\Players\UAP\dotnet\x64\Master" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\Assembly-CSharp-firstpass.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\Assembly-CSharp.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\Assembly-UnityScript-firstpass.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\UnityEngine.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\nunit.framework.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\UnityEngine.UI.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\UnityEngine.Networking.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\ES2.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\PlayMaker.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\ConditionalExpression.dll" "C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\MoodkieSecurity.dll"" exited with code 1. Dragons-Be C:\Users\Wyvern\Documents\DragonsBe\Build\Dragons-Be\Dragons-Be.csproj 285

    It doesn't evens specify an error so I can't even isolate the issue.  Only thing I can make of it is that it's relating to my plugins. Any suggestions on what might be causing the error?  How do I fix this? I pops up regardless of whether it's a Debug, Master or Release Build. I'm at a loss.

    Thursday, June 8, 2017 8:29 PM

All replies

  • Hi Seiryu32,

    Thanks for posting here.

    This forum is about the MSBuild, as your issue is more related to the Unity, we suggest you can submit this question on Unity forum for better support.

    If you have some MSBuild questions, please feel free to contact us. We will try our best to give you a solution.

    Thanks for your understanding and cooperation.


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.




    Friday, June 9, 2017 7:49 AM