locked
CRM 2013 Mobile App cant login RRS feed

  • Question

  • Hi There,

    I'm trying to test forms security on the CRM 2013 mobile app but I am unable to login with my test user. I have a surface which I login under my profile and then I configured the app under my name. Since I am a system administrator I can see everything, but wanted to test for a test user, using one of our standard security roles.

    When I try to login as the test user, I get the following error :

    "You haven't been authorized to use this app. Check with your system administrator to update your settings."

    I confirmed the following privileges have been assigned to the security role

    • Use CRM For Tablets
    • Use CRM For Phone
    • Full Read on System Application Metadata
    • Read/Write/Create/Delete for User Application Metadata

    I then followed this link http://technet.microsoft.com/en-us/library/dn660982.aspx and saw that the app can only be configured for one user at a time. So I uninstalled the app completely, reinstalled the app and only tried to configure it for the test user, and I received the same error.

    I also found an article showing how this could be a bug, if there is no modified date tied to the security role, but I confirmed that this security role has a modified date for when I made the privilege changes outlined above.

    Is there anything else that can be causing this? I have tried to configure it with my role, and it works fine, so Its not the infrastructure or a system setting, but something pertinent to that role.

    Any help or insight would be greatly appreciated.

    Thursday, September 11, 2014 4:50 PM

All replies

  • Figured it out. This particular user was getting a 404 when I tried to login via web too. I had to go into users and change the user id to another user, save then change it back. I was then able to login with that user.

    Another question, Are only 2 custom tabs supported on the mobile client? Is there a limitations in the number of fields per tab that will show on the mobile device? I looked for this in the documentation but couldn't find anything.

    Thursday, September 11, 2014 5:35 PM