Can't complete CRM 2013 mult-server deployment with SQL Alwayson RRS feed

  • Question

  • We are building CRM 2013 & 2015 environments so that we can take our CRM 2011 instances through to current versions. We are aiming for 2 x CRM servers and 2 x SQL nodes in an alwayson configuration. The SQL nodes have 3 instances,

    instance1 = CRM 2011
    instance2 = CRM 2013
    instance3 = CRM 2015

    We have a Alwayson configuration working with CRM 2011 & instance1. We are now trying to get build the CRM 2013 deployment but are hitting various problems.

    Document = https://technet.microsoft.com/en-us/library/jj822357(v=crm.6).aspx

    We have;
    Step1: Created SQL alwayson instance2 listener on custom TCP port
    Step2: Installed CRM 2013 to named instance on SQL node1 then applied SP1
    Step3: run through configuration to get CRM to connect to Alwayson using TechNet document. To get the Deployment Manager to open we had to add the port number to the registry key so we have... Data Source=SQLINS02AG,64800;Initial Catalog=MSCRM_CONFIG;Integrated Security=SSPI

    Step4: Installed the CRM2013 SRS reporting connector on SQL node 1 (having uninstalled the 2011 version), we had to use the local instance name and not the Alwayson listener

    The problems we have are
    1. When you try to create a new CRM organisation you have to change the values in the wizard back to one SQL node and NOT the Alwayson listener. Then the wizard errors:

    2. We can't get the CRM2013 reporting extensions on the second node, we get the following error. "Microsoft Dynamics CRM Reporting Extensions is not compatible with this version of Microsoft Dynamics CRM. Upgrade Microsoft Dynamics CRM, and then try again."

    3. We can't get the second CRM server to install and connect to an existing deployment. " 09:42:57|  Error| Check ConfigDatabaseVersionValidator : Failure: The specified database has a later version."

    Any ideas would be greatly appreciated

    Monday, June 12, 2017 11:14 AM

All replies

  • Taking your issues in turn:

    1. Have you specified the port number for the listener ? I expect you'll have to. However, I'm not sure if that's the only issue. You may be best just installing on one node, then changing the registry values after install
    2. You can't install the Reporting Extensions more than once on the same server, even if you have different SQL instances. You'll either need different servers, or if you're just doing this to upgrade, you can add the IgnoreChecks registry value to allow you to continue without the Reporting Extensions 
    3. Not sure on this one - have you applied any update rollups on the first node before installing the second node ? I'd also double-check that you're connecting to the correct SQL instance 

    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Monday, June 12, 2017 3:53 PM
  • 1. Yes in the registry but not during the create org wizard. I'm currently going through the logs to see why it failed created an error and will post an update.
    2. yes I am aware only one instance of reporting extensions per server. On the Second SQL node I unpacked the msu for the SP1 and added to the updates directory and managed to get the install to complete. I have not had a chance to test failover yet to see if this works.
    3. I had updated the install on the first CRM server to try and resolve the problems getting Alwayson working. I have now added the update to the second server using XML install and completed the install, so this item is RESOLVED.

    Whats not clear from the MS documentation on TechNet is the order of adding additional CRM servers and what registry/DB updates you are then supposed to make and what is expected to work. For instance, if SQL Alwayson is configured and you add the Reporting services databases, I would expect the reporting to work regardless of what SQL node you are running on. Also, creating and importing CRM orgs > it is not clear that you would have to change the wizard to point to one of the SQL nodes.

    Monday, June 12, 2017 4:00 PM