locked
Server Side Sync of Appointments & Contacts not working but no error details provided to enable diagnosis RRS feed

  • Question

  • I configured and successfully tested on-premise server side sync with Exchange on premise. Mailbox tests all positive - send, receive & appointments all show OK. Send & Receive emails work for this mailbox via server side sync. But when I create an appointment I get an alert saying "Appointments, Tasks and Contacts could not be synchronized, the system will try later".

    I have turned on CRM tracing but don't see any errors related to this. I looked in the event log and don't see any errors there. So I how do I start to diagnose the issue?

    I have configured the Mailbox to use the users credentials, so security shouldn't be a problem.
    Friday, December 6, 2013 1:29 PM

All replies

  • I am having the same issue, have you resolved this?

    View Kevin Dan's LinkedIn profileView Kevin Dan's profile Please click "Mark As Answer" on the post if this post answers the question or "Vote as Helpful" when it helps.

    Tuesday, January 7, 2014 10:13 PM
  • In our case the Exchange Server is 2007, which is apparently unsupported by MS, so we have had to disable the appointments and tasks sync pending investigation - interestingly some users mailboxes passed the test on this score but most did not. It would be very good to get some more information from Microsoft on this please. Will ExSvr2007 work or not?
    Tuesday, January 7, 2014 10:22 PM
  • CRM 2013 on premise and Exchange 2010 on premise, all the user emails are working, but for 7 out 22 users sync appointment, contact, and task are disabled automatically for unknown reason/error.

    No tracing information or event log, can anyone point out a direction?


    View Kevin Dan's LinkedIn profileView Kevin Dan's profile Please click "Mark As Answer" on the post if this post answers the question or "Vote as Helpful" when it helps.

    Tuesday, January 7, 2014 11:05 PM
  • We are getting bizarre behaviour on tracking incoming emails - sometimes not matched when they should be and sometimes matched against contacts with the same email address but not on the conversation thread (even using tracking tokens), plus all users intermittently get alerts saying there was a problem receiving messages - I hope this is getting the full attention of Microsoft to be resolved. Does anyone know if the CWRMobility Exchange Server-Side Sync Component is any better?
    Thursday, January 23, 2014 11:13 AM
  • I raised with Microsoft and I believe they are enhancing the tracing / fault logging in UR2 to provide us with more diagnostic info. A preview of UR2 is out but I have not tried it.
    Thursday, February 13, 2014 4:38 PM
  • There should be troubleshooting information in async service traces. Please enable error level tracing on async service and try.
    Monday, June 9, 2014 5:49 PM
  • Can you please look into CRM traces of the async service to troubleshoot the errors? There should be more useful information there.
    Monday, June 9, 2014 5:50 PM
  • I think you have to turn on *.Verbose tracing to see anything of use in the CRM trace for server side sync. Otherwise, even if there is an error, nothing gets logged.
    Thursday, August 14, 2014 2:37 PM