locked
Backup Configuration Problem RRS feed

  • Question

  • I recently reinstalled WHS to move from the evaluation copy to a fully licensed copy.

     

    Now I have a problem with configuring backup for my Vista Ultimate machine. I have not had a problem with a laptop using WXP-SP3.

     

    Whenever I attempt to configure backup the progress bar moves across the screen fairly quickly about two thirds of the way then stalls. Eventually I get an error message that "Home PC" is not responsive. The Vista computer has never had that name and there is no computer on my network with that name. I tried uninstalling and reinstalling the connector but that did not help. The network Workgroup name is "HOME". All of the computers, including the server are in the same workgroup.

     

    Backups of the computer are still being done everyday according to the list of backups in the WHS Console.

     

    I need to be able to do the configuration routine in order to verify the drives being backed up and also to make changes if necessary.

    Tuesday, May 20, 2008 9:16 PM

All replies

  • If it's Vista 64bit you can not currently backup with WHS. If not please try repair or reinstall .net 2.0. Also have a look at the thread Re: Error: "Home PC is unresponsive"

    Tuesday, May 20, 2008 9:32 PM
    Moderator
  • It is a Vista Ultimate 32bit system.

     

    I cannot install .net 2.0. The installer returns a message noting that it is already part of the OS.

     

    I went into Control Panel, Turn Windows features on or off and noted that under .net 3.0, there is no 2.0, the XPS Viewer was the only item checked. I tried checking the two HTTP items but that did not help. I also note that my laptop with Home Premium also has only the XPS Viewer active.

     

    I did look at the "Home PC is unresponsive" thread. I found only two things there that might work. The first is a Registry hack, which I have not yet checked out, the other involves a reset of the backups on the server. I did download and install the WHS Toolkit. I am hesitant to try the reset since all backups will be lost and I have no reasonable assurance that the reset will solve the problem on the one computer. The "Configure Backup" works with two laptops, one with Home Premium, the other with WXP-SP3.

     

    Wednesday, May 21, 2008 1:19 AM
  • An additional comment. I did run chkdsk /f on all of the drives as was suggested in the other thread. Still have the problem. Chkdsk did not find any problems.

     

    I note that there was one suggestion to run a .net cleanup tool which cleans out all instances of .net but I dont think that I should do that since this is a Vista machine and .net is part of the OS.

     

    There are two drives, each with two partitions. I suspect that it is one of the partitions but since chkdsk does not find any problems dont know which one.

     

    Follow-up: Suspecting one of the partitions as mentioned above I moved all of the data off it then reformated it. This did not solve the "Home PC not responsive" problem but it did cause me to lose the ability to back up any of the partitions on the computer. I then removed the computer in the Console and removed and reinstalled the Connector. Still could not perform a backup of any of the partitions. I then used the WHS Toolkit to reset the backup database. Then I removed the connector on the problem computer, removed all of the remaining WHS registry entries and the program files directory.

    When I reinstalled the Connector the Wizard completed properly and the computer showed up in the Console as not backed up. I then ran Discovery on my other computers with no problem. I then had all of the computers showing in the Console as connected and not backed up.

     

    I then went to bed. When I checked this morning backup of all of the computers had completed OK. I checked the backup for the Vista Ultimate unit and all four of the partitions on the drive had been backed up.

     

    This indicates that the wizard was able to access both drives, all partitions when I reinstalled the Connector. I still get the "Home PC not responsive" error whenever I run the "Configure Backup" wizard in the Console.

     

    This is a problem that has been around for a LONG time. Surely by now MS should have been able to come up with a solution.

     

     

     

    Wednesday, May 21, 2008 1:45 AM
  • Fred,

    Have you tried running chkdsk /r on all the disks? /f fixes errors, but /r also checks for bad sectors (and marks them out)

    Also, you haven't at any point used something like Acronis, PartionMagic etc to alter partitions at all?

    As a test, you could possibly disconnect your second disk on the Client and try with just the one disk.

     

     

    Colin

     

    Thursday, May 22, 2008 8:18 PM
  • Colin:

     

    No, I have only used chkdsk /f, several times. No errors found is reported every time.

     

    Yes, I have used Partition Magic. I used it to set up the partitioning when I initially setup the computer. I dont see how using that could have caused it since everything was working correctly after the initial installation of the evaluation copy. This problem only started after I did a Server Reinstallation to upgrade to a licensed copy.

     

    I also dont see how there could be a problem with the disks or partitioning since the reinstallation of the Connector, after I uninstalled it and removed the registry entries for WHS, found all of the partitions and the first backup after the reinstall backed up each of the partitions.

     

    The problem seems to be unique to the "Configure Backup" wizard in the Connector and this computer. I have three others working with no problems.

     

    Since the server is backing up everything on the Ultimate desktop it is not a major issue but the problem will prevent my adding disks or changing partitions if the need should arise in the future. I sure would like to get it corrected somehow.

     

    Friday, May 23, 2008 2:12 AM