locked
Problem with exporting data into an Excel spreadsheet - Dynamics worksheet in Dynamics CRM 2011 RRS feed

  • Question

  • Hi,<o:p></o:p>

    I am trying to export the view/ selected records from Advanced find(in Dynamics CRM 2011) and then select the dynamic sheet option, an XML file is generated which the users should then ‘Save As’ an .xlsx file and, then open it (or directly open the XML file with EXCEL). My client does wants that the file generated should be in .xlsx format and .xml. Is this something that can be changed? This is urgent. Need help!!

     


    Thursday, July 16, 2015 8:50 PM

All replies

  • Hello Anwesha,

    If I have got it right, you want to export dynamic sheet from CRM in .xlsx format and not .xml. Unfortunately this is not possible. If you select a static worksheet to be exported it will be exported in .xlsx format however if you use any other exporting option (Dynamic spreadsheet) it will always be downloaded as .xml.

    It creates a .xml because of the security aspect and creates a embedded connection in between spreadsheet and CRM.

    Hope it helps!

    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/


    • Edited by Abhishek73 Friday, July 17, 2015 10:49 AM
    Friday, July 17, 2015 8:05 AM
  • HI Abhishek,

    Thank you very much for the quick response. Yes you got it completely right. It's like my client says that the file was getting generated as expected(in .xslx format) before. We had an upgrade to CRM 2011 about an year back. Could it be that it worked that way in CRM 4.0? Please let me know.

    Regards,

    Anwesha

    Friday, July 17, 2015 8:30 AM
  • Dear Anwesha,

    I haven't worked on CRM 4.0 so really am not very well versed with it and hence can't comment on that.

    However I did find some blogs regarding the same. Pls check if it helps you,

    http://blog.crmguru.co.uk/2010/07/01/annoying-file-format-warning-when-exporting-crm-records-to-excel/

    http://community.dynamics.com/crm/b/crmcustomereffective/archive/2010/08/27/getting-rid-of-the-crm-export-to-excel-warning-message

    Thanks


    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/


    • Edited by Abhishek73 Friday, July 17, 2015 9:32 AM
    Friday, July 17, 2015 9:32 AM
  • Hi Abhishek,

    Thank you very much again. The warning is fine with the user. The issue is when the user opens the xml, it opens in IE for him (in xml format) and not excel as expected. I have a windows 7 machine with IE 9, in which it works perfectly fine. But for the user who has Windows 2008 and IE 8, it seems to be a problem. I am not sure what setting is needed for it.

    Regards,

    Anwesha

    Friday, July 17, 2015 12:36 PM
  • Hi Anwesha,

    Check these

    http://blogs.msdn.com/b/vsod/archive/2011/06/20/excel-xml-file-behaves-differently-when-opened-in-32-bit-and-64-bit-versions-of-internet-explorer.aspx

    https://support.microsoft.com/en-us/kb/162059


    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/

    Saturday, July 18, 2015 3:52 AM
  • Hi,

    One way is to right click the file and choose "open with" and then click "alway open with this program" and the choose excel. BTW, you don't get xlsx files from CRM 2011, or 2013 OR 2015 (might have been fixed in update 1 of 2015), it's ye olde xls format which will give you a warning mind you.

    Good Luck!


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Saturday, July 18, 2015 8:39 AM
  • Hi Rickard,

    Thanks much for the response.

    I checked the CRM 2015 trail version and it opens the dynamic worksheet in xlsx format. All the other versions give a default xml file. I think it's the  default program that is associated for xml file type has been set to IE instead of Microsoft Excel.

    Thanks,

    Anwesha

    Monday, July 20, 2015 1:46 PM