locked
Cant't connect to my Home Server RRS feed

  • Question

  • Hi,

    every time my WHS has backed up one of my computers I can't connect to the server. The icon in the taskbar gets grey and says, that it has no connection, although the server is working and connected to the network.

    I tried to connect over Remotedesktop, but this fails, too.

    Has anybody an idea, what I should change?

    Hendrik
    Wednesday, August 5, 2009 8:37 PM

Answers

  • Alright the best thing i can suggest is that you do the test pings next time this happens to you.  If you can ping the IP and not the name then it is a DNS issue.  Everything appears to be working as is right now so there isn't much i can do to help. 

    The last thing you can do right now is on your client run cmd and type:

    ipconfig /all

    and record the DNS info under Windows IP Configuration.

    I get the feeling that your losing connection to your server at some point the it gets re-established with different dns settings.

    Next time this problem occurs run cmd and type:

    ipconfig /all

    and compare the DNS entries too see if they are different.  If the entries are different then your server or client has lost connection at some point and has defaulted to different DNS settings.  I've had this issue happen to me several times and it is annoying. 

    Sorry but that is all i can suggest for now. 

    • Marked as answer by Hendrik W. _ Sunday, August 9, 2009 1:52 PM
    Saturday, August 8, 2009 7:25 PM
  • I don't think that we have general network problems (DNS) here. The problems that everything was working, except that after a backup the server woas no longer accessible.

    I have a similar issue in our German forum here (http://forum.home-server-blog.de/viewtopic.php?f=28&t=6358). This user also has a mainboard with a nvidia ION chipset. When he switches to WLAN instead of LAN, the server is working and completing backups.

    So I think the issue is the nvidia network card driver. nvidia does no longer provide Windows Server 2003 drivers, the XP drivers do not work very well. The only workaround I see is an additional network card instead of the onboard one.
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    • Marked as answer by Hendrik W. _ Sunday, August 9, 2009 1:52 PM
    Sunday, August 9, 2009 8:58 AM
    Moderator

All replies

  • Hi,

    every time my WHS has backed up one of my computers I can't connect to the server. The icon in the taskbar gets grey and says, that it has no connection, although the server is working and connected to the network.

    I tried to connect over Remotedesktop, but this fails, too.

    Has anybody an idea, what I should change?

    Hendrik

    Do you have more than one client?  If so, is it always the same client that causes the problem?
    Thursday, August 6, 2009 3:34 AM
    Moderator
  • What hardware is used for your server? This may happen with outdated network card drivers. Try to update.

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Thursday, August 6, 2009 8:10 AM
    Moderator
  • Go to nvidia.com and select the latest XP drivers matching your nForce chipset.

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Thursday, August 6, 2009 9:14 AM
    Moderator
  • What exact chipset do you have and what driver version?

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Thursday, August 6, 2009 12:24 PM
    Moderator
  • Hendrik, you got me wrong.

    You have to install the latest nVidia chipset driver for your nForce chipset. This includes (!) the network drivers.
    So please go again to nvidia.com and select the latest XP chipset driver for your nForce chipset.

    When you provide some more information about your chipset (typically these have names like nForce 720 or nForce 980) I will look for the correct driver.

    Option 2 on the nvidia web site will ony find graphics drivers and that is not what we need here.

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Thursday, August 6, 2009 1:46 PM
    Moderator
  • No, that doesn't help. Please look into your motherboard manual or tell me your exact motherboard name.

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Thursday, August 6, 2009 2:38 PM
    Moderator
  • Ok, that's a GeForce 8200 board. Have you installed that driver here?
    http://www.nvidia.com/object/winxp_190.38_whql.html

    The Gigabyte chipset drivers are here (including a Lan driver):
    http://www.gigabyte.com.tw/Support/Motherboard/Driver_Model.aspx?ProductID=3081&ost=xp#anchor_os

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Thursday, August 6, 2009 3:00 PM
    Moderator
  • Are there any errors or warning in your servers event log?

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Friday, August 7, 2009 8:23 PM
    Moderator
  • Hendrik, do you have a spare network card? Can you try to use that instead of the onboard NIC?

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Saturday, August 8, 2009 5:47 PM
    Moderator
  • first off can you ping the IP address of the server?  If you can ping the IP try to then ping the server name, this will rule out any DNS issues. 
    Saturday, August 8, 2009 6:12 PM
  • start > run > type: cmd

    In the command prompt that comes up type:

    ping yourserverIPaddress




    If you don't know your servers ip address then you will need to gain access to it and on the server open a cmd prompt the same way and type:

    ipconfig

    this will show you the ip address of the computer your on. 
    Saturday, August 8, 2009 6:32 PM
  • alright so just to clarify from the PC your having problems connecting to the server with you were able to ping the IP address of the server with no loss.

    If that is correct then instead of using the IP address of the server in the ping command use the server name and see what happens, i get the feeling it will fail.

    Byblyk.
    Saturday, August 8, 2009 6:39 PM
  • try connecting with remote desktop now first with the name then the IP if the name doesn't work. 
    Saturday, August 8, 2009 6:44 PM
  • alright then try connecting to your server using remote desktop.  If this fails then on your server go to controll panel > windows firewall and turn it off then try to reconnect from your client.   


    Edit: oh and it should have been ping form client to server because you are testing connectivity between the two.
    Saturday, August 8, 2009 6:51 PM
  • alright is the little icon in your taskbar green or showing as connected?  can you connect through this?
    Saturday, August 8, 2009 6:53 PM
  • Alright the best thing i can suggest is that you do the test pings next time this happens to you.  If you can ping the IP and not the name then it is a DNS issue.  Everything appears to be working as is right now so there isn't much i can do to help. 

    The last thing you can do right now is on your client run cmd and type:

    ipconfig /all

    and record the DNS info under Windows IP Configuration.

    I get the feeling that your losing connection to your server at some point the it gets re-established with different dns settings.

    Next time this problem occurs run cmd and type:

    ipconfig /all

    and compare the DNS entries too see if they are different.  If the entries are different then your server or client has lost connection at some point and has defaulted to different DNS settings.  I've had this issue happen to me several times and it is annoying. 

    Sorry but that is all i can suggest for now. 

    • Marked as answer by Hendrik W. _ Sunday, August 9, 2009 1:52 PM
    Saturday, August 8, 2009 7:25 PM
  • Errr it's hard to explane why mine does this without getting into too much detail but the way i get around it is just to restart my PC and it will pull the proper DHCP settings or instead of using the server name i use the IP address. 

    Saturday, August 8, 2009 7:42 PM
  • it seems as if youwere able to ping the IP and not the server name so this could be your problem.  have you looked at your DNS settings under ipconfig /all   
    Saturday, August 8, 2009 7:44 PM
  • start > run > cmd > ipconfig /all 

    record the DNS info under Windows IP Configuration then restart your PC, see if you can ping the server's IP and name.  If you can then look at the DNS settings under ipconfig /all again and see if they are different.
    Saturday, August 8, 2009 7:50 PM
  • sorry all this is going client to server.  You'll want to be on your client that is having the issue pinging the server.
    Saturday, August 8, 2009 8:02 PM
  • I don't think that we have general network problems (DNS) here. The problems that everything was working, except that after a backup the server woas no longer accessible.

    I have a similar issue in our German forum here (http://forum.home-server-blog.de/viewtopic.php?f=28&t=6358). This user also has a mainboard with a nvidia ION chipset. When he switches to WLAN instead of LAN, the server is working and completing backups.

    So I think the issue is the nvidia network card driver. nvidia does no longer provide Windows Server 2003 drivers, the XP drivers do not work very well. The only workaround I see is an additional network card instead of the onboard one.
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    • Marked as answer by Hendrik W. _ Sunday, August 9, 2009 1:52 PM
    Sunday, August 9, 2009 8:58 AM
    Moderator