locked
data import - 1:N link not being created though option set

    General discussion

  • I have this import where the CSV file has the data for this entity and the last column is  the data to another entity that is linked a 1:N

    so lets say the CSV is

    Entity A                  |    Entity B

    column 1, Column2 |     Column 3

    john ,   Smith         |     Programmer

    And I map it like

    Source   |   Destination

    1 (John)                      |    A1

    2  (Smith)                   |    A2

    3  (programmer)         |    B3 (option set)

    As it is for column 3, it is not creating a link when I import it

    Apparently there was a option set on that form but now its being replaces with a Grid

    So Entity A has a grid with info of related records from entity B rather than a look up option set.

    Is there a way to link it through import? does the value for column 3 need to be its ID rather that the value?

    Sunday, November 03, 2013 9:24 AM

All replies

  • Please go through following post.

    http://blogs.msdn.com/b/dynamicscrmonline/archive/2011/06/24/crm-2011-data-import-wizard-importing-related-accounts-and-contacts.aspx

    I hope this helps.


    Hope this helps. If you get answer of your question, please mark the response as an answer and vote as helpful !
    Vikram !

    Sunday, November 03, 2013 10:35 AM
  • it linked on a advanced view but when I open A, the grid that shows the data related A(b) does not show the data

     
    Sunday, November 03, 2013 6:46 PM
  • If that is the case, please re-check how many relationships exist, if more than one select appropriate on sub grid. 

    Hope this helps. If you get answer of your question, please mark the response as an answer and vote as helpful !
    Vikram !

    Monday, November 04, 2013 1:20 AM
  • yeah, this one works or account and contacts only. how can I create a custom mapping  like tableParent and tableChild and have tableClild to have a relationship with tableparent?
    Monday, November 04, 2013 9:11 AM