locked
My DefaultValue stopped working RRS feed

  • Question

  • I imported a spreadsheet into a table, and for a Date/Time field named "Created", I set a Default Value of "=Now()". This way, in Datasheet view, I was provided an editable timestamp on each record.

    Then I used the "Analyze Table" tool to split my table into several normalized tables. But now, in the new Items table, the same Default Value, fails to fill in the date.

    Image 1: Design of new Items table:

    Image 2: Datasheet View, New Record:

    Monday, March 30, 2020 12:41 AM

Answers

All replies

  • Two seconds after posting this, I renamed the Created field to "Created1" and copied the old Items tables field definition into the new table.

    Then I went into datasheet view, and found both fields to be working.

    Since I don't see how my actions could possibly have fixed this, I'm going to assume that one of you waved a magic wand. <grin>

    Kidding aside, if you have any insights, I'd love to figure out what really happened.

    Thanks.

    Monday, March 30, 2020 12:49 AM
  • I'd try asking for help over here.

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_excel

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/home?category=sqlserver

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Monday, March 30, 2020 2:07 AM