locked
Synctoy 2.0 Beta painfully slow, compared to 1.4 RRS feed

  • Question

  • I really love Synctoy 1.4 and I've been using it to synchronize my Documents folder between my notebook and my main machine for a long time now. There's quite a number of files to synchronize: when i last checked, the Docunents folder contained 9,45 GB in 55089 Files.

    Synctoy 1.4 always worked perfectly well with this number of files. A complete Preview took about five Minutes, syncing another minute, done.

    With Synctoy 2.0, the time for a complete preview goes up to more than an hour; in fact, the preview can't even be completed. Synctoy seems to complete the comparison part but gets stuck when ""Adding an action for <random filename here>", which i eventually have to stop, resulting in Synctoy telling me it has reached a "user defined breakpoint" some ten seconds later.

    Unfortunately, i have switched to Vista 64 recently, so i have to run a virtual machine to still use Synctoy 1.4, since it won't run under Vista 64.

    Are you aware of that situation, do you have an explanation for me and/or will the be a version that's about as fast as 1.4 was? Or are there any tricks in your bag that make Synctoy 1.4 run on Vista 64?

    Any hint is really appreciated.
    Thursday, February 14, 2008 6:39 PM

Answers

All replies

  • I have not heard that issue yet, but I will check with engineering and test to see if they run any tests with that many files.  If not, I will make sure we add one. 

     

    In any case, once I hear back I will let you know.

     

    Liam

    Friday, February 15, 2008 4:52 PM
  • I am also having this same problem with SLOOOOWWWWWW comparisons. I've posted in the XP Photos forum, but I'll cross post here:

     

    I'm comparing 3 gig of data in 17,500+ files with one folder pair, another one has 2.5 gig in 14,000+ files. Comparison takes hours (and I get impatient and quit before finishing.)

     

    Network drive is r/w and I am not using any kind of "offline folders." I'm simply trying to sync between my local drive and a UNC path on a server, running Windows 2000 Server. I am an admin on both machines.

     

    Finally, another question. I have noticed with one pair of folders I'm comparing, lists several files to copy but when I examine the files, they have the same timestamp and filesize (in fact the file content is the same, too.) But SyncToy 2.0 thinks it needs to copy the files. Is there any log or anything that I can look at to see why SyncToy thinks it needs to copy these files?

     

    Thanks &

    Cheers,

     

    Toby


     

     

    Friday, February 15, 2008 7:23 PM
  • Hi Toby,

     

    Our engineers are going to take a closer look at this issue next week and I will respond with what we find here. 

     

    As to your other question.  In order to determine if a file has changed we check the following things:

     

    - Timestamp changes

    - File Size changes

    - File Name changes

    - File Attribute changes

    - Optionally File Hash changes (This is turned off by default and it is called "Check File Contents" in the app)

     

    As such, we might detect a change if one of the attributes changes in the file while the size or timestamp may not have.  It is important to note that if we detect a change in the file name or one of the attributes although we will list it as a change in the preview, we don't actually send the whole file, but rather just send the attribute or file name updates across the network.  So even though you see it as a change, we may not  in fact be sending the file over.

     

    I hope that helps,

    Liam

     

    Friday, February 15, 2008 8:12 PM
  • I would like to add my interest in this topic....

    I have a very similar situation to the original poster,

    Synctoy V1.4, One Local  folder , one remote 100MB/s Lan connected server share, aprox 30,000 files, 22GB

    This "regular" sync scenarion takes me about 4-7 minutes for the preview. (depending on which machine/cpu performs the sync)

    Other file synchronisation tools can manage this preview in under 2 minutes, BUT others do not handle renames, and moves as well as Synctoy (v1.4) .

    If this performance issue remains i will NOT be updating to synctoy v2.

    Thank You for your interest LIAM



    Saturday, February 16, 2008 6:15 PM
  • I have SyncToy 2.0, and all I have tried to so far is a preview. It always hangs up about 1/2 way through the "looking for changes" part of the scan. After a while (10-15 minutes), I give up and press the Stop button. Sometimes I have to pull up task manager and end the process. My MyDocs folder has 44,607 files, 3,163 sub-folders, and is 15.5 GB in size.

     

    I never tried version 1.4, so I don't know if it would have worked better.

    Tuesday, February 19, 2008 2:10 PM
  • If you are still running Windows 32 (XP or Vista doesn't matter), then try Synctoy 1.4

     

    Worked perfectly well for me in the last two or so years. It also takes some time to complete the preview (less time than Synctoy 2, though), but it always does complete, and it works like charm. I've never seen a synching program handle deletes and/or renames as well as Synctoy...

     

    If you however, like me, have switched to Windows 64, you're out of luck. Synctoy 1.4 does not run under Windows 64, it simply crashes each time you start it...

    Tuesday, February 19, 2008 3:21 PM
  • Liam,

     

    This explains the issue I was having. The files have the hidden bit set on the source and not on the target. Thanks!

     

    Cheers,

     

    Toby

    Tuesday, February 19, 2008 9:29 PM
  • Hi Toby,

     

    Can I just confirm what you are saying?  Are you saying that after setting the hidden flags on both sides to be the same value that you no longer see a performance issue with SyncToy 2.0? 

     

    If so, I am still concerned about how the files got into the state of having hidden on one side but not on the other.  Do you have any insight here?  Do you think it was SyncToy that did not properly sync these attributes?

     

    Liam

     

    Wednesday, February 20, 2008 9:45 PM
  • I have also gotten the "user defined breakpoint" message in the preview process before Synctoy crashes.  I have gotten this message before, and it seems tied to the length of the filename or the number of folders, because I was able to resolve it by looking at where the preview stopped (what file group) and basically moving up the folder a few levels.  There is one folder in particular that I have been doing that with every time I back up my computer.  As long as it has been just the one, it's been a minor annoyance but doable.  But now I'm getting it for another file/folder group, and I can see that this will be a persistent, growing problem.  I am trying to figure the current one out now.

     

    If there could be a fix developed for this issue, that would be great!

     

    Dan

     

    Sunday, February 24, 2008 6:14 PM
  • I too have problems with slow sync and crashes with 2.0 beta.  When syncing a big ~1gb network folder, to an empty local folder, the scan took about 1 hour, and then after copying began, at exactly 2,000 "new" files in the status window, the application crashed.

    Jeff

    Wednesday, February 27, 2008 7:01 PM
  • Liam,

     

    I am also seeing painfully slow performance, it took nearly 20 minutes to copy only 18 files onto a writeable DVD. If I had used Explorer, that copy would have been about 3 minutes.

     

    I'm trying to use the 'Contribute' feature, just backing up new files to the DVD, but SyncToy 2.0 seems to transfer little tiny pieces of the files while continuously updating some SyncToy_*.dat and .tmp files on the destination disk.

     

    This utility seems to be unsuitable for writing to media that has a limited number of write cycles.

     

    Saturday, March 15, 2008 3:12 AM
  • I have been using V2 for about 2 months now.  Over the past week, I have been doing a Contribute between 2 Windows 2003 Servers.  One is a Dell 2950 with 2003 Version R2.  The old server is a 2.0Gh clone.

     

    I am trying to Contribute one folder at a time.  The folder on the left is the remote Mapped drive of the old server and the folder on the right is a local HD.

     

    The sync will run good for 30 minutes to an hour and the transfer rate will be about 400mb per minute.  Then for some reason, the tranfer rate will drop down to less than 1mb per minute.  It will continue at that rate till I open the mapped drive on the server running the Synctoy.  Once the drive is opened, any folder, does not have to be the folder i am syncing, the speed will return to normal. 

     

    Its frustrating to start a 50gb sync and walk away execting it to be finished in a couple of hours and come back to find it has only copied 800mb of data and is running at turtle speed.  I have screen shots if someone wants to see the speed difference.

     

    Sunday, March 16, 2008 10:20 PM
  •  

    Liam:

    I’ve been using V1.4 on my PC and Laptop, and love it, but got a new tablet with vista64 and was thinking of moving everything to Synctoy v 2, has the issue reported on this post been addressed? i'd rather not change the version if it’s going to be this slow.

    Thank you
    Wednesday, March 19, 2008 5:22 AM
  •  

    For the time being,  there seems to be no solution yet, at least none that i know about. The Synctoy 2 Beta download is online unchanged since October 2007, and if i understand it right, the problem does not lie within Synctoy, but rather in the new MS Sync Framework that Synctoy 2 uses.

     

    Unfortunately, if you switch to Vista 64 with your new tablet pc, you do not have a real choice: Synctoy 1.4 does not run under Windows 64. You are left with the choice of living with Synctoy 2 and its limitations or else using Synctoy 1.4 on Windows 32, if you still can. In fact, that's what i'm doing right now: I use my ultraportable notebook (running under Vista 32) to synchronize my development notebook and my main development machine (both running under Vista 64) with Synctoy 1.4, which works surprisingly well, but of course requires a Windows 32 machine in the house...

     

    @Liam: Any news from engineering yet, concerning the issues mentioned above?

     

    Wednesday, March 19, 2008 9:06 AM
  •  jamesglewisf wrote:

    I have SyncToy 2.0, and all I have tried to so far is a preview. It always hangs up about 1/2 way through the "looking for changes" part of the scan. After a while (10-15 minutes), I give up and press the Stop button. Sometimes I have to pull up task manager and end the process. My MyDocs folder has 44,607 files, 3,163 sub-folders, and is 15.5 GB in size.

     

    I never tried version 1.4, so I don't know if it would have worked better.



    I have a similar problem, although my system is hanging at the copying stage. As far as I can tell, it's hanging at the same point in the copy each time I try it. (It says, "97% done copying ...<file path>.) Process Explorer shows no activity from SyncToy 2.0 when it hangs. If I press Stop and then Close, SyncToy just sits there. Process Explorer can usually kill it. However, if I then try to restart SyncToy, I get a message that another instance of it is running, and I have to reboot my system to use SyncToy again.

    I have a large set of synchronizations and files. Usually, I choose "Run All" from SyncToy, but because of this problem I've been choosing individual synchronizations. Some work, others hang.

    I was using SyncToy 1.4 without many problems, although it was slow on this clunky system. I installed a USB 2.0 card and the second 40GB drive and had some problems, so I upgraded to SyncToy 2.0 thinking that it may have worked out more bugs. I've scanned my hard drives and can find no errors.

    I am running XP pro SP2 on a Dell with 640MB RAM and 2 40GB hard drives, labeled C: and E: Drive C: holds the root of my file system, and E: is mounted as the My Documents folder on C:. My backup device is a 160GB Toshiba USB 2.0 portable drive.
    Friday, March 21, 2008 2:58 PM
  • Not resolved yet.

     

    Preview was OK, but every 4MB file (digital pictures) takes about 2 seconds between a 500GB eSATA drive and a FireWire 250GB drive.

     

    I hope an update comes out soon...

     

    Amnon

     

    Friday, March 28, 2008 3:28 PM
  • I just wanted to add that I regularly sync 54GB (and growing) worth of music files (11,440) between 5 different computers, running various Windows OS's (XP, Vista 32 and Vista 64) and connected to my Server 2003 over gigabit ethernet, and everytime it runs quickly and without ever an error.  Once I had a timestamp issue and it needed to recopy all my music files, but that MAY have been due to DST...

     

    In any case, I wanted everyone to know that syncing a large number of files does not always mean slow.

     

    Using (obviously) Synctoy 2.0 Beta.

     

    ps.  Will there be a 64-bit version of Synctoy?

    pss.  When will the next version update be released?  You must have fixed something since last year!  Smile

     

    Monday, April 21, 2008 1:40 PM
  • Hello everyone,

     

    First of all please let me appologize for taking so long on this issue.  It has unfortunately taken us longer than expected but I do want you to know that we do have a number of engineers now heavily focussing on this issue. 

     

    I would like to ask your help to resolve this issue as it has been somewhat difficult to completely reproduce in our labs.  Your help will basically consist of running a trace during sync and sending us the output.

     

    If you are willing to help us please email me directly at FirstName.LastName @ Microsoft.com and I will send you additional instructions.

     

    Thanks,

    Liam Cavanagh

     

    Wednesday, April 23, 2008 5:49 PM
  • Hello Everyone,

     

    Thanks to everyone so far who has offered to help us resolve this issue.  If you are still willing to help us by running a trace of your sync, please let me know by email (FirstName.LastName@microsoft.com).

     

    To date, most people who have had a performance issue have been using the "Echo" functionality of SyncToy rather than the "Synchronize" option.  I am fairly sure this is just a coincidence but I thought I would check.  Is there any one having a perf issue that is not using the "Echo" option?

     

    Thanks,

    Liam Cavanagh

    Monday, April 28, 2008 5:26 PM
  • In addition to my last question, can you tell me if you are using an SMB share in the case where you are having performance issues?

     

    Thanks,

    Liam

     

    Tuesday, April 29, 2008 8:35 PM
  •  

    I have tried 2.0 on two folder pairs and had the same issues as above.

    I just downloaded 1.4 and setup the two folder pairs. I started a sync and was wondering if anyone could tell me how long a sync on 1.4 terabytes can be expected to run? It is set to echo and running on fiber san based hard drives.

     

    Thanks,

     

    kevin

    Wednesday, May 7, 2008 6:06 PM
  •  

    Liam,

     

    >> Is there any one having a perf issue that is not using the "Echo" option?

     

    that would be me, for instance.

     

    I never use echo, but always synchronize. I try to synchronize a local folder containing 50613 files in 7080 directoryies to a mapped network drive (100MBit Ethernet, both machines under Vista 64). Looking at the progress bar, the comparison runs quite fast to around 50% and then gets reeeally slow (while still "Looking for changes" on the local drive), Things get even worse when Synctoy starts "Looking for changes" on the mapped network drive: Synctoy seems to show each and every directory he's looking at for 5 to 10 seconds, even though there are only very few files in each of those directories. When Synctoy finally arrives at "Adding an action" for all the files/directories, it nearly crawls to a halt, often also crashing with a "user defined breakpoint" error message.

     

    While writing this, Synctoy 2 is running for more than an hour now, and is still in the "Adding an action" phase.

     

    I don't think there's just an "Echo" issue involved...

    Monday, May 12, 2008 10:24 AM
  • Thanks cgdams,

     

    By any chance have you tried a similar sync with SyncToy 1.4?  If so, did you have similar performance issues?

     

    Liam

     

    Monday, May 12, 2008 6:33 PM
  • Actually, i'm still using Synctoy 1.4.

     

    Since Synctoy 1.4 doesn't run under Vista 64, i can't install it on the two machines i synchronize with each other. Fortunately, i have a third machine running Vista 32, so i installed Synctoy 1.4 on that machine, mapped the two other machines as network drives and synchronize those network drives.

     

    Synctoy 1.4 works fast and reliable, i never had any problems with it.

    Monday, May 12, 2008 7:06 PM
  • Hi,

     

    If you look under the root of the two folders on your Vista64 machines that you were trying to keep synchronized, you will find under each a hidden file called something like "SyncToy_*.dat". Could you tell me what the sizes of these files are?

     

    Deepa

    Wednesday, May 14, 2008 9:05 PM
    Moderator
  • Liam,

    Same problem here with 2.0 Beta; now with a USB-stick (OCZ ATV 32GB, according to spec. 34MB/s read, 15MB/s write). Version 1.4 works perfectly allright.

    I have done some testing with echoing 1 divx file of 348MB from my hard drive to the USB stick (caching disabled on USB stick):
    - Version 1.4 took 47s -> 7,40MB/s
    - Version 2.0 Beta took appr. 1000s -> 0,35MB/s
    So, version 1.4 works more then 20x faster !!!

    Next, I did some testing from both the command line (xcopy) and the Windows Explorer  (CTRL-C, CTRL-V). Both did the trick in appr. 41s -> 8,49MB/s.

    Hopefully this can help you drilling down to the problem. If I need to do some more testing, please let me know.

    BR,
    Jean-Luc Picard
    Thursday, May 15, 2008 6:35 PM
  • Deepa,

    sorry to be a bit late, but anyhow:

    there are indeed around ten files 'SyncToy_<some random guid>.dat' in those 2 directories. The latest one (from my last synchronisation a week ago) has a bit more that 58 MB (60,313,600 bytes, to be exact).

    Hope that helps,

    Christian

    Tuesday, May 20, 2008 8:16 AM
  • I downloaded and installed the 2.0 beta today. I hadn't installed the earlier version because it required the .NET framkwork, a rather large download to install such a simple piece of software to run it. However, now that I've installed the 2.0 version, I'm afraid to even run it, since this issue sounds pretty serious. I suppose that's why it's a beta. I think I'll wait a little longer and hope that the fix is forthcoming.
    Tuesday, May 20, 2008 5:37 PM
  • cgdams,

     

    You may already know this (since it turns up on a google search), but it's quite easy to get synctoy 1.4 working on an x64 install of Vista -- it simply needs a newer version of the "custsat.dll" file, which you obtain by downloading/installing "Microsoft Net Monitor 3.0" and then manually copying the file over to the synctoy install directory.  I've been running Synctoy 1.4 on a Vista Ultimate x64 install for quite a whle now (using this newer version of custsat.dll), and have never had a problem (well, aside from the various issues synctoy 1.4 has that I'm patiently waiting to be resolved in v2.0).

     

    Jim

    Saturday, May 24, 2008 8:23 PM
  • Jim,

    actually, i didn't know that. When i switched to Vista 64 in November 2007, i did google for solutions to the synctoy 1.4 problem, but the solution wasn't there or it did slip my attention, and since synctoy 2 was already in the pipeline, i took it for granted that 1.4 wasn't supposed to run under x64 and never looked again.

    Anyhoo, this is grrrrrreat news, thanks a lot for pointing me to this. It's good to have my beloved Synctoy back where it belongs. I'm sure Liam and his colleagues will eventually figure out what's wrong with 2.0, but now i have all the time in the world to wait for it.
    Sunday, May 25, 2008 8:46 AM
  • Sunday, June 1, 2008 7:21 PM
  • I'm running 2.0 beta and windows media player 11.0

    I have all of my data including music and photo files on a usb attached drive, and use synctoy in echo mode to backup my entire data to another usb drive. The music files are all overwritten each time I run synctoy, even though I only listen - haven't added new music for a month or so.

    After reading the comments in this forum, I looked at all the data for a wma music file that is displayable with windows explorer. One of the fields you can display is "Date Accessed". WMP appears to change this each time I play something. I might select all songs and scroll thru building a playlist. I just checked, and the date on every music file is 6/6/08 - the last time I ran the player, even though I just played a dozen or so tracks.

    SyncToy must be looking at that date. It would be useful if there were an option to ignore "Date Accessed". It would also be nice if WMP had an option to not update that field - haven't checked yet
    Wednesday, June 11, 2008 11:08 PM
  • I have to agree, 1.4 is way faster than 2.0, 1.4 would take my huge collection of mostly picture file, 4297 folder, 144539 file and about 35GB of data. It get stuck on taking action part, I check the file and they are fine but I notice it has a hard time with read only files, I'm Echoing from a Laptop Hard Drive. WD 250GB 5400rpm to a WD 750GB RE2 SATA 2. It take about 3 hours in all, 1.4 would do in half that.
    Monday, June 23, 2008 3:24 AM
  • When you compare 3 hours on SyncToy 2.0 vs 1.5 hours for SyncToy 1.4 - are you comparing an initial sync ( time taken to actually copy 35 GB of data from the left side to an empty right side) or a sync after that where you are trying to keep ~35GB of data in sync between the left and the right?

     

    Thanks

    Deepa

    Tuesday, June 24, 2008 11:32 PM
    Moderator
  • I'm talking more or less about the time it take to scan right then left and see what files have changed, moved or need to deleted. I don't really care about the time it takes to move the files. That depend on mostly hardware, but the scanning on the other hand is a mix of hardware and software. I went in to taskmgr and it was eating very little CPU time, if any at all. When 1.4 was running it loved the Intel 2.2GB Core 2 Dou, it would just sped along. I run this software mostly for backing up the files to another system.
    Tuesday, June 24, 2008 11:54 PM
  • Thanks for getting back to us! We think we have a fix for this and you should see the improvement in our next version. To help confirm that indeed this is the problem - could you compare times taken when there are no changes that need to be sync'ed over. Basically time taken to do an empty sync.

     

    Thanks

    Deepa

    Wednesday, June 25, 2008 1:40 AM
    Moderator
  • Hooray! I'm glad to see a solution is forthcoming.

    Every time I attempted to use v. 2, it took so long that I would eventually just shut it down. It would just go on for hours without making progress. V. 1.4 works well for me, and takes about 15-20 minutes to sync my desktop and laptop or to sync to an external HD. But it is lacking in features that are needed.

    I look forward to the additional functionality of v. 2. Til then, I'll keep using v. 1.4.
    Wednesday, July 2, 2008 8:07 PM
  • I am having the same problem, though it manages to get through the preview, eventually, but to copy 4GB gets stuck very quickly (about 5% of the way through).

     

    It is significantly slower than 1.4 which was fine, except that it did not delete blank folders and possibly had issues with long file names.

     

    Incidentally, I am syncing USB drive to USB drive, so I do expect some delay but not to get stuck! Wink

     

    Looking forward to the fix!

     

    Thanks

     

     

    Thursday, July 3, 2008 10:00 AM
  • I have been using Sync Toy 1.4 for quite a while, but my set of folder pairs has gotten so large that Sync toy reported 'out of memory' exceptions when I ran a sync on all pairs. I am running Win XP SP3 with 2 GB of memory.

    I had to sync small sets of pairs at a time and then it worked, but this took about 1/2 hour. So I decided to try an upgrade.  I performed a full sync and then downloaded Synctoy 2 and installed it.

    When I ran the first sync it took several hours, but did complete; and it did find a few things that version 1.4 missed.

    I had it set to preview and then run and it took the same to to run as preview, so I've been at this all day now.

    I thought SyncToy 1.4 ran its execution very quickly after a preview,version 2 seems to start all over again.

    I have 2 external Firewire 800 drives (750GB), 1 external Firewire 400 drive (500 GB), and 1 USB drive (400 GB) that I sync to my main 1 TB drive. These are all formatted in NTFS with 64K clusters. I usually get 40 MB/s transfers on these drives (except for the USB drive).

    I have a lot of music files (samples and projects) that I 'echo' to these various drives. They don't usually change very much, mostly just grow, but occasionally a software update will cause a small amount of change.

    The speed difference is very substantial and I'd switch back, but it looks like this version is more accurate and will eventually straighten itself out.

    If you would like me to run that trace test I'd be happy to do so.
    Friday, August 1, 2008 3:09 AM
  • Hi Archnaut

     

    Would you mind contacting me through email?  I have a few specific questions for you.

     

    My email is liam.cavanagh@NO_SPAMmicrosoft.com

     

    (please remove the NO_SPAM part) 

     

    Thanks,

    Liam

     

    Friday, August 1, 2008 7:15 PM
  • Hi
    I just thought I'd put my 2 cents in here. I'm using XP sp3 and have a 900gig raid that I want to back up to a 1TB external drive. So far I've been doing that manually.

    I came across Synctoy V2 the other day and thought I'd give it a try. While I'm sure it could do what I want, it's been running a preview for 3+ days now. It hasn't crashed and it hasn't locked up, it's just incredibly painfully slow. It likes to sit on a file for 1/2 hour or more. I don't know what it's doing, but there is no disk activity on the external drive (or it is so seldom that I don't notice), the internal (raid) has between 100 to 300 operations/sec from Synctoy according to performance monitor, memory usage is constantly only at 37%, there is no CPU usage to speak of.

    Once this preview is finished (hopefully in no more than a day) I'll try an echo, if it's just as slow, I will remove v2 and  try V1.4 instead.

    If Synctoy is scanning files internally, I don't need it to do that. All I want is to replace older files with newer ones based on the modified file date. Is there an option that I missed to control that?

    Rick-S

    Edited to add: I just noticed that there is an option 'Do not check file contents', it has a pale blue dot so I assume that option is enabled. I can't access it while the preview window is active.


    Sunday, August 10, 2008 10:03 PM
  • Hi,

    I also tried to use SyncToy 2.0 on a network drive. Before letting it run away with my files, I tried the preview function. It ran a bit slow so I went out and did some shopping, came back an hour and a half later and it was still working on the first 100 MB of 30GB of files to copy. I like to use SyncToy 1.4 when I need to copy large numbers of files because it is easy to restart it if I need to stop in the middle. Isaw the new version of the product ant thought I'd give it a try. I was running with a new folder pair copying from a network drive to my local drive in preparation for archiving my photo files onto a set of DVDs. The destination folder was empty.

    Afer an hour and a half of it attempting to do the preview, I gave up. I tried both Echo and Contribute attempts I checked the Networking tabl of Windows Task Manager and found that it was using almost no network resources

    Cheers!


    Sunday, August 10, 2008 10:56 PM
  •  

    I now use Synctoy on all my computers (4 of them) to keep about 60GB of music sync'ed between all of them.

     

    For some reason, I have NO PROBLEMS whatsoever!  Synctoy 2.0 works speedily and always without issue.

     

    What am I doing RIGHT?  Smile

    Sunday, August 10, 2008 11:00 PM
  •  

    Wow..  I've been having the same problems with 2.0 beta. 

     

    I downloaded SyncToy 2.0 earlier this week, and tried it out syncing My Documents between my Laptop and my Desktop (15GB, 18,347 files, Gigabit card in desktop, gigabit switch, 10/100 card in laptop) and I let the preview run for 5 hours before I stopped it.  I had a new computer coming in, so I decided that my old computer was just acting up.

     

    I got my new computer in and set up, and started the preview, it worked VERY quickly on the local check, but when it got to the networked laptop folder (\\ JAKE-LATITUDE\My Documents) it slowed to a crawl.  After 4 hours it was only on the C's (3.32G up to that point that it had to look through, 3,589 files, 469 folders).

     

    I found this thread, and decided I'd try SyncToy 1.4.  In the time it has taken me to complete this message < 5 minutes, it has performed the initial preview, and the complete initial sync.  (Initial Sync was 2,295 files out of 18,347 total files),  This is with the exact same data set as 2.0 beta.

     

    I would be more than happy to participate in any way to help getting 2.0 beta up and running.

     

    JAKE

    Friday, August 15, 2008 6:15 PM
  • It would be great if everyone that has had issues with performance could give the latest version of SyncToy 2.0 a try.  It has just been released and more details can be found here:

     

    http://forums.microsoft.com/sync/ShowPost.aspx?PostID=3753059&SiteID=75&mode=1

     

    Liam

     

    Saturday, August 16, 2008 12:07 AM
  • Both the 32-bit and 64-bit download links don't work.  Just get a Page Not Found...

     

    Saturday, August 16, 2008 12:42 AM
  • Please refresh the page and try again. I got the same error on the first try but it succeeded after doing the refresh.

     

     

    Saturday, August 16, 2008 1:11 AM
    Answerer
  • I've been refreshing over 20 times, I'm still getting a 404 Not Found.
    Saturday, August 16, 2008 1:59 AM
  • I was able to download it just now.
    Saturday, August 16, 2008 4:52 AM
  • Liam,

    i downloaded and tested Synctoy 2.0 this morning. The results are, well, mixed. I tested it with my default case: Synchronizing my Documents folder with my primary Notebook. My Documents folder contains ca. 104,000 files, ca. 650 of which require synchronisation.

    I'm using Vista Ultimate 64 on both machines, so i installed the x64 version of synctoy 2.0.

    The good news: Synctoy 2.0 finally succeeds to show me a preview. It finishes it's preview in about 6 Minutes, which is an acceptable time.

    The bad news: Synctoy is still considerably slower than Synctoy 1.4. That goes für the Preview (Synctoy 1.4 take 3 minutes 45 seconds to show the same preview), but even more for the file copying part.

      Synctoy 2 is awfully much slower when copying the files, taking easily 5 times the time Synctoy 1.4 uses to copy the files. The reason obviously isn't the transfer speed itself (while copying a large file, Syntoy 2 is just as fast as 1.4),  but Synctoy 2 seems to take long pauses between the files. In 1.4, there's no pause between the files at all, small files appear so fast in the "Copying..." line you can't read their names. In 2.0, it copies some files very fast and then suddenly starts crawling, taking 5 to 10 seconds for even the smallest file, keeps that slow for some time, then speeds up again, almost in waves.

    Some more observations:

      Synctoy 2.0 uses much less memory, but much more CPU Power than 1.4. When 1.4 is comparing, it's memory use (as watched in the task manager) goes up to some 180,000 K, with CPU load near zero for most of the time, while 2.0s memory never goes above 31,000 K, with a constant CPU load of 15 to 30% (on a Q6600 quad core machine).
      That and 2.0s behavior of doing some things very fast, then slowing down to a crawl for some time, then speeding up again and so on (not only while copying files, but also while scanning and "adding actions"), gives me the impression that it's working with far too less memory. Given the fact that i have 8 GB installed, it could use lots and lots more, but it doesn't, and it seems as if 2.0 spends much time reorganizing the few memory it uses, thereby using all the CPU cycles.
      Synctoy 1.4 uses more memory instead, and keeps it's cpu load near to 0 when comparing and copying. The only time 1.4 uses CPU power is when "Loading saved information for" my directories, which seems to be the phase when it decides which files need action.

    I have to conclude that while things have gotten better, Synctoy 2 still is no replacement for 1.4. I sincerely do hope that the problem is just within Synctoy and not within the whole MS Sync framework.

    Saturday, August 16, 2008 10:54 AM
  • How do I know whether I need 32-bit or 64-bit? I want to make sure I download the correct SyncToy V2.0 version.

    I have Windows XP Professional.
    Saturday, August 16, 2008 4:46 PM
  • sbenard, unless you specifically installed 64 bit windows, it will be 32. I imagine 64 bit windows will have it marked somewhere if you poke around, but I couldn't find anything that told me mine was 32 bit other than looking in the windows folder and seeing system32 there.


    Version 2.0.100.0:

    I just tried the new version, much better than before. To preview a 600gig echo took about 1 hour (rather than the 4 days before) and running the job took 1.25 hours (rather than a day).

    As mentioned in a previous post, synctoy still pauses on some files. I have it set to not check file contents, yet big files still seem to take longer. Also, shortcuts (a shortcut to a drive or folder for example) seem to pause a long time too. Is it possible that synctoy is scanning what the shortcut is pointing at as if it's a subdirectory? If so, there should be an option to not allow that.

    In any case, a full 600gig preview and echo took just over 2 hours and I'm good with that.

    Rick S

    Sunday, August 17, 2008 12:42 AM
  • Cgdams - these numbers you're reporting after upgrade to 2.0 final build - are these from the first sync after upgrade? The first sync after upgrade is special and it will take more time because the metadata databases for both sides are completely rebuilt. The times will get better as you sync multiple times and the databases on both sides get a chance to finish building their indexes. Please let us know if it gets better with more syncs.

    Sunday, August 17, 2008 5:22 PM
    Answerer
  • Thanks for the fast feedback, Asish,

    i'll try a daily sync with Synctoy 2 every day, for the next week, and i'll report back my experience end of next week.

    'til then, have a good time,

    Christian
    Sunday, August 17, 2008 6:06 PM
  • I uninstall my old version of SyncToy 2.0 and Installed the new one. I delete the old Sync Data files and start a "Preview" First 10 min it was scanning folders. For the next 19 Minutes it said "Looking for Changes in *****". and the final 3 minute it displayed all the changes, a total of 822 files and 6 folders, Found 294,373 file that did not require action.

    Hardware Local Drive Seagate 5400 rpm SATA 2 drive running over 1 Gigabyte Ethernet.
    Hardware Remote Drive Western Digital 750GB 7200 rpm SATA 2 with 1 Gigabyte Ethernet.

    Overall to do a Preview and it only takes 32 mins, Left Folder: 39 Gigabyte folder and Right Folder: 750gb drive with 479gb used space totaling 152,825 files with 4705 folders.

    Not bad at all, it a lot faster than the old version of 2.0, still need some improvements, like maybe an time counter showing how much time has passed and maybe tell us whats going on those 19 minutes where it was just hanging out on that last folder, I think it was writing the data files. Also it only used 20 to 40% of my Intel Core 2 Dou 2.5Ggbz with 3mb L2 Cashe, and only used 20k of the 4GB of ram and a 4GB ReadyBoost Drive.
    Sunday, August 17, 2008 6:50 PM
  • Rick-S,

    Thanks for the help!

    New question:

    I installed SyncToy 2.0 (the old one that took forever), but because of all the issues reported on this forum, I have never run it a single time. I've been using version 1.4 for the past several months.

    The download page doesn't indicate that an uninstall of the old version 2.0 is a necessity, but other users have said they uninstalled the slow one and did a new install of the latest version 2.0. Is it necessary or recommended that we uninstall the old version 2.0 before installing or running the newest one? What about version 1.4? Same question?
    Monday, August 18, 2008 1:12 PM
  • You don't need to uninstall. The latest release version will upgrade your previous 1.4 or 2.0 Beta installation. Please try it out and let us know how it works out for you. You do need to make sure before you upgrade, that all of your folder pairs are fully synchronized. And after the upgrade, please run all of your folder pairs as well.

     

    Monday, August 18, 2008 6:52 PM
    Answerer
  • I setup two server 2003 r2 boxes with a 300G folder to echo from clf-06 to clf-07.  V2.0 seems to scan and prepare its list of work to do in a reasonable time but the file copy is very, very slow.  These are dedicated machines on a 1G switch with no other activity and after for the last 8 hours have only copied 63162 files.  Task Manager is showing 0-1% cpu load and the network monitor is almost making it to 6% but with very regular valleys that look like throttling.  average network load is probably around 1%.  Both CPU's are quad core xeons with 4G ram using onboard intel pro/1000 mt interface.  Disks are 1.5 TB raid 6 echoing to a 2.3TB raid 5 both on 3ware SATA controllers.

    I watched synctoy take about 2 minutes to copy a 705MB file that drag and drop copied in about 35 seconds.

    Is there a throttle in the registry or elsewhere that I can change?

    8/20/08 2126
    Further testing shows it only runs every 15 seconds and that just isn't often enough for moving much data.


    Wednesday, August 20, 2008 1:23 PM
  • I'd like to add that some (minor) problems remain. My default sync i mentioned in my posts above works very well now, it's actually faster than it was in Synctoy 1.4, so i've uninstalled 1.4 and switched to Synctoy 2 for good now.

    Today, i had an opposite experience. I switched one on my hard disk drives for a bigger one. To transfer the content of the smaller drive to the bigger one, i connected both via USB to my machine and copied all files with Robocopy from one to the other drive (~97 GB, ~98,000 files, ~13,500 folders). One of the options in Robocopy was to omit copying empty folders. When i was done copying, i tried to use Synctoy 2 to add the uncopied empty folders to my new drive. The Preview took quite long, and the speed showed the usual "wave" behavior:  comparing lots of files very fast, then really "crawl" for some seconds/minutes, then speed up again and so on.

    When the preview was done, if showed the expected result: 691 empty folders needed to be created on my new drive. Just creating these empty folders took more than half an hour, and it seemed to get slower by every folder it created. The last one, with the progress bar at 100%, stayed on screen for more than two minutes!

    After completing the first sync, a new preview is now done in less than a minute. I supect that I'll also seem the same speedup in synchronizing. So Synctoy is working fine for future syncs, but the first run still seems to be terribly slow.
    Thursday, August 21, 2008 12:54 PM
  • I just wanted to add my results with the new 2.0 to the mix (even though I've never had any problems with the beta 2.0).

     

    I just installed Vista Ultimate 64-bit on my "notebook" (A Dell 20" M2010) which is a 2.1Ghz system with 3GB RAM and a 320GB HDD.

     

    As part of my music sync process, I have a Server 2003 server that holds all my music (about 60GB), and regularly sync that with my Desktop system, a shop system, and various notebooks. 

     

    Today I ran the new 64-bit version of Synctoy to sync 60GB of music onto my notebook (from server to notebook over gigabit ethernet).  Here are the results:

     

    SYNC: 08/23/2008 19:03:26:262: SyncToy run of Music -- Server to PC (\\myservername\music\, E:\Music\) completed at 8/23/2008 7:03:26 PM.

    SyncToy action was 'Echo'.

    SyncToy options were:

                    Active for run all

                    All files included

                    No files excluded

                    Do not check file contents

                    Include read-only files

                    Include hidden files

                    Include system files

                    Backup older files (send to Recycle Bin)

                    All subfolders included

    SyncToy run took 00:40:12:597.

    Copied 60,702,349,159 bytes in 10,902 files in 00:40:12:597.

    Bytes per second 25,160,575.5, files per second 4.5

     

    So, it took about 40 minutes to sync 60GB of music (mp3's) to my notebook.  It seemed to be moving very fast, and I think 40 minutes is a good time.  Subsequent syncs correctly showed 0 files to sync, and generally took about 10-15 seconds to scan and give a zero result.

     

    PROBLEM:  What does concern me is that something changed the date modified on about half my music files on the server after that sync.  Because of that, attempts to sync my desktop or notebook resulted in about 5000 files that needed to be overwritten.  I restored my music from a backup made that morning, and everything is back to normal.  Odd...

    Sunday, August 24, 2008 11:43 AM
  • Would it be possible to change the location of the SyncToy 2 database?
    There is a 'SyncToy.config' file.

    I would like to move it off my system drive because it causes so much fragmentation.
    Tuesday, August 26, 2008 4:47 PM
  • I am sorry - there is no way currently to change the location of the synctoy database file. If you go to Help->Customer Feedback Options - can you check if you have Yes or No selected there? I am wondering if that is what is causing a large number of SyncToy_*dat files to come up on your system drive?

     

    Thanks
    Deepa

    Tuesday, August 26, 2008 5:28 PM
    Moderator
  • It is turned off
    Friday, August 29, 2008 3:52 AM
  • Now I'm having a problem (since switching one computer to the newer Synctoy 2.0 x64?).

     

    When I do a Sync of music from my server to my PC, using Echo method, and I do a preview, it shows that there are NEW files to sync.  The problem is, those are NOT new files, they already exist in the target location, and if I proceed with a RUN, I wind up with files identical to the original, just with a ".1" added to the name (so song.mp3 becomes song.1.mp3).

     

    Is this because one of my computers is running Synctoy 2.0 x64 and all the others are still running the BETA 2.0 (perfectly, up to this point)??

     

    This is now causing much unpredictable behavior that is driving me crazy.  I don't want to lose any of my files in trying to clean this mess up of duplicate and triplicate files!

     

    Thanks.

     

    Sunday, August 31, 2008 6:22 PM
  • Can you describe your setup in more detail? For any two folders that you want to keep in sync using SyncToy, you should only sync them from a single copy of SyncToy installed on a single PC - you'll get unpredictable results if you try to sometimes sync these folders using SyncToy on one machine and then some other times, try it from another machine.

    Tuesday, September 2, 2008 3:41 AM
    Answerer
  • That is what I have been doing with the 2.0 BETA software for quite a while, without any issues.

     

    Basically, here is what I have...a network setup with a server (Windows 2003 R2) with about 60GB of MP3 music.

    On this network I have my main desktop PC w/Vista Ultimate32, a "play" PC w/Vista Ultimate64, and two notebook PC's.

     

    Up to now, I haven't had a problem keeping the MP3 content sync'd on all the computers.  I basically only use ECHO or CONTRIBUTE mode on all of them, and have folder pairs setup on each PC that go both ways (PC-to-Server and Server-to-PC).  This way, I treat the server and my main desktop as "master" computers (music folder could have deletions), and the "play" and notebooks as "slaves" and usually only sync from Server-to-PC on the notebooks (only delete on these if the server has it deleted).

     

    For some reason, now, from my desktop PC, when I attempt to sync Server-to-PC, it wants to write "NEW" a bunch of MP3's that are already in that patch on my local drive. I've noticed it had that problem going the other way too (PC-to-Server) as the server had a bunch (hundreds) of MP3 with filenames with ".1" added to the filename. 

     

    I understand that you say you shouldn't sync more than two computers (why?), but it has always worked in the past.

     

    Only one of the notebooks and the "play" desktop have SyncToy 2.0 x64.

     

     

    Tuesday, September 2, 2008 12:11 PM
  • Bump.

    Just wondering if there is going to be a fix or a new version introduced to correct the slowness.

    Right now I use 1.4 because 2.0 Beta and 2.0 Official have been way to slow to finish.

    I have about 40GB syncing... MP3s, JPGs, misc documents, the typical collection.

    I have Synctoy installed on a XP laptop with SP3, and it syncs with a Vista desktop running SP1.

    Both have all patches.

    I sync with a wired 100MB connection on a local network (home linksys router).

     

    Thanks,

    Jdogga

    Friday, October 24, 2008 5:26 PM
  • Just seeking some closure on this while I watch my 2TB sync run in start-stop waves like cgdams mentions... from what I gather in reading this thread some users who previously had problems with syncs "never" finishing actually overcame it by waiting it out. It sounds like when the first sync finished, subsequent syncs didn't experience the pauses.

    I watched a sync take three days last week to do 75% of a 2TB echo. I had to give up and am trying to get the rest done now. It had pauses in the first echo and is having pauses now.

    Most of my 2TB are made up of JPEGs (<10MB each) and the pauses occur on seemingly random images. SyncToy is using minimal CPU and 42MB memory, which doesn't change much when it "un-pauses". Around 1,000 files get copied between pauses. Each pause seems to last about 10 - 20 minutes. Time between pauses seems around 5 - 10 minutes.

    Specs: 8x Xeon 2.33GHz processors, 4GB RAM, Win 2003 SBS. The SyncToy DAT file is 1KB.

    So I'll keep perservering and hopefully it will get over its initial slowness in the same way others experienced.
    Monday, November 17, 2008 3:29 AM
  • Some tips from my personal experience with Synctoy 2.0 that should help those who have performance problems:

    • Don't perform the intial duplication of your data to the destination location with Synctoy, especially when you have such a huge amount of data to synchronize. Instead, use xcopy or robocopy to duplicate your data to the destination location and use Synctoy to synchronize source and destination from then on.

    • On large folders, it can take an awful lot of time to perform the first comparison on a new folder pair in Synctoy. When compairing a folder par for the first time, Synctoy has to add a lot of filenames and actions to it's internal database, and the underlying database obviously isn't good at this. Here, you just need to be patient. Very patient....

    • Beginning with the second run on a folder pair, things get much better. Synctoy is remarkably fast on compairing even large collections of files and folders, and the copy portion runs at the full speed to be expected from your network and/or disks.

    If you don't need to see what gets synchronized before you actually snychronize it, you might also consider Robocopy (with the /MIR option) instead of Synctoy. If you don't know it, just google (or Live search) for it...
    Monday, November 17, 2008 10:30 AM
  • I have to agree with all of the other posts on this subject.  SyncToy 2.0 is not only painfully slow, but it hangs up not responding for 15-45 minutes at at time.  It's weird.  It will hang up, and then eventually it will pop back and then synchronize normally withint a couple of seconds or minutes.

     

    I ran SyncToy 2 on a folder with only 5 updates needed.  It took 45 minutes to process those 5 files.

     

    As much as I liked SyncToys, I'm actively investigating other alternatives.  The big problem is that when SyncToy does work, it handles renamed files et al.  Unfortunately, it does not sychronize individual files within a folder.

     

    Other alternatives sychronize files, but can't handle renamed files and directories.

     

    I wish the two teams could get together and produce a sychronization application that can do both.  Sigh, I think the community is too disorganized and unfocused to solve the synchronization problems from soup to nuts.

     

    I can handle the individual files with a macro routine, but I wish SyncToy would solve the incredibly slow time it now takes to sychronize a folder that used to take only seconds or minutes.  Now, it takes minutes to who knows how long.   I've terminated more sychronizations with SyncToy 2.0 because of slowness or hanging than I have with all other versions of SyncToy combined.

    Monday, December 1, 2008 10:16 PM
  • cgdams' tips are spot on for my situation. synctoy 2 is now much more efficient after (finally) getting through the first echo.
    Monday, December 1, 2008 11:27 PM
  •  

    I'm getting the same problem, it's just totally unusable, and in fact, I reckon I could have a program MD5 Hash every single file in both folders before this thing has even got 1/3rd of the way through.

     

    Totally useless in my opinion, sorry but it is.  Over 3 hours and it hadn't completed 1/3rd of a 180gb folder containing solely MP3's, it's just not usable in version 2.0.  And what's more I wouldn't even need to use it if explorer gave you the option to only replace newer files when copying an entire directory of folders.

     

    What's odd is it's memory usage isn't particularly high and I would understand if it was storing each result in a less than optimum way, but 15mb doesn't really reflect this.

    Thursday, December 4, 2008 4:00 PM
  • I agree, unfortunately totally unusable tool.  ( I guess what do you expect for free?). I tried ViceVersa, it's at LEAST 10x faster.  I'll have to pay a few $'s to get something that actually works.

    Tuesday, December 30, 2008 4:05 AM
  •  Avvidman wrote:
    I agree, unfortunately totally unusable tool.  ( I guess what do you expect for free?). I tried ViceVersa, it's at LEAST 10x faster.  I'll have to pay a few $'s to get something that actually works.

     

    Interesting how people complain it doesn't work when I have NEVER had a problem with Synctoy being slow on any of my computers.  I run it on at least 6 different desktops and notebooks...never a problem with it being slow.  I wonder what it is about my setup (or others) that cause it to act that way?

     

    I feel lucky it works great for me...it's a great tool to have.  I even use it on client's PC's as a simple, one click, backup!

    Tuesday, December 30, 2008 4:28 AM
  •  lancorp wrote:

     Avvidman wrote:
    I agree, unfortunately totally unusable tool.  ( I guess what do you expect for free?). I tried ViceVersa, it's at LEAST 10x faster.  I'll have to pay a few $'s to get something that actually works.

     

    Interesting how people complain it doesn't work when I have NEVER had a problem with Synctoy being slow on any of my computers.  I run it on at least 6 different desktops and notebooks...never a problem with it being slow.  I wonder what it is about my setup (or others) that cause it to act that way?

     

    I feel lucky it works great for me...it's a great tool to have.  I even use it on client's PC's as a simple, one click, backup!

     

    Quite simple really, I would say it's down to quantity of files.  Don't be so surprised that it works for some people and not for others, that's software for you.

     

    The number and spec of machines you are using has got nothing to do with this problem.  How many files are you syncing?  I bet its nowhere near 13,000 in 1,400 folders

     

    BTW, giving clients beta software for backup purposes is pretty risky imo.

    Tuesday, December 30, 2008 9:04 AM
  •  Firkinfedup wrote:
     lancorp wrote:

     Avvidman wrote:
    I agree, unfortunately totally unusable tool.  ( I guess what do you expect for free?). I tried ViceVersa, it's at LEAST 10x faster.  I'll have to pay a few $'s to get something that actually works.

     

    Interesting how people complain it doesn't work when I have NEVER had a problem with Synctoy being slow on any of my computers.  I run it on at least 6 different desktops and notebooks...never a problem with it being slow.  I wonder what it is about my setup (or others) that cause it to act that way?

     

    I feel lucky it works great for me...it's a great tool to have.  I even use it on client's PC's as a simple, one click, backup!

     

    Quite simple really, I would say it's down to quantity of files.  Don't be so surprised that it works for some people and not for others, that's software for you.

     

    The number and spec of machines you are using has got nothing to do with this problem.  How many files are you syncing?  I bet its nowhere near 13,000 in 1,400 folders

     

    BTW, giving clients beta software for backup purposes is pretty risky imo.

     

    How about 11,700 files in 1,240 folders?  60GB of MP3 files.  And I've kept that much data synced on more than 6 PC's since I've been using Synctoy. Probably closer to 12, all told.   I get new computers often (part of the business I'm in), and included in the setup of the new computer is setting up synctoy and syncing my music collection to the computer.  This includes both 32 and 64 bit installs.

     

    FWIW, I give my clients what I find, in my professional opinion, works.  Given the magnitude of success I've had with Synctoy, I don't have any qualms about them using it, and so far, they have been using it successfully and without complaints.

     

    Synctoy works great for me.  Always has.

    Tuesday, December 30, 2008 1:28 PM
  •  Firkinfedup wrote:

     

    Quite simple really, I would say it's down to quantity of files.  Don't be so surprised that it works for some people and not for others, that's software for you.

     

    The number and spec of machines you are using has got nothing to do with this problem.  How many files are you syncing?  I bet its nowhere near 13,000 in 1,400 folders

     

    BTW, giving clients beta software for backup purposes is pretty risky imo.




    13.000 files in 1.400 folders? You're right, i'm nowhere near that.

    Actually, it's 56.673 files in 7.928 folders for me at the moment.

    As for speed: Synctoy compares this folder to it's counterpart on my notebook over a 100Mbit/s Ethernet line in about 100 seconds and then copies the necessary files at the maxmimum network speed of ~12 MB/s.

    Let me repeat the most important fact about Synctoy when measuring speed: It's the first comparison on a new folder pair that can take forever. Once this first comparison is done, Synctoy is really fast and very reliable. You might want to read my post with some general tips, on page 5 of this thread.

    Oh, and BTW: This thread is quite old. The beta phase of Synctoy 2 has ended months ago, there's no beta risk anymore....

    Tuesday, December 30, 2008 6:48 PM
  • I am experincing the same issue with version 2.0

    If anyone has a fix I would be happy to know.

    Synctoy 1.4 was backing up my network drive in 10 mins - now 2 hours or not at all - just hanging.

    grrr
    Monday, February 2, 2009 11:10 PM
  • I confirm having the same issue (very slowww!) when running SyncToy 2.0 on an WinXP PC. I was about to throw this addon away when I decided to give it another chance on Vista.

    It seems to be working fine on a Vista laptop, even over a WLAN. 
    Wednesday, February 11, 2009 5:17 PM
  •  As with most of these posts I have been uysing Synctoy 1.4 for years without issue.  I use it to keep a desktop and laptop synchronised via a NAS drive.

    Now I have upgraded to 2.0 I get different performance on both machines.  My Dell Laptiop (4Gb memory, 2.0Ghz Dual core processor) zips through the process in less than a minute wirelessly.  My more powerful (4Gb memory, 2.4Ghz quad core processor) takes over five minutes on a wired ethernet connection.

    Any thoughts on why there is a difference?

    Best wishes,

    Jon
    Thursday, February 26, 2009 11:23 AM
  • Hey, The sync in v.2.0 took me forever indeed, even the deletions acts (the initial sync - of about 200GB - didn't take long, but the sync actions later did).

    I have unmarked the option "Save overwitten files in Recycle Bin".

    Now it works faster (at least less slow), I think. Yet it still gets stuck sometimes.


    BTW, If there was a way to move the data files from app date to another hdd, it would be great.

    Wednesday, March 4, 2009 12:51 PM
  • Has anything ever been figured out with this program? I am attempting to use it but it is way slow.

    My folder is 3.39gig and has 1,441 folders and 35,616 files in it
    Computer is Vist Q6600 processor

    I copied the folder to the remote location and then created the Sync folder. Started running a comparison. It has been running for 25 hours and is less then 1/2 done, that makes no sence at all.

    Any recomendations on a program that works, I really thought this was exactly what I had been looking for. Well it is, just doesn't seem to work.
    Wednesday, March 4, 2009 3:07 PM
  • Hi -

    The first sync is always slow but it should not be this slow. Are you working the SyncToy 2.0 RTM version ( not Beta)?

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Wednesday, March 4, 2009 8:04 PM
    Moderator