locked
Backup Service errors (IWbemLocator::ConnectServer; sort.cpp) --> server reinstallation fails too RRS feed

  • Question

  • I am having frustrating problems.  No longer able to back up or access backups, every attempt would complaing that the Backup Service was not running (even though the Services snap-in showed that it was) and was always assocated with a pair of errors in the event log complaining about 1) IWbemLocator::ConnectServer and 2) [some path]\backup\util\sort.cpp, similar to http://social.microsoft.com/Forums/en-US/whssoftware/thread/f476260a-55b7-4c7d-a946-303df891ae07 . I also see cryptic errors like "Fault Bucket 1201134262"

    chkdisk /x /r did not reveal any problems, and there were no bad sectors.  I also uninstalled all addons.  No dice.  Since I wasn't able to solve the above issue, I tried to do a server reinstallation, but that is failing :(.  There are all sorts of messages complaining about qs.ini and in the end the install fails with this:

    [7/30/2009 6:49:02 PM   d8] Creating directory D:\shares\Software\Home Server Connector Software
    [7/30/2009 6:49:02 PM   d8] ERROR: Failed to copy c:\WHS\WHSConnector.msi to D:\shares\Software\Home Server Connector Software\WHSConnector.msi (0x80070006)
    [TRACE] PublishFiles : Exited (0x80070006)
    [TRACE] Step_InstallQ : Exited (0x80070006)
    [7/30/2009 6:49:02 PM   d8] Installing Windows Home Server failed. Error 0x80070006.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 2
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [7/30/2009 6:49:02 PM   d8] MessageBox: Installing Windows Home Server failed: The handle is invalid.

     (error code 0x80070006).
    [7/30/2009 7:47:48 PM   d8] Windows Home Server setup failed. The error code is 0x80070006. Please correct the problem and reboot to restart the setup program.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 2
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [7/30/2009 7:47:48 PM   d8] MessageBox: Windows Home Server installation failed. Do you want to view the installation log file?

    Any advice to help me rescue this server reinstallation?

    Friday, July 31, 2009 2:12 AM

All replies

  • Try deleting the C: partition on that system disk, and also try replacing the DVD-ROM drive.
    I'm not on the WHS team, I just post a lot. :)
    Friday, July 31, 2009 3:49 PM
    Moderator
  • Won't C: be locked whenever I am booted into WHS, even in safe mode?  I guess I can do it using a bootable CD.

    More importantly, if I do successfully delete the C: partition, then won't I lose the option to perform a server reinstallation , since WHS installer will search and find no existing OS once C: is gone?
    Friday, July 31, 2009 4:27 PM
  • You should still be able to do a server reinstallation. And yes, C: will be locked, so you'll have to install the disk in another computer or use a bootable CD to remove the partition.
    I'm not on the WHS team, I just post a lot. :)
    Friday, July 31, 2009 4:34 PM
    Moderator
  • OK, I will give it a try.  If it doesn't work, my only other option would have been a new install anyway.  Thank you.

    Friday, July 31, 2009 4:41 PM
  • An update: I used a bootable CD to reformat the C: partition.  Unfortunately, I then lost the option for a server reinstallation, so I had to do a new installation.  I hope with this new install that I am not be hit with more cryptic and fatal IWbemLocator::ConnectServer and sort.cpp errors.
    Monday, August 3, 2009 3:48 PM