locked
Remote access not available, domain name not working RRS feed

  • Question

  • Now, as the final step in the saga of reinstalling my WHS on a HP MediaSmart Server (EX475) I want to solve the probelm with remote access.

    The server had a hard drive failure and the hard drive was replaced by an HP autorised shop, after some trouble to access the server at all, that has now been solved (see previous questions of mine), but remote access still doesn't work. I have a feeling it may have something to do the server moving ISP, country and router and therfore the DNS might have a problem finding it. However, I have no clue on how to solve the problem. Unfortunately I can't do any fault finding on these three issues as the ISP I used in the UK isn't availabel in Sweden, I can't move back to the UK just for this purpose, and the old router was the property of the UK ISP, so I don't have it anymore.

    I've read other posts that talks about unconfiguring the domain name (xxxxxx.homeserver.com), but I have no such option, just "Details" and "Configure". Details just says "Status: Not working", "Service Provider: Windows Live Custom domains", the ret is blank. In configure I have the option to "Release your current domain name" or "Choose a different domain name", none of which appeals to me. I would very much like to use my old domain.homeserver.com as friends and family finally remember it. In the remote access tab under router it reports my router IP and server IPs correctly. Under Domain name it lists my old domain name.

    When I click the Remote Access "Repair..." it says that Remote access is being repaired and veryfying that remote web site is available locally, but then fails (red X). Clicking next tells me "A local web server or firewall issue may have occured." Under toolkit 1.1 I've tried to researt IIS to see if this solves the problem, but no change at all.

    Oh BTW, when I run the toolkit it reports that I run different versions on the laptop and the server. I've uninstalled it on the server (and deleted it from the "Add-in" folder) and published it again from the laptop to the server and it still says I'm running diffferent versions (laptop: 6.0.2030.2 server: 6.0.2030.0). I get no other errors in advanced mode ot toolkit, everything else gets a green tick.

    The only thing I can access in a browser is http://ServerNAME/home, i.e. the basicstart page, anything else fails.

    Any help on this issue is very much appreciated.

    My setup:
    Cable modem
    D-Link DIR-855 router (2.4GHz and 5GHz)
    HP MediaSmart Server EX475 on WHS (2.5TB)
    Maxtor Shared Storage Plus (500GB)
    2 Dell XPS M1530 (Vista Ultimate and Home Premium 32-bit)
    XBox 360 Elite
    Sonos system (4 devices)

    11:45 CET 20th July: xxxxxx.homeserver.com/home - works, none of the links on the fron page works though, xxxxxx.homeserver.com/remote says that I need to type in https:// beofre the address as the page needs to be viewed on a secure channel, but when I comply it' not accessable, which is rather odd. xxxxxx.homeserver.com still doesn't work.

    /Donald

    • Edited by donlin Monday, July 20, 2009 9:52 AM Update on what I can access on the domain
    Sunday, July 19, 2009 3:38 PM

All replies

  • I guess you are using Internet Explorer to access the server (if not please try this first).

    If you are accessing the server from outside your LAN please make sure there's no firewalls blocking any of the essential ports. You may also need to check if ISP is blocking any service ports (specifically port 80)

    Next please check if port forwarding in your router is properly configured.  Background info and more help can be found in the Windows Home Server Console Help ( If you click Details in the WHS console, Settings, Remote Access Menu then click the help link at the bottom of the Details window you get to the correct pages) and in the Technical Brief Remote Access.

    You may also need to specifically allow these ports in your router firewall.

    Monday, July 20, 2009 9:58 AM
    Moderator
  • Thanks for your reply brubber,

    I've read the tech brief and the help files before and run the test suggested there, with no change in behaviour at all.
    So far I've just tried to acess the URL from inside my LAN, so I guess ISPs blocking any ports wouldn't be  problem then, or am I wrong?
    I also don't have proper access with just using http://SERVERNAME/home, etc, which shouldn't be affected by ISP at all, or have I totally misunderstood what ISPs do?

    Sure, I can open the ports in the router, don't think they are blocked in the first place, but I don't really know where to look for blocked ports in my DIR-855 configuration/logs. However, isn't the problem then that since we're using DHCP, the server could very well end up with a new IP-address, which means I need to change the port forwarding setting all over again.

    The thing is that when I bought this server it was super easy to set up, took 10 minutes or so and everything just worked right out of the box. I didn't have to do anything but follow the on-screen instructions from HP in the initial setup. Not a single change in my router was needed, and that was a super dum standard low-range ISP-supplied router. Now, after this system hard drive failure, there's loads of issues to be resolved and I have a top of the range router.

    As you can tell, networks and servers is not my expertise, so I'm very grateful for whatevver help I can get.

    /Donald
    Monday, July 20, 2009 11:05 AM
  • If you only tried from inside your network please also try from the outside if possible; it depends on your routers features and settings if http(s) access from an inside address is properly routed. You're right ISP port blockin is not part of the equation in this scenario.

    If your internal server IP has changed, and you are using DHCP on the server it's likely you may need to set portforwarding again. To check if the ports are properly forwarded you can use Shields Up to check for open ports. You should find port 80 and port 443 open (not 4125, this will only show open when you have remote access to the WHS console or a computer in your network)

    You can check if UPnP is enabled in your router. If not please enable, then let WHS auto configure your router. If this fails you may need to set port forwarding manually. Also please check if there's any firewall settings you need to change in the router. I know this can be a bit of a hassle, problem is no two router are the same, so it's not easy to supply detailed instructions.

    Also top of the range router doesn't mean it's easier to configure. Often the routers have more features (including security / firewall) which make it more difficult to configure for non-standar situations.
    Monday, July 20, 2009 11:38 AM
    Moderator
  • Thanks brubber,

    I have now als tried accessing the server from outside, with exactly the same problem as from inside.
    It looks like everything in the router and from my ISP is in order. I've run the tests from Shiels Up (test results below) and Microsoft (http://go.microsoft.com/fwlink/?LinkId=100267), that from what I understand confirms that port 80 and 443 are open and that my router support UPnP. The microsoft test says "Supported" on all tests including UPnP. Is there something I'm missing?

    What's a bit odd is that when I type in the xxxxx.homeserver.com URL (both from inside and outside our network) and I get the "webpage can't be displayed" message it stops at http://xxxxxxxxx.homeserver.com/home/default.aspx?gotodefault=true which to me indicates that the server responds in some way but then fails to actually bring up the page. So it feels like there's something that's not right internally in the server configuration.

    I've tried to configure the router through the remote access configuration tool in the WHS Console, but it fails in verifying that the remote web site is available locally. What confuses me then is that the Shields Up test and the Microsoft test showed that my router was configured properly. It feels like some web page that should be availabel on the server just isn't.

    I haven't checked the firewall settings and I'm not to keen on setting port forwarding manually, as I'm using DHCP, but the Sheilds Up and Microsoft tests indicate to me that my router isn't the problem here. If the firewal blocked this trafffic, the Shields Up test wouldn't have showed port 80 and 443 as open, I guess. Or maybe I really don't undestand what I'm doing ;-) That is very possible actually.

    Any further thoughts that could help me?

    /Donald

    Shields Up tests
    -----------------------------------
    File Sharing:

    Attempting connection to your computer. . .
    Shields UP! is now attempting to contact the Hidden Internet Server within your PC. It is likely that no one has

    told you that your own personal computer may now be functioning as an Internet Server with neither your

    knowledge nor your permission. And that it may be serving up all or many of your personal files for reading,

    writing, modification and even deletion by anyone, anywhere, on the Internet!
     Your Internet port 139 does not appear to exist!
    One or more ports on this system are operating in FULL STEALTH MODE! Standard Internet behavior requires port

    connection attempts to be answered with a success or refusal response. Therefore, only an attempt to connect to

    a nonexistent computer results in no response of either kind. But YOUR computer has DELIBERATELY CHOSEN NOT TO

    RESPOND (that's very cool!) which represents advanced computer and port stealthing capabilities. A machine

    configured in this fashion is well hardened to Internet NetBIOS attack and intrusion.
     Unable to connect with NetBIOS to your computer.
    All attempts to get any information from your computer have FAILED. (This is very uncommon for a Windows

    networking-based PC.) Relative to vulnerabilities from Windows networking, this computer appears to be VERY

    SECURE since it is NOT exposing ANY of its internal NetBIOS networking protocol over the Internet.

    -------------------

    Common ports:

    GRC Port Authority Report created on UTC: 2009-07-20 at 12:35:44

    Results from scan of ports: 0, 21-23, 25, 79, 80, 110, 113,
                                119, 135, 139, 143, 389, 443, 445,
                                1002, 1024-1030, 1720, 5000

        3 Ports Open
        0 Ports Closed
       23 Ports Stealth
    ---------------------
       26 Ports Tested

    NO PORTS were found to be CLOSED.

    Ports found to be OPEN were: 80, 443, 1026

    Other than what is listed above, all ports are STEALTH.

    TruStealth: FAILED - NOT all tested ports were STEALTH,
                       - NO unsolicited packets were received,
                       - NO Ping reply (ICMP Echo) was received.

    ---------------------

    All ports:

    GRC Port Authority Report created on UTC: 2009-07-20 at 12:39:54

    Results from scan of ports: 0-1055

        3 Ports Open
        0 Ports Closed
     1053 Ports Stealth
    ---------------------
     1056 Ports Tested

    NO PORTS were found to be CLOSED.

    Ports found to be OPEN were: 80, 443, 1026

    Other than what is listed above, all ports are STEALTH.

    TruStealth: FAILED - NOT all tested ports were STEALTH,
                       - NO unsolicited packets were received,
                       - NO Ping reply (ICMP Echo) was received.

    ----------------------------------------------------------------------

    Monday, July 20, 2009 1:43 PM
  • I agree port forwarding is probably OK, and also your webserver (IIS) is running and responsive.

    Basically there's two things you can try:

    A. (Supported) Server reinstall; for server reinstall you should keep all drives connected. If the server reinstall properly detects all disks, and correctly identifies the primary disk a server reinstall should normally preserve all data in shares and the client backup data. You will need to reconfiure users, client computers and redo any other post install modifications (installation of Add ins, custom configuration and so on)

    Potetnial pitfalls with server reinstall:
    1. Server reinstall doesn't correctly identify primary disk, so you will not get server reinstall option (only clean install which will format all disk connected)
    2. SATA disk are not properly recognised (when running in AHCI mode), you may need to supply appropriate 32 bit drivers on a USB thumb drive, once during intial phase of install, then again at the beginning of text mode install using F6 key.

    B. (Not supported) logon to your server desktop, browse to C:\WHS and then execute all files starting with UMRA, then reboot. Please note that anything you do from the server desktop may mess up your server (even further).

    Monday, July 20, 2009 2:33 PM
    Moderator
  • Thanks brubber,

    I'm leaning towards trying option B first. If that fails I can always do option A afterwards, right?

    One question though. Since I've changed ISP and country, is it possible that Windows Live Domains doesn't find my server and that this might be part of the problem? I guess not, as I can access xxxxxxx.homeserver.com/home. However, what's also a bit confusing is that I don't have the Unconfigure option in remote access that I've read other users have. I only have a "Details" and "Configure". Under "Configure" I have the option to Release th current ddomain name or to Choose a different domain name.

    Thanks a lot for your help so far

    /Donald
    Monday, July 20, 2009 2:44 PM
  • I think the Unconfigure option disappeared with one of the updates (I think PowerPack 1), not sure though.

    One other thing you could try is https://yourname.homeserver.com.

    As for option B, that might well be what's hidden behind the Remote Access Repair, if that's true I think your best option is server reinstall. Alternatively you can file a bug on the Windows Home Server Connect site, wait until someone else has a better idea (I may have overlooked the obvious) or again contact your original supplier or HP support (bet they will advise you to do server reinstall using the server recovery disk).
    Monday, July 20, 2009 2:58 PM
    Moderator
  • Did option B and after restarting server and IIS, turning off and on Remote Access I now get the default home page for the server by just typing in xxxxxxx.homeserver.com, compared to before when I needed to type in /home after the URL. Unfortunately, that's where the good news ends and everyting else is as before.

    In the WHS Console/Toolkit section Server connectivity reports that everything is fine (see below report), which is odd as that is clearly not the case. Advanced Connector Troubleshooter now reports two issues, client and server version don't match, as before, and a new issue - 4.8 Check EnrollId 55000 - hint.aspx: Test Timed Out.

    I guess that it's just erver Recovery left to do on the list of things to try, if you haven't thought about something else orsomeone else can com up with a solution. However, I have to wait with doing a server recovery for a couple of weeks for different reasons. For now my WHS just have to act backup and file/printer server.

    Oh, yeh, what happens with my sub-domain if I decide to release my current domain? Can I re-select it later, as a last desperate attempt to get remote access to work?

    Any last thoughts?

    /Donald

    --------------------------------
    Home Server Connectivity report:

    Checking if Remote Desktop Connection is enabled on your home server......
     PASS: Remote Desktop connection is enabled on your Home Server.
    ---------------------------------------------------------
    Checking if Remote Desktop Connection is allowed by Group Policy......
     PASS: Remote Desktop connection is allowed by Group Policy.
    ---------------------------------------------------------
    Checking Windows Firewall settings on your Home Server......
     PASS: Windows Firewall is enabled on your Home Server.
    ---------------------------------------------------------
    Checking if Exception is allowed by Windows Firewall......
     PASS: Exception is allowed by Windows Firewall.
    ---------------------------------------------------------
    Checking if Remote Desktop proxy port is allowed by Windows Firewall......
     PASS: Remote Desktop proxy port is allowed
    ---------------------------------------------------------
    Checking if Remote Desktop is allowed by Windows Firewall......
     PASS: Remote Desktop is allowed by Windows Firewall.
    ---------------------------------------------------------
    Checking Website: "RemoteAccess"
    Checking path: "c:\inetpub\remote"
     PASS: Website RemoteAccess files are ok.
    ---------------------------------------------------------
    Checking Website: "PublicLanding"
    Checking path: "c:\inetpub\home"
     PASS: Website PublicLanding files are ok.
    ---------------------------------------------------------
    Checking Website: "Welcome"
    Checking path: "c:\inetpub\upnp"
     PASS: Website Welcome files are ok.
    ---------------------------------------------------------
     PASS: End checking Windows Home Server website files......


    ---------------------------------------------------------
    Checking IIS service status...
     PASS: IIS service status: Running


    ---------------------------------------------------------
    Checking Windows Home Server App Pool Status......
     PASS: Windows Home Server AppPool is on.
    ---------------------------------------------------------
    Checking default IIS site on your Windows Home Server......
     PASS: Default website is Windows Home Server Site
    ---------------------------------------------------------

    • Edited by donlin Monday, July 20, 2009 4:44 PM Added paragraph on sub-domain
    Monday, July 20, 2009 4:42 PM
  • I have just brought a home server & had exactly the same problem.
    I am running a D-Link DSL Modem & DIR-855 router. The problem was finally solved by turning NAT off on the modem.
    This sorted out the port forwarding issue & I am away!

    Monday, July 27, 2009 8:49 AM