locked
Trying to remove and reinstall ocs 2007....and I need some big time help! RRS feed

  • Question

  •  

    Hello All,

     

    Below is a run down of what I have and what the issue is:

     

    I currently have a server running LCS 2005 standard perfectly fine. I have over 700 users on it.

     

    I HAD a seperate server running OCS 2007 enterprise.

     

    Both servers run Windows 2003 R2 with SP2..

     

    I had installed OCS back when Public Beta 3 was out. When the full version came out I uninstalled it and reinstalled the new version. I ended up having some issues with some phone things I was trying to do and ended up calling Microsodft.

     

    After some review the tech I spoke with suggested that I should remove and reinstall OCS 2007 since it wasnt production. I also noticed that the schema version info in ocs 22007 said the schema was set to Office Communications Server Beta 3 Interim.

     

    So first I removed the server, and then removed the pool. The tech said I had to unprep and then reinstall. Every time I try to unprep I get an error saying a pool still exists. I looked and the pool is referring to my LCS 2005 server!

     

    Also, in one of the logs from a lcscmd /forest /action:checkschemaprepstats it says that I am in Windows 2000 native mode. The tech said I needed to switch to 2003 functional. Since we dont have any Windows 2000 domain controllers I did so....at this point about 3 hours ago. I have rebooted and then ran the command above only for it to say the same thing.

     

    So the questions I have are:

     

    How do upgrade the schema from OCS 2007 Beta 3 Interim to I guess just OCS 2007?

     

    Can I unprep without affecting my LCS server? He suggested doing a force removal but Im scared it will remove my lcs 2005 pool.

     

    Patick

    Wednesday, April 23, 2008 6:11 PM

All replies

  • I haven't done this in awhile, but I believe if you just run forestprep and domainprep again from the OCS RTM setup it will update the schema. 

     

    Before doing a force I would backup a DC/GC and your LCS servers and try this in a lab!

     

    Tuesday, May 6, 2008 12:01 AM
  • I have a similar situation regarding the schema:

     

    I Installed the LCS 2007 Public Beta (which it now states in the schema description), because of problems with the full OCS 2007 Standard server last week I had to deactivate it, unprepped the domain (forced), unprepped the forest (forced) and then performed the installation of the final OCS2007 installation setup files.

    I didn't immediately have a button active to update the schema (I think it was suitable enough for the installer to let me continue), I prepared the forest (button),  prepared the domain (button), activated the server but checking the schema still displays the Public Beta schema. At least in the schema version description.

     

    I would suspect that there is a commandline to run with which you can upgrade the schema from pre-final OCS 2007 to final OCS 2007 version.

     

    For me it doesn't make a difference in functionality (yet! ;-)) so I haven't found a solution yet but if I find something that helps I will post it.

     

    Daniel

    Wednesday, July 2, 2008 2:08 PM
  • So I think that based on my experience described above unprepping and prepping the forest and domain will not automatically solve your schema issue when you're going to reinstall the OCS2007 server(s).

     

    Indeed try it in a lab first if you have that available.

     

    Daniel

     

    Wednesday, July 2, 2008 2:11 PM
  • This blog might help you with finding and cleaning up any OCS-related info in AD.

     

    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=13

    Wednesday, July 2, 2008 3:42 PM
    Moderator