locked
Uninstall OCS 2007 R2 SE RRS feed

  • Question

  • We encountered a problem today. After restarting the server, we have lost the disk drive that we store the database and the logs for OCS, when we tried to re-run the setupee.exe, it started all over again like it's never been run, and it failed of course.

    Then we decided to uninstall/deactivate everything to start from scratch.

    We have deactivated all other services/servers in OCS, the last one is Frond-End server, can't deactivate it at all. Everytime we tried to deactivate it, it reads:

    Server Role: Not assigned.

    Failure [0xC3EC782E] Deactivation didn't succeed completely. Some
    objects may have to be manually removed. Please refer to the Live
    Communications Server documentation for more details.

    Has any1 run into this before? Any input/comment would be very helpful,

    Thanks in advance,
    Friday, October 23, 2009 9:58 PM

Answers

  • I had tried that too, but still.

    Thank you so much for your help LewWI.

    I'll leave this one open for now and will keep you updated when I find a solution for it.
    • Marked as answer by CidNguyen Thursday, October 29, 2009 6:04 PM
    Tuesday, October 27, 2009 8:47 PM

All replies

  • When we removed our pilot environment to rebuild it with the production servers we ran into this issue.

    Did you remove everything from Active Directory yet?

    We had to go into ADSIedit and remove the pool from there.  Jeff Schertz has some good blogs about this here.

    https://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=13
    http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=31



    • Proposed as answer by LewWI Saturday, October 24, 2009 3:45 AM
    Saturday, October 24, 2009 3:44 AM
  • Do you have KB974571 installed on your servers ? If so please un-install the KB and then try again

    There are some know issues with the KB with Activation.

    http://blogs.technet.com/ucspotting/archive/2009/10/15/3287189.aspx

    Monday, October 26, 2009 4:24 AM
  • Hi LewWI,

    Thanks for the response and sorry for the late response.

    I did look that article over but am hesitant to take action with ADSIedit because I am not sure what I am doing. I cannot risk making a slip up as this is the production network and services cannot be interrupted.

    I coudn't deactivate the last Front-end server, uninstall it, would I still be able to do the domainunprep and forestunprep?

    Hi Sri,

    Nope, I don't have the KB974571 installed on our server. I'll keep in mind about this. Thanks


    Monday, October 26, 2009 3:59 PM
  • I tried it without the ADSIedit portion and a fresh install wouldn't work.  Unfortunately, that was the main thing that got it working.

    Monday, October 26, 2009 8:17 PM
  • I've tried to use the ADSIedit and was able to remove all the objects in that list.

    Then I tried to run the domainunprep, it gave me the error that I'm not a Domain admin even though I am in the Domain admin group.

    That's strange. Now I'm stuck at the 2 last steps.
    Tuesday, October 27, 2009 6:52 AM
  • Did you open the command prompt using the "run as administrator" option?

    You can also try the /force option at the end of the command.

    lcscmd.exe /domain:<your domain fqdn> /action:domainunprep /force

    Tuesday, October 27, 2009 2:05 PM
  • Yes, I've tried that, but it still said that I'm not a domain admin. I've even put myself in RTCUniversalServerAdmins group, but no luck.

    I'm wondering about this one: http://img204.imageshack.us/i/unabletodeactivate.jpg/ when I tried to deactivate.

    At the server role, is it supposed to be: Server Role: EE or Server Role: SE? Here it reads: Server Role: Not assigned.

    Tuesday, October 27, 2009 3:42 PM
  • Humor me and put the account you are logged in as in the local admins group for the server.  Not sure what else to try. 

    I wouldn't be concerend over the Server Role being empty at this point since you have partially removed some items.
    Tuesday, October 27, 2009 7:57 PM
  • I had tried that too, but still.

    Thank you so much for your help LewWI.

    I'll leave this one open for now and will keep you updated when I find a solution for it.
    • Marked as answer by CidNguyen Thursday, October 29, 2009 6:04 PM
    Tuesday, October 27, 2009 8:47 PM