Backup of host causes virtual machine to fail RRS feed

  • Question

  • I'm fairly new to WHS and need some help.  I recently purchased an Acer Aspire WHS system -- it came with one 2TB drive and I added a second.  I have a gigabit network (with the exception of one old XP machine which isn't the subject of the problem).  On a Windows 7 system which gets backed up to my WHS, I have a virtual machine installed in VirtualBox which runs an installation of Linux which I use as a MythTV backend system.  It has two virtual hard drives - a relatively small one containing the OS on an internal drive and a large one -- around 700GB (for the recorded TV shows) -- on a partition of an external Raid-5 unit which is attached via an E-sata cable (so it is still treated as a local drive).  Initially, I did not include the partition holding the large virtual drive in my backup because of its size.  At that time, the backups worked just fine.  Recently, I decided that, given that I had almost 3TB of empty space on my server, I might as well backup that large partition as well. The initial backup went fine but the incrementals are disastrous.

    Everytime an incremental backup runs, when it gets to the stage: "Checking which clusters have changed", it takes forever (where forever is approximately 4 hours or so) and during that phase, my virtual machine starts to die.  It isn't a CPU issue -- it is an I7 machine and in task manager it shows that the system-idle process is getting about 95% of the CPU time.  I don't think it is a memory issue -- I'm sure that both processes use a substantial amount of memory (the virtual machine is allocated 2GB) but the machine has 12GB of memory.  the best I can tell is that it is being starved of disk access.  The Linux error log for MythTV shows that it is failing disk writes left and right and the virtual machine log, though I don't really know how to read it, seems to indicate that some activities (I am presuming disk access) are taking very long to complete.  Eventually the VM just grinds to a halt.

    Doesn't the backup connector use volusme-shadow-copy to avoid conflicts with the file system?  It's acting as if it hss the file containing one of the virtual drives (I'm guessing, the big one) locked while it checks for changed clusters though I can't imagine how it would do that since VirtualBox should already have it locked.  Usually, there is nothing recording at the time that the backup runs (though it is possible that the some of the recently recorded files are being searched to mark commercials at that time).

    The time to check for changed clusters seems pretty excessive as well.  Though there would be a fair amount changed on that drive from day to day (old TV shows expired and new ones recorded) I would expect that the total change (presuming that most of the new recordings are using space recently deleted since the disk normally runs at 90+ percent of capacity) I would guess that we're talking about 40-60 GB of changes a day which is, admittedly, a lot, but it isn't taking that much time to do the actual backup -- most of the time is spent deciding what to backup.  It hardly seems like it would take hours to go through and create hashes for the blocks.

    Has anyone else seen anything like this?  I tried searching but didn't really find anything (it was a little difficult to think of search terms that would pin the thing down, but even fairly generic search terms didn't turn up that much).  Does anyone have any idea of how I can fix it?  I suppose I could always go back to not backing up that partition but as a solution, that seems pretty lame -- while it isn't essential to me to backup that data, someday I may have a similar situation involving data I definitely do want backed up.

    Thanks for any help you can offer.

    - Les

    Sunday, March 27, 2011 10:53 AM